Notices
General Electrical & Lighting Related Topics Ask here for electrical, wiring, and lighting info for your rig that could apply to all years

Wiring harness

Old 12-19-2018, 09:25 AM
  #1  
Registered User
Thread Starter
 
NYHumpinUtah's Avatar
 
Join Date: Dec 2017
Location: Enoch Utah
Posts: 726
Received 23 Likes on 22 Posts
Wiring harness

Hi all,
Does anyone have a picture of the wiring harness for a 1984 4wd standard cab pickup that goes from the back up light switch and the 4 wheel drive switch to the engine bay, and what it connects to in the engine bay? Mine is missing and don't know what I will need to get things to work. Right now I have no back up lights and the 4wd light on the cluster don't work, of course they don't there's no harness! What am I missing and what does it look like
If anyone HAS one for sale please let me know.
NYHumpinUtah is offline  
Old 12-22-2018, 06:07 PM
  #2  
Registered User
Thread Starter
 
NYHumpinUtah's Avatar
 
Join Date: Dec 2017
Location: Enoch Utah
Posts: 726
Received 23 Likes on 22 Posts
Interesting find today. While trolling around youtube I found a trany removel video. In the video it showed the wiring for the backup lights and the 4wd switch going up through the cab floor in the hole just above where the shifter plate goes. There is a hole with a rubber grommet and the wires fed through it to go to ( I Believe) the dash board wiring harness. So the wires don't go to the engine bay, they go inside the cab just above the shifter plate and attach somewhere in the dash harness. There are a lot of plugs coming off the dash harness, heater, cig, ac, radio, ect. I'll have to find if I have plugs that maybe the PO didn't hack off.
Comments?
NYHumpinUtah is offline  
Old 01-16-2019, 11:28 AM
  #3  
Registered User
Thread Starter
 
NYHumpinUtah's Avatar
 
Join Date: Dec 2017
Location: Enoch Utah
Posts: 726
Received 23 Likes on 22 Posts
Hi all
Well the weather sucks, cold rainy and snowy so I had some time to do research on my wiring problems. I managed to find the plug in the under the dash board wiring harness that feeds the 4wd and backup light switches. see pics


Now I need the find the harness that goes from this plug to through the cab floor hole just above the shifters to the 4wd switch and the backup light switch.
Anyone?
Then I discovered that I am missing a relay that plugs into the lower left inside the cab fuse block. I'm missing the change lamp relay, there wasn't one in the fuse block. Another reason the charge light didn't work on my gage cluster. The tail light relay is there but it's all rusted so I'll probably look for both while I'm at it. Pics



I'd say a pretty good start for someone who knows ZERO about wiring and schematics.
If anyone has that harness please let me know, even a pic would help me so I can look for it or build one.
Thanks
Hump
NYHumpinUtah is offline  
The following users liked this post:
jazz1 (01-26-2019)
Old 01-16-2019, 10:30 PM
  #4  
Registered User
Thread Starter
 
NYHumpinUtah's Avatar
 
Join Date: Dec 2017
Location: Enoch Utah
Posts: 726
Received 23 Likes on 22 Posts
Bigger picture of the fuse block


See the wires going to where the charge lamp relay should be.
I think once I find the missing wire harness and a charge lamp relay everything will work as it should.
NYHumpinUtah is offline  
Old 01-16-2019, 10:52 PM
  #5  
Registered User
Thread Starter
 
NYHumpinUtah's Avatar
 
Join Date: Dec 2017
Location: Enoch Utah
Posts: 726
Received 23 Likes on 22 Posts
FSM shows it
NYHumpinUtah is offline  
Old 01-17-2019, 10:07 AM
  #6  
Registered User
Thread Starter
 
NYHumpinUtah's Avatar
 
Join Date: Dec 2017
Location: Enoch Utah
Posts: 726
Received 23 Likes on 22 Posts
Update,
Good day
I found a CLR online stateside for $30 shipped.
Found the harness for the backup and 4wd switches, ebay
And I traced all the wires from the CLR in the cab fuse block No breaks!
W-B goes to ground
R goes to my plug for the backup and 4wd I'm assuming for power
Y-B and Y go to a plug that fits in the engine bay fuse block.
At least the PO didn't hack these wires up.............
So much more to figure out but it's keeping me busy with inside work.
NYHumpinUtah is offline  
Old 01-17-2019, 10:19 PM
  #7  
Registered User
 
RAD4Runner's Avatar
 
Join Date: Mar 2012
Posts: 5,903
Received 90 Likes on 74 Posts
Good job, Mike! My comments in green below...
[RAD: Looking at schematic, i do not really thing the CLR is needed. All it does is send Y-B wire to ground when Y (= charge light signal) goes low or close to zeroV. The fix on Marlin Board here is correct. Connect side of diode with stripe to pin with Y wire, and other side of diode to pin wit Y-B wire.]

...W-B goes to ground
[RAD: yes standard wire color]

R goes to my plug for the backup and 4wd I'm assuming for power
[RAD: makes sense. R is 12 Volts supply, only on when IG is on. Supplies Backup Lights. Typical operation:
12V steady on one side of backup light switch. When put in reverse, BUL switch closes, sends 12V to other side of switch, to backup lights.
However, we need to see schematic for 4WD indicator, to verify whether 4WD switch switches power or ground.]


Y-B and Y go to a plug that fits in the engine bay fuse block.
[RAD: Yes. Y goes to one side of Charge light fuse.
Not sure about the Y-B, though, because that's supposed to go to the Charge Light on the dash.
Please verify^^^]


Please also post schematic that shows backup light and 4WD lights, AND pls note on picture which color wires go to the pins on CLR socket = Easier to visualize than words.

[/COLOR]

Last edited by RAD4Runner; 01-17-2019 at 10:39 PM.
RAD4Runner is offline  
Old 01-18-2019, 10:08 AM
  #8  
Registered User
Thread Starter
 
NYHumpinUtah's Avatar
 
Join Date: Dec 2017
Location: Enoch Utah
Posts: 726
Received 23 Likes on 22 Posts
Ray
yes, I also thought that the Y-B should have gone to the gage cluster but it didn't
This is what I have for you
This is the full charging schematic

Next is the backup lights



And this is the 4wd lights


This is my gage cluster



This is where the Y from the CLR goes on the plug for the Engine bay fuse block

And this is where the Y-B goes


Now the wire colors for the CLR Are
Y
Y-B
R
W-B
Did I miss anything?
NYHumpinUtah is offline  
Old 01-18-2019, 10:33 AM
  #9  
Registered User
Thread Starter
 
NYHumpinUtah's Avatar
 
Join Date: Dec 2017
Location: Enoch Utah
Posts: 726
Received 23 Likes on 22 Posts


Yes, it does look like they are connected
NYHumpinUtah is offline  
Old 01-18-2019, 03:44 PM
  #10  
Registered User
Thread Starter
 
NYHumpinUtah's Avatar
 
Join Date: Dec 2017
Location: Enoch Utah
Posts: 726
Received 23 Likes on 22 Posts
Ok, some more info
I was able to find out more:
This is where the wire from pin 28 goes from the dash cluster, (CHG Fuse), same plug for the engine fuse block

And pin 29, (IGN Fuse), goes here

So what I get is that Y-B doesn't go directly from the CLR to the gage cluster it goes to the EFB (engine fuse block) then back to the gage cluster.

Last edited by NYHumpinUtah; 01-18-2019 at 03:54 PM.
NYHumpinUtah is offline  
Old 01-18-2019, 07:47 PM
  #11  
Registered User
 
RAD4Runner's Avatar
 
Join Date: Mar 2012
Posts: 5,903
Received 90 Likes on 74 Posts
Originally Posted by NYHumpinUtah View Post
Ray
yes, I also thought that the Y-B should have gone to the gage cluster but it didn't...
... Now the wire colors for the CLR Are
Y
Y-B
R
W-B
Did I miss anything?
No Y-W wire?
IF your truck was meant to have the CLR:
1)
from one pin of CLR socket, there should be Y-B wire, spliced to Y-W wire then the Y-W would go to pin 28 of gage cluster, to negative sides of TWO diode (one that connects to charge light, and one that connects to brake error light).
2) There should be 2 Y wires going to engine fuse block. One from CLR to one side of charge fuse, the other from alt to the other side of the charge fuse, like this:


There should be TWO yellow wires going to engine fuse block. One on each side of charge fuse. Also need to see continuation of left side of schematic.

BUT...
Originally Posted by NYHumpinUtah View Post
...This is where the wire from pin 28 goes from the dash cluster, (CHG Fuse), same plug for the engine fuse block

So what I get is that Y-B doesn't go directly from the CLR to the gage cluster it goes to the EFB (engine fuse block) then back to the gage cluster.
So you only have Y-B wire from pin 28 of dash to engine compartment fuse block, correct?
Now I have good reason to believe that your truck intentionally did not have the CLR.
The Y wire from the CLR socket to engine fuse block may not even be there or not needed anymore.

Last edited by RAD4Runner; 01-18-2019 at 08:02 PM.
RAD4Runner is offline  
Old 01-18-2019, 09:35 PM
  #12  
Registered User
Thread Starter
 
NYHumpinUtah's Avatar
 
Join Date: Dec 2017
Location: Enoch Utah
Posts: 726
Received 23 Likes on 22 Posts
Ray
The Y wire does go to the charge fuse (goes to the plug and then it goes to the fuse) and the other end of the charge fuse goes to the regulator.

So this picture is correct!


So from the plug in the EFB the Y wire goes to the one contact of the 7.5 charge fuse and the other contact of the fuse goes to the regulator also Y it's just in a different harness, the harness that goes from the EFB around the front of the cab near the radiator and then along the drivers side fender to the regulator where it thens goes to the alternator
So I believe it's correct
Here's the continued section of the schematic


Last edited by NYHumpinUtah; 01-18-2019 at 10:29 PM.
NYHumpinUtah is offline  
Old 01-18-2019, 10:25 PM
  #13  
Registered User
Thread Starter
 
NYHumpinUtah's Avatar
 
Join Date: Dec 2017
Location: Enoch Utah
Posts: 726
Received 23 Likes on 22 Posts
Re cap
So the Y wire and the Y-B wire from the CLR go in the under dash harness to the EFB along with wires from pin 28 and pin 29 of the gage cluster.
Then they all go into a plug, that plug plugs into the EFB, from there the Y wire connects to (inside the fuse block) one side of the 7.5 charge fuse and the other side of the fuse connects to Y that comes out in the another wire harness that goes around the front of the truck then along the drivers side fender then plugs into the regulator and then goes to the alternator.
I think it is wired correctly and I do need to have the CLR
NOTE:
The R wire from the CLR goes to the plug that feeds the backup and 4wd switches, in that plug (3 wires) it has the wire that feeds pin 22 (4wd light) and a wire that feeds the backup lights. The W-B from the CLR goes to ground.
NYHumpinUtah is offline  
Old 01-19-2019, 08:05 AM
  #14  
Registered User
 
RAD4Runner's Avatar
 
Join Date: Mar 2012
Posts: 5,903
Received 90 Likes on 74 Posts
Bottomline:
"L" of alt needs to connect to dash pin 22.

Originally Posted by NYHumpinUtah View Post
Re cap
So the Y wire and the Y-B wire from the CLR go in the under dash harness to the EFB along with wires from pin 28 and pin 29 of the gage cluster...
I think it is wired correctly and I do need to have the CLR....
​Where does the other end of Y-B go?
Need to know how negative​​​​​​ side of diode of Charge light (PIN 28) connects to CLR, OR to pin of charge
fuse opposite where Y wire from Alt connects to.

The "orig" schematic shows CLR to Y-B wire, to Y-W to diode of Charge Light.
R wire's straight forward. It's just power wire.
BTW, schematic has typo There are two pin 22's and missing pin 21. Pin 28 should be where one end of Y-W goes.

Last edited by RAD4Runner; 01-19-2019 at 08:47 AM.
RAD4Runner is offline  
Old 01-19-2019, 08:16 AM
  #15  
Registered User
Thread Starter
 
NYHumpinUtah's Avatar
 
Join Date: Dec 2017
Location: Enoch Utah
Posts: 726
Received 23 Likes on 22 Posts
Ok
Y-B does come out of the CLR and goes to the plug that plugs into the EFB, I will trace where it goes from there.
I don't see the typo?
NYHumpinUtah is offline  
Old 01-19-2019, 08:33 AM
  #16  
Registered User
Thread Starter
 
NYHumpinUtah's Avatar
 
Join Date: Dec 2017
Location: Enoch Utah
Posts: 726
Received 23 Likes on 22 Posts
Ray
Pin 22 is the 4wd pin, I'm confused.
NYHumpinUtah is offline  
Old 01-19-2019, 08:38 AM
  #17  
Registered User
 
RAD4Runner's Avatar
 
Join Date: Mar 2012
Posts: 5,903
Received 90 Likes on 74 Posts
Originally Posted by NYHumpinUtah View Post
Ray
Pin 22 is the 4wd pin, I'm confused.
OOPS SORRY!
I meant PIN 28 (diode of Charge light).
On smart phone so no easy way to refer to picture of schematic.

4WD indicator and Backup lights are straightforward.
Power (R) from fuse, to one side of 4WD switch, other side of switch to a ground somewhere.
Power from fuse, to one side of Backup switch, other side of backup switch to lights positive.

Last edited by RAD4Runner; 01-19-2019 at 08:45 AM.
RAD4Runner is offline  
Old 01-19-2019, 10:15 AM
  #18  
Registered User
Thread Starter
 
NYHumpinUtah's Avatar
 
Join Date: Dec 2017
Location: Enoch Utah
Posts: 726
Received 23 Likes on 22 Posts
Ok so here's what we have
Y-B from CLR to the plug that goes into the EFB Then plugs into the EFB and then the Y-B wire has a jumper wire to a Y with red stripes then out the same plug and Y with red stripes goes to pin 28 of dash cluster.

NYHumpinUtah is offline  
Old 01-19-2019, 11:40 AM
  #19  
Registered User
 
RAD4Runner's Avatar
 
Join Date: Mar 2012
Posts: 5,903
Received 90 Likes on 74 Posts
Originally Posted by NYHumpinUtah View Post
Ok so here's what we have
Y-B from CLR to the plug that goes into the EFB Then plugs into the EFB and then the Y-B wire has a jumper wire to a Y with red stripes then out the same plug and Y with red stripes goes to pin 28 of dash cluster.
And all these wires above are electrically connected?
And they connect to ONE side of the charge fuse?
And there is no yellow wire that connects to the other pin of CLR socket?

Then there should be a Totally Separate wire from the other side of charge fuse to Alt.

Hard to see words. Diagram is better.
Best to erase all the wires on the schematic, and replace with actual wires thay you have traced. Thats how we come up with the wiring diagram. Better done on computer OR paper than on smartphone.

Last edited by RAD4Runner; 01-19-2019 at 11:41 AM.
RAD4Runner is offline  
Old 01-19-2019, 01:21 PM
  #20  
Registered User
 
RAD4Runner's Avatar
 
Join Date: Mar 2012
Posts: 5,903
Received 90 Likes on 74 Posts
Originally Posted by NYHumpinUtah View Post
...
I don't see the typo?
HI Beam and 4WD ind. Pins say 22
RAD4Runner is offline  

Thread Tools
Search this Thread
Quick Reply: Wiring harness


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: