Notices
86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

Temp sensor gauge or sender?

Old 04-17-2019, 04:48 AM
  #1  
Registered User
Thread Starter
 
Join Date: Apr 2019
Location: North Carolina
Posts: 2
Likes: 0
Liked 0 Times in 0 Posts
Temp sensor gauge or sender?

Hello all. First time poster, long time creeper. I have an 87 22re 4runner. I've only driven it 100 miles since it broke down on me and left me in shame of my bad purchase, so this will be my first post of many I'm certain. But first issue I want to address, is how to address OBD Code 4. The temp sensor aft of the coolant hose to the intake has a shotty cable, and since removing it I can see it's in bad shape, so I know this needs to be addressed whether it solves the CEL. I assume it's the temp sensor for the gauge, but I've read people say it's for the AC cutoff. The one I have does not look like photos, perhaps it's even the wrong sensor. I know embarrassingly little about this trucks history. But can anybody confirm what sensor this is, whether cooling sensor, gauge sensor, or even possibly AC cutoff? And have they ever seen one look like this?

Thanks in advance. On a side note, the truck shut off when taken out of 5th on the highway. Supposedly heads were reworked 500 miles ago, along with new water pump and timing chaing, and distributor in last 50. Since then it's started back up 2 out of many cranks and sounds like something is clanging. She'll turn over sluggishly and I can manually turn the crank. Fuel pump works. Researching all I can do and check prior removing valve cover and main block parts and replacing parts that would not be included in long block. Replacing fuel filter and testing compression this week.

coastal is offline  
Old 04-17-2019, 07:29 AM
  #2  
Registered User
iTrader: (-1)
 
Join Date: Dec 2012
Location: Colorado
Posts: 4,206
Likes: 0
Liked 64 Times in 64 Posts
This is not the AC cutoff, you can tell by the round housing and because the wire is coming out if the engine harness.

The AC cut off comes out of the body harness and has an exposed spade connector.

The temp guage sensor is actually located farther back on the intake. Shine a flashlight down beside the cold start injector and you'll see it near the head side.

The sensors for the ECU are located below the radiator inlet hose and face the front of the vehicle.
Co_94_PU is online now  
Old 04-17-2019, 08:11 AM
  #3  
Registered User
Thread Starter
 
Join Date: Apr 2019
Location: North Carolina
Posts: 2
Likes: 0
Liked 0 Times in 0 Posts
Appreciate the reply, that helps to understand what it isn't. From the circle on the engine photo, can you tell me what it is?
coastal is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
TacoWeez
95.5-2004 Tacomas & 96-2002 4Runners
2
04-17-2019 03:09 PM


Thread Tools
Search this Thread
Quick Reply: Temp sensor gauge or sender?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: