99 4runner acceleration issues - YotaTech Forums



95.5-2004 Tacomas & 96-2002 4Runners 4th gen pickups and 3rd gen 4Runners

99 4runner acceleration issues

Reply
 
LinkBack Thread Tools Search this Thread
Old 05-20-2018, 10:51 AM   #1  
Registered User
Thread Starter
 
Join Date: May 2018
Posts: 4
99 4runner acceleration issues

99 4runner 3.4 at slow acceleration no problems. during hard acceleration no power car slows. whats up with this?
Chevy is offline   Reply With Quote
Old 05-20-2018, 10:58 AM   #2  
Registered User
Thread Starter
 
Join Date: May 2018
Posts: 4
power loss

99 4r slow throttle runs fine, hard throttle power loss need help
Chevy is offline   Reply With Quote
Old 05-20-2018, 11:46 AM   #3  
Registered User
 
Join Date: Sep 2007
Location: San Francisco East Bay
Posts: 6,009
I don't know. I know a bit about "86-95 Trucks & 4Runners 2nd/3rd gen pickups," but not about 1999 Tacomas. Maybe you should post in that forum?
scope103 is offline   Reply With Quote
Old 05-20-2018, 02:27 PM   #4  
Registered User
iTrader: (1)
 
wyoming9's Avatar
 
Join Date: Apr 2009
Location: I live in New Tripoli Pa out in the woods
Posts: 12,881
Red face

Ok That is pretty vague Power loss can mean quite a few things .

My first thought electrical system loses all power !

Has the MIL tripped and if so what codes??

Perhaps explain somewhat what happens compared to what you think should happen.

Auto or Manual ??
wyoming9 is offline   Reply With Quote
Old 05-20-2018, 04:19 PM   #5  
Fossilized
Staff
iTrader: (6)
 
dropzone's Avatar
 
Join Date: Oct 2005
Location: PNW
Posts: 18,734
merge similart threads
dropzone is offline   Reply With Quote
Old 05-20-2018, 04:39 PM   #6  
Registered User
 
Join Date: Apr 2016
Location: Alaska
Posts: 781
I'll take a stab at it even though I think you need to give us more to go on.
I had an 01 4runner once that would do similar things when I was on ice or loose surfaces. when I would put my foot in it any wheel losing any traction would cause the traction control to take over.
it would back off the throttle for me and may have even applied brakes (it's been a while)
I cussed that truck out a lot! until I found out that if I hit the center diff lock button on the dash all of that was bypassed.
So, are you having this problem all the time? or is it when you are trying to drive in a foot of mud?
akwheeler is offline   Reply With Quote
Old 06-16-2018, 06:50 PM   #7  
Registered User
 
Join Date: Nov 2017
Posts: 19
Quote:
Originally Posted by Chevy View Post
99 4r slow throttle runs fine, hard throttle power loss need help
injector or air filter mine would rev fine slowly but as soon as I dumped throttle it would drop out, was a bad injector, replaced that and it would rev but cut for a split second, that half was the air filter, 3.4s are finicky as can be
Soumipukuu is online now   Reply With Quote
Old 06-16-2018, 11:07 PM   #8  
Registered User
 
Join Date: Nov 2017
Posts: 313
most likely a fuel pressure regulator issue.
Thommo Thompson is offline   Reply With Quote
Old 06-17-2018, 08:21 AM   #9  
Registered User
 
Join Date: Apr 2016
Location: Alaska
Posts: 781
[QUOTE=akwheeler;52398948]I'll take a stab at it even though I think you need to give us more to go on.
I had an 01 4runner once that would do similar things when I was on ice or loose surfaces. when I would put my foot in it any wheel losing any traction would cause the traction control to take over.
it would back off the throttle for me and may have even applied brakes (it's been a while)
I cussed that truck out a lot! until I found out that if I hit the center diff lock button on the dash all of that was bypassed.
So, are you having this problem all the time? or is it when you are trying to drive in a foot of mud?[/QUOTE]

The original poster hasn't deemed us worthy of any follow up or clues as to what he really means.
akwheeler is offline   Reply With Quote
Old 06-17-2018, 10:03 AM   #10  
Registered User
 
75w90mantraN's Avatar
 
Join Date: Dec 2007
Location: Cali desert, now PNW
Posts: 353
I think it's a troll or a hater...hence the member name of Chevy....

We know better than that.
75w90mantraN is online now   Reply With Quote
Old 07-11-2018, 10:10 PM   #11  
Registered User
 
theriddler33's Avatar
 
Join Date: Jul 2018
Location: Madison, Indiana
Posts: 7
Quote:
Originally Posted by Chevy View Post
99 4r slow throttle runs fine, hard throttle power loss need help
Sounds like my what my weedeater is doing
theriddler33 is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
3.4 Swap 101 dntsdad 3.4 Swaps 51 12-24-2017 10:11 AM
stalling issue on 95 4runner v6 kcoughlan 86-95 Trucks & 4Runners 12 04-03-2017 11:29 AM
Flamethrower Injector Issues?! HELP!!! Brandon Dodson 86-95 Trucks & 4Runners 20 03-31-2017 03:37 PM
This is what my hard work bought me... Get the cable modem ready. Pics... Jason B Off Topic Talk 28 08-22-2005 06:30 PM
4WD Problems dlotoy4runner 95.5-2004 Tacomas & 96-2002 4Runners 7 07-03-2002 03:42 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 05:34 PM.


2017 InternetBrands, Inc.
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: