wipers don't work 98 4runnr - YotaTech Forums

Go Back  YotaTech Forums > Toyota SUV & Truck Tech > Newbie Tech Section
Reload this Page >

wipers don't work 98 4runnr

Notices
Newbie Tech Section Often asked technical questions can be asked here

wipers don't work 98 4runnr

Reply

Old 03-21-2018, 03:58 PM
  #1  
Registered User
Thread Starter
 
Join Date: Mar 2018
Location: Charlotte nc
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy wipers don't work 98 4runnr

my 98 4runner wipers do not work frt or rear, i can pull wiper up windshield turn key on and wipers park.does this mean bad switch ?
lilbare is offline  
Reply With Quote
Old 03-22-2018, 07:27 AM
  #2  
Registered User
iTrader: (1)
 
Join Date: Dec 2011
Location: sammamish, wa.
Posts: 1,826
Thanks: 0
Thanked 2 Times in 2 Posts
Better details please. When you say pull the wipers up. Do you mean rotate them on the windshield? Or pull the up from the windshield like to replace them.

Have you checked the fuses? First place to start. Then you're probably going to need a multimeter to proceed from there. No what to know if an electrical part is bad without testing it first. Might be as simple as a broken wire going to the wiper motor and replacing the switch will just waste your time and money.
thefishguy77 is offline  
Reply With Quote
Old 03-22-2018, 01:27 PM
  #3  
Registered User
Thread Starter
 
Join Date: Mar 2018
Location: Charlotte nc
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
fuses good and wipers park after manual move
lilbare is offline  
Reply With Quote
Old 03-22-2018, 01:28 PM
  #4  
Registered User
Thread Starter
 
Join Date: Mar 2018
Location: Charlotte nc
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
where can i find wiring diagram?
lilbare is offline  
Reply With Quote
Old 03-22-2018, 01:55 PM
  #5  
Registered User
Thread Starter
 
Join Date: Mar 2018
Location: Charlotte nc
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
rotate on windshield 3-4 inches and they go back to 'park' position
lilbare is offline  
Reply With Quote
Old 03-25-2018, 08:53 PM
  #6  
Registered User
iTrader: (1)
 
Join Date: Dec 2011
Location: sammamish, wa.
Posts: 1,826
Thanks: 0
Thanked 2 Times in 2 Posts
thefishguy77 is offline  
Reply With Quote
Old 04-14-2018, 06:49 AM
  #7  
Registered User
Thread Starter
 
Join Date: Mar 2018
Location: Charlotte nc
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
now i have replaced stripped out linkage,motor, switch now fuse was replaced with a circuit breaker. turn on wipers motor move arms 3 inches and stops and does it 3-4 time till breaker overheats.
straight wire runs fine. where would a short be. in harness to rear? washer pump?
any help greatly needed
this wall is getting harder on head
lilbare is offline  
Reply With Quote
Old 04-14-2018, 06:52 AM
  #8  
Registered User
Thread Starter
 
Join Date: Mar 2018
Location: Charlotte nc
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
thanks
lilbare is offline  
Reply With Quote
Old 04-14-2018, 02:46 PM
  #9  
Registered User
 
RAD4Runner's Avatar
 
Join Date: Mar 2012
Posts: 5,429
Thanks: 0
Thanked 18 Times in 18 Posts
How did you verify that fuses and wires are good?
A multi-meter is cheaper than motor and switch. Did you get one and use it as thefishguy suggested^^^
Better english would help, too.

Last edited by RAD4Runner; 04-14-2018 at 02:54 PM.
RAD4Runner is offline  
Reply With Quote
Old 04-14-2018, 07:11 PM
  #10  
Registered User
Thread Starter
 
Join Date: Mar 2018
Location: Charlotte nc
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
found out my rear wiper motor shorted and causing front motor to not work. unplugged rear motor and wipers work now.
if i had only started in the back
i do have a digital meter ,flukes by the dozen
thanks for your help
lilbare
lilbare is offline  
Reply With Quote
Old 04-14-2018, 08:00 PM
  #11  
Registered User
iTrader: (1)
 
Join Date: Dec 2011
Location: sammamish, wa.
Posts: 1,826
Thanks: 0
Thanked 2 Times in 2 Posts
Good find and follow up.
thefishguy77 is offline  
Reply With Quote
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
chicago60647
Newbie Tech Section
6
05-09-2016 11:59 PM
91 yota
86-95 Trucks & 4Runners
4
11-29-2008 11:22 AM
Sandman7
03+ 4Runner/GX470, & 05+ Tacomas
0
07-14-2008 05:12 AM
Granddental
86-95 Trucks & 4Runners
2
04-01-2006 03:48 PM
505taco
95.5-2004 Tacomas & 96-2002 4Runners
4
08-22-2003 12:22 PM


Thread Tools
Search this Thread
Quick Reply: wipers don't work 98 4runnr


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: