94 yota 4x4 cranking issues - YotaTech Forums



86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

94 yota 4x4 cranking issues

Reply
 
LinkBack Thread Tools Search this Thread
Old 07-07-2015, 09:09 AM   #1
Registered User
Thread Starter
 
Join Date: Dec 2012
Posts: 44
94 yota 4x4 cranking issues

It will crank one minute then it may not crank. Yesterday I cranked it drove 6 miles down the road,killed it then it would not crank again until this morning. I thought the fuel pump had gone out until it cranked up this morning.Now I don't have a clue. Yesterday was not the first time to do this,but it has never taken this long to crank back up.It has a full tank of gas.Thanks for any help and I need help. It's about to drive me nuts
redneck17 is offline   Reply With Quote
Old 07-07-2015, 09:43 AM   #2
Registered User
 
Join Date: Aug 2013
Location: Southern Arizona
Posts: 2,390
Won't crank, or won't start??

These words mean different things to most folks.

Crank merely means that the starter will turn the engine over.

Start means that the engine runs.

Which one is your issue??

Last edited by millball; 07-07-2015 at 10:53 AM.
millball is online now   Reply With Quote
Old 07-07-2015, 01:47 PM   #3
Registered User
Thread Starter
 
Join Date: Dec 2012
Posts: 44
Will not start then it might start. It might do fine for a week or two then won't start again. Do yall think it might be a relay of some kind.Ihave had in shops.one shop kept it for two months and it done fine then he went down the road and had to call his wrecker truck. He thought it was the main relay getting hot but changed it snd still does the same
redneck17 is offline   Reply With Quote
Old 07-07-2015, 05:16 PM   #4
Registered User
 
RAD4Runner's Avatar
 
Join Date: Mar 2012
Posts: 4,216
So to be clear:
1) It cranks, meaning the starter turns the engine,
2) But you do not get the VROOM!

Quote:
Originally Posted by redneck17 View Post
Ihave had in shops.one shop kept it for two months and it done fine then he went down the road and had to call his wrecker truck. He thought it was the main relay getting hot but changed it snd still does the same
Don't trust those shops. Many are good at guessing and replacing parts blindly, then charging you, and when problems come back, they keep you money.
Find schematic for your specific truck and figure it out with the help of members here.

Quote:
Do yall think it might be a relay of some kind.
No way to tell unless someone posts a schematic.

Re: Main relay
22RE's do not have a "Main Relay" I wonder if the later models have this?

Last edited by RAD4Runner; 07-07-2015 at 05:18 PM.
RAD4Runner is offline   Reply With Quote
Old 07-08-2015, 07:31 AM   #5
RJR
Registered User
 
Join Date: Jul 2012
Location: Northern Colorado
Posts: 1,459
The closest thing to a "main relay" that a 94 would have is the EFI relay, which powers up the I/O and memory section of the ECU and allows the engine to actually run. As RAD4Runner says, the best way to trouble shoot is with a $15 multimeter and a schematic.

For another $15, you can subscribe to the official toyota tech website for two days and download all of the FSM sections and full-color wiring diagrams for your truck. Although the free online FSM sites have wiring info, they're all in B&W. The full-color ones are much easier to read and find through. Best $15 I ever spent.
The website is here. www.techinfo.toyota.com
RJR is offline   Reply With Quote
Old 07-08-2015, 08:38 AM   #6
Registered User
Thread Starter
 
Join Date: Dec 2012
Posts: 44
Thanks for the website, I will surely download the info.
redneck17 is offline   Reply With Quote
Old 07-09-2015, 09:10 PM   #7
Registered User
Thread Starter
 
Join Date: Dec 2012
Posts: 44
We think we got the problem narrowed down to the MAF sensor. Going to order one tommorrow.
redneck17 is offline   Reply With Quote
Old 07-17-2015, 07:42 PM   #8
Registered User
Thread Starter
 
Join Date: Dec 2012
Posts: 44
The Maf sensor was not the problem so back to the drawing board
redneck17 is offline   Reply With Quote
Old 07-17-2015, 08:44 PM   #9
Registered User
Thread Starter
 
Join Date: Dec 2012
Posts: 44
trying to open the tech.info.toyota.com and it won't open any suggestions
redneck17 is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
87 22r rebuild issue bigjstang 86-95 Trucks & 4Runners 18 07-21-2017 11:31 AM
88 Pickup Transmission Swap mskalmus 86-95 Trucks & 4Runners 9 05-28-2017 08:51 AM
factory A/C wiring MO transplant 86-95 Trucks & 4Runners 8 05-11-2016 04:01 PM
HID Projector Retro 7x6 sealed beam Regency General Electrical & Lighting Related Topics 19 07-15-2015 04:45 PM
ENGINE TROUBLE 3vze please help :( smiley52 86-95 Trucks & 4Runners 8 07-11-2015 06:16 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 06:55 AM.


2017 InternetBrands, Inc. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: