1996 with 2001 engine - YotaTech Forums

Notices
Newbie Tech Section Often asked technical questions can be asked here

1996 with 2001 engine

Reply

Old 07-15-2018, 01:26 PM
  #1  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 15
1996 with 2001 engine

I have a 1996 Tacoma that had a engine failure. I found a low mileage 2001 and have swapped them. After getting wiring harness, engine, etc swapped out (1996 was not fuel injected but 2001 is) it ran a bit rough before complete but it did run. Now that I have finished it wont start, dash lights stay on with the key removed, brake light on cab is on unless I hit the brake pedal. Does anyone have any ideas of what item in the electrical system could be the culprit for these issues? I may have missed a connection or miswired something. Thanks in advance.
Ira
Ira Dean McKitrick is offline  
Reply With Quote
Old 07-15-2018, 01:37 PM
  #2  
Registered User
iTrader: (1)
 
wyoming9's Avatar
 
Join Date: Apr 2009
Location: I live in New Tripoli Pa out in the woods
Posts: 12,948
Red face

Lets start with just what engine you started with ?

Just what engine you installed ?

Your sure it was a 1996 With a Carburetor ?

Is it a 1995 Toyota Pick Up with a 22re instead of a Tacoma ?

You do have the Wiring Diagrams for the Year vehicle the Engine Came from and Your Truck??

Last edited by wyoming9; 07-15-2018 at 01:41 PM.
wyoming9 is online now  
Reply With Quote
Old 07-15-2018, 02:42 PM
  #3  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 15
Yes I'm sure both are Tacomas. Both are 22re engines. 96 carbed 01 injected. 96 manual transmission 01 automatic, kept manual. Yes have both diagrams. Going through all the wiring my next day off but I have an ASE mechanic helping when he can and hes checking it when he can. Just wanting to see if I can save him a trip.
Ira Dean McKitrick is offline  
Reply With Quote
Old 07-15-2018, 04:23 PM
  #4  
Registered User
 
old87yota's Avatar
 
Join Date: Jun 2013
Location: Portland, Oregon, USA
Posts: 1,125


Where are you located?

I am trying to figure out if you have some information wrong or if you live in a different country than me where Toyota did things differently.

There were no new carbureted Toyotas in 1996 or 2001 in the United States and no Tacomas had the 22R-E engine in the United States either. This is why wyoming9 and I are confused.

old87yota is offline  
Reply With Quote
Old 07-15-2018, 04:32 PM
  #5  
Fossilized
Staff
iTrader: (6)
 
dropzone's Avatar
 
Join Date: Oct 2005
Location: PNW
Posts: 18,794
Negative:
if you had a 96 Tacoma with a 22RE somebody did some serious micky mouse crap with the truck and even stupider junk with an 01
in 96 the following were available
in 2WD, the 2.4l 2RZ (fuel injected) and 3.4l 5VZE
in 4WD- the 2.7l 3RZ (fuel injected) and 3.4l 5VZE

in 2001 the same engines would have been around

to verify throw your VIN in this toyota site, it will give you the info for your truck

IP address shows the OP to be in Viginia, unless you are running through a proxy server

there was a 22RE up to 1997 in a Volkwagen badged Toyota truck called the Taro, it would have looked like a 3rd gen 2WD drive (86-95 us market truck)

Please post pics of what you are working on, outside of the truck and the engine compartment

Last edited by dropzone; 07-15-2018 at 04:40 PM.
dropzone is offline  
Reply With Quote
Old 07-15-2018, 05:56 PM
  #6  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 15
I'll get pics when I have more light. Located in WV. If I'm wrong about them being 22re I apologize. They're both the same engine except for being injected.
Ira Dean McKitrick is offline  
Reply With Quote
Old 07-15-2018, 05:59 PM
  #7  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 15
The only rigging I had to do was the reverse lights. Everything else was fine since I took the wiring computer etc from the 01 with the engine (both vehicles on site). There are lights on I expected (Overdrive off and transmission temp lights because it doesn't have the automatic transmission anymore).
Ira Dean McKitrick is offline  
Reply With Quote
Old 07-15-2018, 10:54 PM
  #8  
Registered User
iTrader: (1)
 
wyoming9's Avatar
 
Join Date: Apr 2009
Location: I live in New Tripoli Pa out in the woods
Posts: 12,948
Red face

Please post pictures

At the least going from Carb to EFI you would need to change fuel pumps

This will be interesting for sure
wyoming9 is online now  
Reply With Quote
Old 07-16-2018, 05:59 PM
  #9  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 15
Pics uploaded from cell

96 as it sits. Parts removed for other engine.
Close up of the tag on 96.
Tag on 2001
2001 engine in the 96
Got called in to work. Took these as soon as I got home. I can take more/others if any more questions.
Ira Dean McKitrick is offline  
Reply With Quote
Old 07-16-2018, 11:43 PM
  #10  
Registered User
iTrader: (1)
 
wyoming9's Avatar
 
Join Date: Apr 2009
Location: I live in New Tripoli Pa out in the woods
Posts: 12,948
Red face

Take a picture of the Carburetor .
wyoming9 is online now  
Reply With Quote
Old 07-17-2018, 04:39 AM
  #11  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 15
I will when I get home. I should be off tomorrow and able to work on it some more.
Ira Dean McKitrick is offline  
Reply With Quote
Old 07-17-2018, 05:26 AM
  #12  
Fossilized
Staff
iTrader: (6)
 
dropzone's Avatar
 
Join Date: Oct 2005
Location: PNW
Posts: 18,794
the pic you posted of your 2001 engine indicates you have a 2.7l 3RZ . Wipe the oil off the tag on the engine for the 96 and you might be surprised at what you find...



one big piece of info that would help is if you say if your truck is a 2WD or 4WD

Last edited by dropzone; 07-17-2018 at 05:33 AM.
dropzone is offline  
Reply With Quote
Old 07-17-2018, 09:02 AM
  #13  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 15
I apologize. I will check when I get home and make sure they are the same engine. I'm no mechanic still learning the ins and outs. Both are 4 wheel drive.
Ira Dean McKitrick is offline  
Reply With Quote
Old 07-17-2018, 09:25 PM
  #14  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 15
96 was injected as is the 01. Difference was distributor and coil packs. Sorry all.
Ira Dean McKitrick is offline  
Reply With Quote
Old 07-18-2018, 05:33 AM
  #15  
Registered User
iTrader: (1)
 
wyoming9's Avatar
 
Join Date: Apr 2009
Location: I live in New Tripoli Pa out in the woods
Posts: 12,948
Red face

We are all learning !

Some of us are just lucky to have learned before the Internet .

We will get it figured out
wyoming9 is online now  
Reply With Quote
Old 07-18-2018, 05:40 PM
  #16  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 15
Picked up a new relay for the fuel pump, some sea foam for the gas, getting some gas tomorrow, and a battery booster to make sure it has enough power. Gonna give it a shot and see where I'm at. I know the two lights will stay on but I'm hopeful with enough power they wont be on after the key is removed. Couldn't work on it today at the vet with our puppy. He lost an eye but is in good spirits and acting the same as always.
Ira Dean McKitrick is offline  
Reply With Quote
Old 07-19-2018, 03:13 AM
  #17  
Fossilized
Staff
iTrader: (6)
 
dropzone's Avatar
 
Join Date: Oct 2005
Location: PNW
Posts: 18,794
Sorry to hear about the pup..

Hope the truck works out soon
dropzone is offline  
Reply With Quote
Old 07-19-2018, 09:06 AM
  #18  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 15
Thanks. It isn't the relay, fuel, fuel pump, or battery...going to see if it's even getting fire to the plugs.
Ira Dean McKitrick is offline  
Reply With Quote
Old 07-19-2018, 12:28 PM
  #19  
Registered User
iTrader: (1)
 
wyoming9's Avatar
 
Join Date: Apr 2009
Location: I live in New Tripoli Pa out in the woods
Posts: 12,948
Red face

Are You getting any codes at all ??

Great help to get pointed in the correct direction some times
wyoming9 is online now  
Reply With Quote
Old 07-19-2018, 02:30 PM
  #20  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 15
Ok so no spark or sparking very little on any cylinder. It tried to start with starter fluid but wouldn't stay, sounded like it wanted to start for one or 2 rotations. Took plugs out with coil packs one at a time and had my son crank it to see if any sparked. None did that I saw. Looking at wiring diagrams to see if I can trace back and find something misplugged or unplugged.
Ira Dean McKitrick is offline  
Reply With Quote
Reply
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
KZN185W
95.5-2004 Tacomas & 96-2002 4Runners
5
08-12-2016 10:30 AM
rschmidts
95.5-2004 Tacomas & 96-2002 4Runners
4
03-16-2015 05:51 AM
ger9147
Engine Swaps
2
01-08-2012 04:04 PM
ARB1977
95.5-2004 Tacomas & 96-2002 4Runners
9
12-05-2009 09:26 AM
95_4MuddinSr5
Engine Swaps
1
09-19-2008 07:22 PM


Thread Tools
Search this Thread
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: