Notices
86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

87 4RUNNER wont fire

Old 02-10-2019, 08:14 AM
  #1  
Registered User
Thread Starter
 
Join Date: Oct 2014
Posts: 6
Thanked 0 Times in 0 Posts
87 4RUNNER wont fire

Started having non-firing issue last week. Would crank over great, no fire, also at work. Had towed home. Next morning, cranking over getting slower. Got battery check, dead. Put new battery in, cranking great, still no fire. Prior to new battery, took to work 2 more days no problems firing up. Then again, no fire. Now, new battery, new plugs, fired up normal, idling fine, repeat 3 times, great, that was it! Nooooo. Took to store 1/2mile away, came out, cranking great, wanting to fire but no! Towed back home. Tried slight adjustment to distributor, advance/retard, no change. It wants to fire as it speeds up on cranking. Any help is appreciated, sincerely, Frustrated also it is a 22re

Last edited by dmurrdub; 02-10-2019 at 08:24 AM. Reason: engine
dmurrdub is offline  
Old 02-10-2019, 08:35 AM
  #2  
Registered User
 
87-4runner's Avatar
 
Join Date: Mar 2012
Location: Oklahoma
Posts: 415
Thanks: 0
Thanked 36 Times in 34 Posts
Your saying no fire... you mean it just won't start?
or are you saying you've done some diagnostic and ignition system isn't providing spark/ fire?
87-4runner is offline  
Old 02-10-2019, 08:37 AM
  #3  
Registered User
 
87-4runner's Avatar
 
Join Date: Mar 2012
Location: Oklahoma
Posts: 415
Thanks: 0
Thanked 36 Times in 34 Posts
Love those random issues... it will help the next time it doesn't start... if you can discover if it's lack of spark or fuel...
87-4runner is offline  
Old 02-10-2019, 09:48 AM
  #4  
Registered User
Thread Starter
 
Join Date: Oct 2014
Posts: 6
Thanked 0 Times in 0 Posts
Sorry, it won’t start up now
dmurrdub is offline  
Old 02-10-2019, 10:46 AM
  #5  
Registered User
 
87-4runner's Avatar
 
Join Date: Mar 2012
Location: Oklahoma
Posts: 415
Thanks: 0
Thanked 36 Times in 34 Posts
Originally Posted by dmurrdub View Post
Sorry, it wont start up now
ok... can you tell if it's fuel related or spark related?
87-4runner is offline  
Old 02-10-2019, 08:07 PM
  #6  
Registered User
 
RAD4Runner's Avatar
 
Join Date: Mar 2012
Posts: 5,779
Thanked 50 Times in 44 Posts
Originally Posted by dmurrdub View Post
Sorry, it wont start up now... Frustrated also it is a 22re...
We're also frustrated. You've said "it won't start" enough.
We're asking:
1) if you have fuel and
2) if you have spark
RAD4Runner is offline  
Old 02-21-2019, 09:03 AM
  #7  
Registered User
Thread Starter
 
Join Date: Oct 2014
Posts: 6
Thanked 0 Times in 0 Posts
It now starts, so fuel and spark are there, my dash warning lights stay on for at least 5 mins of running, then go off and rpm’s drop just slightly, 500, shut off, restarts fine with no panel lights, several times. Now what could be causing the lights to come on for a bit?
dmurrdub is offline  
Old 02-21-2019, 10:06 AM
  #8  
Registered User
 
87-4runner's Avatar
 
Join Date: Mar 2012
Location: Oklahoma
Posts: 415
Thanks: 0
Thanked 36 Times in 34 Posts
Bad grounds poor connections
87-4runner is offline  
The Following User Says Thank You to 87-4runner For This Useful Post:
dmurrdub (02-21-2019)
Old 02-21-2019, 10:32 AM
  #9  
Registered User
 
Join Date: Aug 2018
Posts: 182
Thanked 22 Times in 22 Posts
Make sure the alternator is charging. When it is running, test voltage across battery terminals.

Last edited by snippits; 02-21-2019 at 10:33 AM.
snippits is online now  
The Following User Says Thank You to snippits For This Useful Post:
dmurrdub (02-21-2019)
Old 02-21-2019, 11:18 AM
  #10  
Registered User
 
RAD4Runner's Avatar
 
Join Date: Mar 2012
Posts: 5,779
Thanked 50 Times in 44 Posts
Yes, answer all our questions above, do suggestions, get a multi-meter. Then send update.
500 RPM is not slight decrease from normal 750 RPM. It is significant.
RAD4Runner is offline  
Old 02-21-2019, 01:09 PM
  #11  
Registered User
Thread Starter
 
Join Date: Oct 2014
Posts: 6
Thanked 0 Times in 0 Posts
No, sorry it didn’t drop from 750rpm to 500, I was holding it at 1000 and it dropped to 900/950, Wrong wording.
dmurrdub is offline  
Old 02-21-2019, 02:43 PM
  #12  
Registered User
 
RAD4Runner's Avatar
 
Join Date: Mar 2012
Posts: 5,779
Thanked 50 Times in 44 Posts
Our crystal balls are broken.
If you want people thousands of miles away from you to help:
1) Describe problem clearly.
2) Put us AT YOUR VEHICLE. Tell us exactly what you see, hear, feel, smell.
3) Answer our questions.
4) Tell us if you tried what we have suggested you do and what the results were.

Last edited by RAD4Runner; 02-21-2019 at 03:40 PM.
RAD4Runner is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Miller yota
86-95 Trucks & 4Runners
3
06-03-2015 12:00 PM
ktreece
86-95 Trucks & 4Runners
1
08-15-2013 02:48 PM
Thump
86-95 Trucks & 4Runners
38
08-27-2012 09:21 PM
hmmwv15
84-85 Trucks & 4Runners
2
07-29-2008 03:22 PM
rimpainter.com
95.5-2004 Tacomas & 96-2002 4Runners
36
04-04-2003 05:06 PM


Thread Tools
Search this Thread
Quick Reply: 87 4RUNNER wont fire


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: