Notices
86-95 Trucks & 4Runners (Build-Up Section) Post your build-ups here

chuntr's 1988 4runner v6 build

Old 10-03-2010, 10:54 PM
  #1  
Registered User
Thread Starter
 
chuntr's Avatar
 
Join Date: May 2009
Location: Seattle, WA
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
chuntr's 1988 4runner v6 build

I had an 88 pickup for about a year that I really liked, but I was getting tired of not having any secure cargo space and not being able to take any passengers (it was a standard cab). also I'm kinda tall and not being able to move the seat back far enough made driving for long periods pretty uncomfortable.

so I shopped around and found an 88 sr5 v6 4runner with 305k miles on it. for an old and heavily used truck, it was in pretty good condition, and with the exception of a few bulbs in the dash lights, everything worked. cruise control, power locks, the whole bit.

This is what it first looked like the night I got it.



I got it for pretty cheap so I could afford to do some upgrades, and would need to. also figured I wanted something that was more of a project than just something to drive. first off, I put my 31" toyos on it that were on my old truck. they were almost brand new so I wasn't going to give those up when I sold the pickup.
chuntr is offline  
Old 10-03-2010, 11:00 PM
  #2  
Registered User
Thread Starter
 
chuntr's Avatar
 
Join Date: May 2009
Location: Seattle, WA
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
Suspension

the next thing that needed attention was the suspension. the rear was sagging badly and the springs were almost inverted. (what I hadn't realized at the time either, was that someone had already band-aided this by putting 6 inch shackles on the rear leafs, but the springs were so bad the truck still sagged quite a bit, and the ride was pretty harsh too.

I picked up a set of OME Dakar springs and shocks, and some ball-joint spacers and pro-comp long-travel shocks for the front to even out the 2" or so of lift from the Dakars.

so I read a bunch of threads on yotatech and headed to my dad's for the weekend to have him help me out, and to use his driveway since there was currently a 17 foot flatbed trailer occupying mine.

The ball joint spacers and the shocks went on pretty painlessly. took longer than I had expected to grind out the notch in the A-arm for the spacers, but they went in easy.



The rear leafs were a little more tricky. I was surprised not to have any trouble with the shackle bolts, I had heard they are usually frozen up and need to be cut off or have the bushings burned out to get at them (I hadn't figured out these were aftermarket shackles yet and someone had saved me that chore), but getting one of the leafs to seat on the pin on top of the axle took some creativity and some muscle. for a couple of novice to medium skill mechanics all of it front and rear was two whole days of work.

anyway, when it was done, the most obvious thing was the amount of lift in the rear. I was supposed to get 2", but the tailgate to ground measure was a good 9" higher than it had been, and the back end was waaaaayyy jacked up compared to the front.



I factored that some of it was just because the old springs had been sagging so bad. It had probably been drooping 3", plus 2 from the springs, but that still didn't add up. It wasn't until I had been reading around and doing some more research that I noticed that the shackles I had were way bigger than stock, and that was accounting for the extra 2 or so inches of lift I was getting. in the meantime I just decided to live with it.

Last edited by chuntr; 10-03-2010 at 11:38 PM.
chuntr is offline  
Old 10-03-2010, 11:07 PM
  #3  
Registered User
Thread Starter
 
chuntr's Avatar
 
Join Date: May 2009
Location: Seattle, WA
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
Gears

next project was gearing. with the 31s and the limping old 3.0, there wasn't much power at all, and that was on a good day. getting off the line needed enough torque that it was hard to do without killing it, and I've been driving manual transmissions for a long time. I decided to go with 4.88s in case I ever wanted to upgrade to 33s, and I figured the extra bit of torque probably wouldn't hurt me any. this wasn't a race car.

picked up the front diff from craigslist and got the rear from yotatech classifieds. decided to do the rear first so I could get the main benefits right away, knowing I wouldn't have enough time to do the front. as it was it took a while before I could take an entire day to tearing out the old third member.

everything went smooth taking the old 4.11 diff out, besides managing to get brake fluid and gear oil all over myself. I got the new diff in and when I went to bolt it back on to the driveline, I noticed something was wrong. the holes on the companion flanges did not match up at all. I sat around and tried to figure out if I could fab up and adapter with some steel plate and a drill press but nothing would really work right. so I searched online and found this flange from marlin crawler. perfect, though I'd have to wait a few days before I could drive again.

when I pulled the old flange I was careful to count the number of turns so I'd have a ballpark to getting the bearing preload right again. well the new flange is thicker or something because it was stopping hard with another good full turn to go. I wrenched away at it but it wouldn't go any further. it occurred to me then the parts might be different, so I just torqued it to 70 or so ft-lbs. and called it good. I was worried I'd made the bearing preload too high now, but from what other people on these forums have said, 70 ft-lbs. is not even close to the amount of force you need to deform the crush sleeve so I was probably safe.

bolted up the driveline, filled up the diff with gear oil, and then took a spirited drive around the block to try it out. the truck felt great. spedometer was reading noticebly high now (it had read about 5 mph low before, which had cost me a ticket), and there was lots more torque. it was starting to drive like a normal vehicle again.

I got home and looked underneath the truck just to make sure nothing obvious had gone wrong. well, my heart stopped for a second cause the rear axle looked like a crime scene. there was gear oil everywhere, splattered on the spare tire, all over the place. what the hell had happened? I thought the breather was loose at first but it was fine, and so were the drain and fill plugs. closer inspection revealed that the third member has a nickel-sized hole in the top of it, that I just hadn't noticed at all before. did some research and talked to some guys at the dealership and found out that newer third members had an ABS sensor installed in that location. I didn't need that, and a new sensor was $200+ so that was out of the question. I just needed to plug the hole anyway.

yotatech to the rescue again. found out you can get a 1/2" expansion plug and pound it into that spot and it will plug it up perfectly. now I just needed to get to a parts store in my leaky truck so I could get my hands on the plug. well, long story short, it wasn't pretty.



got the plug and spent some time underneath the truck parked on the street outside the store in the rain, but I got it all patched up.

You can also see in that pic I threw on a LSPV bracket to compensate for the 2" lift, so the rear brakes work much better now.

Last edited by chuntr; 10-03-2010 at 11:30 PM. Reason: Gears
chuntr is offline  
Old 10-03-2010, 11:16 PM
  #4  
Registered User
Thread Starter
 
chuntr's Avatar
 
Join Date: May 2009
Location: Seattle, WA
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
More Suspension

at some point I figured out that my leaf spring shackles were much larger than stock, and that they had probably been put on to try and fix the terrible springs that were on it when I bought it. anyway, with a good new set of springs the rear end was sitting much too high. trying to find stock height shackles is a bit of and undertaking. the dealership wanted like $80 *a piece* for them, and aftermarket ones were pretty spendy if you could even find them in the stock length. I'd been trying my hand at some metal fab and welding recently, so I figured I'd try and make a set. I got some 3/8ths steel and an 18mm drill bit and set to it.



had the parts cut up and drilled in a day or so and threw on the new shackles. the ride height certainly was much better now, but what I noticed almost immediately was that the truck was riding way more harsh. every little bump was coming through. it was pretty ridiculous. i upgraded to a set of trail gear greasable bolts since the OME bushings are supposed to have them anyway, but that didn't really help at all. I considered that maybe the springs were just that stiff, and didn't have as much room to flex as they had with the longer shackles, and I would need to pull a leaf from the spring pack to make them act like normal. this didn't seem exactly right though, so I kept looking around online to see what I could find.

eventually I found some people on yotatech who had had similar problems. it turns out that the shackles need to have some mechanism to keep the plates seperated around the spring eye, or else when you torque the shackle bolts to spec, it will bind the shackle to the spring and basically keep the suspension from flexing at all.

I pulled one of the shackles and attempted to weld in a brace, but it was sort of half-hearted, and i think the brace ended up being too short so there wasn't any noticable difference when I had it on there. I'd been getting sick of pulling the shackles on and off by this point and didn't want to keep on with this if it was going to be a bunch of trial and error, so I broke down and got the stock-length OME greaseable shackles. once those were on the truck, the ride was back to normal, (maybe even comfortable) and it was basically sitting level now. anyway, a great example of how trying to "fix" one little thing can lead to a whole slew of other problems.

here's how it's looking now:

chuntr is offline  
Old 10-06-2010, 09:19 PM
  #5  
Registered User
Thread Starter
 
chuntr's Avatar
 
Join Date: May 2009
Location: Seattle, WA
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
finally got a real spare tire on a decent rim. black pro-comp steelie, going to get 4 more to match when I save some cash up. anyway, mounting the larger spare required some re-routing of the tailpipe, which was hitting the springs the way it was anyway.

cut the old tailpipe off, got a couple of exhaust parts to match the right diameters and welded them up.



from the side



also replaced all my dash lights with red LEDs. they look a bit orange in the picture but they are bright bright red. everything but the turn signal and high beam lamps, which I think need a solid-state flasher for them to work with LEDs. got them all from superbrightleds.com



I've got most of the taillights except for the tiny marker replaced with LED bulbs too. my backup lights are nice and bright white now. can actually see what's behind me at night. the front marker/blinkers are a work-in progress, but planning on having those LED converted too.

Last edited by chuntr; 10-06-2010 at 09:27 PM.
chuntr is offline  
Old 11-05-2010, 07:46 PM
  #6  
Registered User
 
Join Date: Oct 2010
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Nice Ride!

Last edited by Randy12345; 11-05-2010 at 07:49 PM.
Randy12345 is offline  
Old 11-23-2010, 07:15 PM
  #7  
Registered User
Thread Starter
 
chuntr's Avatar
 
Join Date: May 2009
Location: Seattle, WA
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
thanks!

Finally got around to installing the new front 4.88 diff with detroit locker a couple weekends ago. heard it was going to snow soon and figured it might be good to have the gears match. the install went pretty smoothly. my gf helped It took us a few hours, most of it spent cracking bolts and scratching our heads trying to figure out how to lift the new one back into place. Zuk's write up on IFS third removal was invaluable. even the FSM is a little thin on how to remove the beast.

and sure enough it snowed here and I'm glad to have the 4WD working again. I've been getting around Seattle's hills with zero problems, while cars and buses have been sliding all over the place.
chuntr is offline  
Old 11-23-2010, 08:51 PM
  #8  
Registered User
 
avenged142's Avatar
 
Join Date: Nov 2010
Location: renton, washington
Posts: 27
Likes: 0
Received 0 Likes on 0 Posts
seattle has been crazy these last 2 days. kent/ranton is bad too. it took me 2 hours to make a 10 minute drive upfrom the valley.

runner looks good though. good thing it was ready for snow!!
avenged142 is offline  
Old 12-20-2010, 09:48 PM
  #9  
Registered User
iTrader: (1)
 
twistedyota's Avatar
 
Join Date: Nov 2008
Location: Napa, CA
Posts: 1,211
Likes: 0
Received 1 Like on 1 Post
dang ur runner looks clean. now i know what mine should look like if i wash it one day
twistedyota is offline  
Old 04-11-2011, 07:51 PM
  #10  
Registered User
Thread Starter
 
chuntr's Avatar
 
Join Date: May 2009
Location: Seattle, WA
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
I've done a few things since my last update here. muffler bit the dust so I welded on a magnaflow. (sounded boss till I got the tailpipe on, heh). got a matching spare a while back. also wired in keyless entry and remote rear window control, which I'll do full write-up of once I get it all ironed out.

also don't think I've mentioned but I had a new engine put in last summer. at 305,000 miles the old one was not doing so great. was leaking oil a lot and sounded like garbage. still ran and got me around though, which there is something to be said for. anyway the new one is doing great except now I have a code 52 knock sensor problem, which I'm finally gonna take care of this weekend hopefully.
chuntr is offline  
Old 04-20-2011, 11:23 PM
  #11  
Registered User
Thread Starter
 
chuntr's Avatar
 
Join Date: May 2009
Location: Seattle, WA
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
Well I did the knock sensor last weekend. what a pain. its 3/4 done anyway. I have to put the intake plenum back on tomorrow and hook everything back up. first time I've torn an engine apart. pretty interesting.
chuntr is offline  
Old 05-14-2011, 06:51 PM
  #12  
Registered User
iTrader: (1)
 
twistedyota's Avatar
 
Join Date: Nov 2008
Location: Napa, CA
Posts: 1,211
Likes: 0
Received 1 Like on 1 Post
get the engine back together?
twistedyota is offline  
Old 05-15-2011, 10:13 AM
  #13  
Registered User
Thread Starter
 
chuntr's Avatar
 
Join Date: May 2009
Location: Seattle, WA
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
yep, everything came back together fine. no more CEL, engine runs noticeably smoother, and my gas mileage has improved.

I did a write-up on replacing the knock sensor/solving my code-52 problems here: http://https://www.yotatech.com/foru...cement-233708/
chuntr is offline  
Old 05-15-2011, 11:27 AM
  #14  
Registered User
iTrader: (1)
 
twistedyota's Avatar
 
Join Date: Nov 2008
Location: Napa, CA
Posts: 1,211
Likes: 0
Received 1 Like on 1 Post
sounds good, what are your next plans to do to it?
twistedyota is offline  
Old 05-15-2011, 12:14 PM
  #15  
Registered User
Thread Starter
 
chuntr's Avatar
 
Join Date: May 2009
Location: Seattle, WA
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
gonna replace a u-joint and then I think that's it as far as mechanical issues. want to get some new wheels, put on a roof rack and a tow hitch and fab up a new front bumper. eventually i'd like to put some new paint on it too.
chuntr is offline  
Old 05-15-2011, 03:57 PM
  #16  
Registered User
 
t3chth1rt33n's Avatar
 
Join Date: Jan 2011
Posts: 35
Likes: 0
Received 0 Likes on 0 Posts
Nice job. The truck looks great. Just a few questions:

How much did you spend on the new engine? And what did you get?

How did you manage to put LEDs in your side markers? Im currently working on that, and I have a plan, I just haven't put it into action yet.

And im really interested in your "remote rear-window control". How did you get that set up?
t3chth1rt33n is offline  
Old 05-16-2011, 08:03 PM
  #17  
Registered User
Thread Starter
 
chuntr's Avatar
 
Join Date: May 2009
Location: Seattle, WA
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by t3chth1rt33n View Post
Nice job. The truck looks great. Just a few questions:

How much did you spend on the new engine? And what did you get?

How did you manage to put LEDs in your side markers? Im currently working on that, and I have a plan, I just haven't put it into action yet.

And im really interested in your "remote rear-window control". How did you get that set up?
new engine cost me around $3500 total. brand new block, clutch, waterpump, a couple other pieces. found the guy off craigslist and wondered why it was so cheap. after he was done I know. not at all professional and kept promising it would be done and then something else would happen to delay it. he quoted me under a week and it was closer to 3 when it was done. the CEL came on within minutes of me driving off despite his mechanics having just said it was running clean with no codes. I'm convinced it was probably him that broke my knock sensor. if anything he should have replaced it anyway. but it runs ok.

the side marker lights are a hack job. one has LEDs and one doesn't. i cut new holes to fit the LED lights so I could wire in the turn signals too but it never worked quite perfectly so I patched it up to be legal. I got a spare set of pristine marker housings so I can take it slow and do them right. also I'll probably have blinkers in my new bumper so I won't have to double up. the 1st gen runner housings have *no* room in them so doing the turn signal or LED mod is hard.

the rear window remote is pretty cool. basically you get a wireless keyfob and receiver with onboard relays (I used this one: http://www.electronickits.com/remote_control/rf4.htm) and hook it up in a plastic enclosure somewhere inside the truck. it needs +12v and ground to power the unit, and then to wire up the relays on the receiver into your stock window control wiring harness.

there are four wires that operate the rear window: up/down from the tailgate and up/down from the console switch. you want to use the ones from the tailgate because they always have power whereas the console switch only has power with the key on. you want to use the fob-activated relays on the receiver to connect the up or down wire to ground, which does the same thing as operating the key switch in the tailgate.

I wired up the power door locks using basically the same idea. you have one wire that locks them when you connect it to ground and one that unlocks when you connect it to ground. the receiver has 4 relays so it works out well to operate both.

I will do a more thorough writeup on this later on, but I fried the stock control board in the process of doing this so I had to wire it up a bit differently on my truck and so the rear wiper does not work now. want to fix that before I start telling other people how to do it.
chuntr is offline  
Old 05-16-2011, 08:35 PM
  #18  
Registered User
 
jason in tn's Avatar
 
Join Date: Aug 2009
Location: hohenwald tn.
Posts: 2,173
Likes: 0
Received 0 Likes on 0 Posts
Nice rig are your rear springs sagging at all after some time to settle?
jason in tn is offline  
Old 05-17-2011, 01:22 PM
  #19  
Registered User
Thread Starter
 
chuntr's Avatar
 
Join Date: May 2009
Location: Seattle, WA
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by jason in tn View Post
Nice rig are your rear springs sagging at all after some time to settle?
nope, not really. I haven't rode or flexed them hard but the back end still sits a little bit higher than the front.
chuntr is offline  
Old 06-24-2011, 06:16 PM
  #20  
Registered User
Thread Starter
 
chuntr's Avatar
 
Join Date: May 2009
Location: Seattle, WA
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
Put some new steelies on the other day

chuntr is offline  

Thread Tools
Search this Thread
Quick Reply: chuntr's 1988 4runner v6 build


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: