Notices
Newbie Tech Section Often asked technical questions can be asked here

Valve Job???

Old 05-17-2019, 01:55 PM
  #1  
Registered User
Thread Starter
 
Join Date: Dec 2017
Location: Volcano, Hawaii
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Valve Job???


the Runner

the culprit

Plenum 1,2,3

Plenum 4,5,6

Right side (passenger)

Left

Lower 4,5,6

Lower 1,2,3
1990 Runner 3.0 3VZE 326,235 on the odometer
Disabled Vet lots of free time,but takes forever to get things done

This is my first post here, I have gotten lots of info from this site. Thank you all. Some of my questions have probably been answered in other ares, and for that I apologise. I will try and be as detailed as possible, and can post pics as soon as I figure that part out. Ok so here goes.....

Swapped 2 wheels (03 sportster) for 4 1990 Runner 3.0. Runner had head gasket replaced looks like MLS gasket with a little separation on the front left(drivers) outside of the head,K&N Air filter setup.... I have since replaced injectors, upper plenum gasket, valve cover gaskets, plugs (NGK), wires, cap and rotor, coil, fuel filter, soon fuel pump, thermostat, rotors, wheel bearings and seals, tie rod ends, end links, starter, misc vacuum hoses, pcv valve, trans filter, added external trans cooler as I do pull a trailer not daily, (less than 1 ton of weight), and I removed a/c compressor, as well as JET VForce thing that was installed as far as I can tell it was worthless. Over the past few months I have noticed that it seemed like the truck would sometimes skip a beat while cruising uphill 55-60 mph, just a little burp and not constantly just once in awhile. while driving last weekend lost power and rattling from engine. Left it at a friends house and had it towed home. Crank no start,by the sound of it cranking seemed like the timing belt broke. Tore it down, found the tensioner pulley broken, belt not broken but frayed on engine side from rubbing. There looks to be excessive build up through the passages from head through plenum in 1,2,3. 4,5,and 6 don't look near as bad, most build up in 4,5 is limited to lower, 6 had some buildup in lower upper looks normal. There is oil in the throttle body, and EGR tube running into plenum is caked.
Am I looking at pulling the heads and doing a valve job? or am I possibly looking at ring blowby?
Like I said before I will try and get pics posted, as soon as I figure that out.Ok I think I have the pics
Mahalo,
Shammah

Last edited by Shammah; 05-17-2019 at 05:41 PM. Reason: Add Pics
Shammah is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
yummybrains
95.5-2004 Tacomas & 96-2002 4Runners
8
03-26-2013 05:07 PM
brian2sun
95.5-2004 Tacomas & 96-2002 4Runners
13
11-14-2011 09:05 AM
FleshThorn
86-95 Trucks & 4Runners
10
04-07-2011 07:31 AM
Uisge Beathe
95.5-2004 Tacomas & 96-2002 4Runners
14
07-26-2009 03:02 PM
kevinkal
86-95 Trucks & 4Runners
4
05-30-2007 05:04 PM


Thread Tools
Search this Thread
Quick Reply: Valve Job???


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: