Notices
86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

89 3.0 No Power until 3,000 RPM

Old 05-02-2019, 09:40 AM
  #1  
Registered User
Thread Starter
 
Join Date: May 2019
Location: Utah
Posts: 3
Received 0 Likes on 0 Posts
Exclamation 89 3.0 No Power until 3,000 RPM

This is my first post, found this forum doing some research.
I recently picked up an 89 3.0 V6 from a friend for a good price, just broke 300K but has been running like a champ.
Until recently it has no power through 1st and 2nd gear and I have to run it up to 3-5K rpms to get it to start moving. No check engine light.
It still drives I'm just ripping through gas though, and it takes a good minute to get up to speed, making 4 ways and merging awkward.
I'm wondering if someone else has had this problem or knows the solution. It has a rough idle when it's cold but that's Toyota.
I'm tempted to take it in and see if a mechanic knows off the bat what's wrong but a common theme on here is dumping tons of cash on a goose chase.
Thinking it's either a timing issue or vacuum leak. Help would be much appreciated.
89 Pace is offline  
Old 05-02-2019, 09:43 AM
  #2  
Registered User
 
87-4runner's Avatar
 
Join Date: Mar 2012
Location: Oklahoma
Posts: 435
Received 43 Likes on 41 Posts
I think your on the right track...
87-4runner is offline  
The following users liked this post:
89 Pace (05-02-2019)
Old 05-02-2019, 01:38 PM
  #3  
Registered User
Thread Starter
 
Join Date: May 2019
Location: Utah
Posts: 3
Received 0 Likes on 0 Posts
Solved

PROBLEM SOLVED
Wasn't a vacuum leak my clutch was blown. Recently hauled a heavy-ish trailer. Just didn't happen gradually. It was probably the original one.
89 Pace is offline  
Old 05-02-2019, 01:48 PM
  #4  
Registered User
 
Join Date: Sep 2007
Location: San Francisco East Bay
Posts: 6,605
Likes: 0
Received 103 Likes on 93 Posts
Didn't you see that in the tach? (The rpms were rising, but the mph was not.)
scope103 is online now  
Old 05-02-2019, 02:01 PM
  #5  
Registered User
Thread Starter
 
Join Date: May 2019
Location: Utah
Posts: 3
Received 0 Likes on 0 Posts
Originally Posted by scope103 View Post
Didn't you see that in the tach? (The rpms were rising, but the mph was not.)
I should of, but I've never had a clutch go out on me before and It never slipped or felt like it was going out. Got home and immediately smelled it and realized. The surge issues matched to timing/vacuum leak and went down that rabbit hole.
89 Pace is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Parttimer
95.5-2004 Tacomas & 96-2002 4Runners
2
11-14-2017 07:50 PM
Jethro540i
95.5-2004 Tacomas & 96-2002 4Runners
2
11-12-2015 06:09 AM
Josh_Br
86-95 Trucks & 4Runners
33
11-12-2014 11:33 AM
805yoda
86-95 Trucks & 4Runners
4
05-13-2013 06:31 PM
eastcoast
86-95 Trucks & 4Runners
11
01-16-2011 04:35 AM


Thread Tools
Search this Thread
Quick Reply: 89 3.0 No Power until 3,000 RPM


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: