My check engine light is on (Code DTC PO171) - YotaTech Forums


Go Back   > >


95.5-2004 Tacomas & 96-2002 4Runners 4th gen pickups and 3rd gen 4Runners

My check engine light is on (Code DTC PO171)

Reply
 
LinkBack Thread Tools Search this Thread
Old 11-11-2005, 12:09 PM   #1
Registered User
Thread Starter
 
Join Date: Sep 2003
Location: Toronto
Posts: 169
My check engine light is on (Code DTC PO171)

A week ago my check engine light came on .I took it to a garage and it came up as Code DTC PO171 .One thing is that my print out says 3.4L motor and I have a 2.7L .Will the reading make a diffence ?


The possible problems according to the print out .

-Air intake hose is loose
-Fuel line pressure
-Injector blockage
-Heated oxygen sensor
-Mass airflow semsor
-Engine collant tempraur(ECT)sensor

I now have 148 000km on the truck .I did a oil change a week before the light turned on .I reset the computer by unplugging the battery for a few hours .The light came on again after a few days .Any ideas ?
pfbmgd is offline   Reply With Quote
Old 11-11-2005, 12:16 PM   #2
Contributing Member
 
colsoncj's Avatar
 
Join Date: Jun 2004
Location: Monett, MO (Springfield)
Posts: 2,644
Does it come on and stay on, or come on and go off.
colsoncj is offline   Reply With Quote
Old 11-11-2005, 12:21 PM   #3
Registered User
Thread Starter
 
Join Date: Sep 2003
Location: Toronto
Posts: 169
It stays on all the time .
pfbmgd is offline   Reply With Quote
Old 11-11-2005, 01:07 PM   #4
Contributing Member
 
WATRD's Avatar
 
Join Date: Oct 2002
Location: Duvall, WA
Posts: 5,089
That's a common code. Clean your MAF and 99% of the time it goes away. It is probably caused by overoiling the K&N filter.

From the FSM for the 2.7

System too Lean (Fuel Trim)
 Air induction system
 Injector blockage
 Mass air flow meter
 Engine coolant temp. sensor
 Fuel pressure
 Gas leakage on exhaust system
 Open or short in heated oxygen sensor (bank 1 sensor 1) circuit
 A/F sensor (bank 1 sensor 1)
ECM

But I will bet you $1.00 that cleaning the MAF makes the problem go away.
WATRD is offline   Reply With Quote
Old 11-11-2005, 01:16 PM   #5
Registered User
Thread Starter
 
Join Date: Sep 2003
Location: Toronto
Posts: 169
Where is the MAS ? How do I clean it ?
pfbmgd is offline   Reply With Quote
Old 11-11-2005, 01:23 PM   #6
Contributing Member
 
WATRD's Avatar
 
Join Date: Oct 2002
Location: Duvall, WA
Posts: 5,089
Just inboard of your airbox.



But, you should read up a bit on the technique for cleaning it. It's VERY fragile and VERY expensive, so you want to handle it like you would your <censored>s. There ar a few write ups around, so familiarize yourself with the process BEFORE you decide if it's something you want to take on.
WATRD is offline   Reply With Quote
Old 11-11-2005, 01:57 PM   #7
Registered User
 
Join Date: May 2002
Location: Los Angeles
Posts: 10,036
Quote:
Originally Posted by pfbmgd
Where is the MAS ? How do I clean it ?
pf,

it's MAF, not MAS. rob's pic and advice is good. depending on your year vehicle, there are several writeup on "cleaning MAF"

bob
Bob_98SR5 is offline   Reply With Quote
Old 11-13-2005, 05:31 AM   #8
Registered User
Thread Starter
 
Join Date: Sep 2003
Location: Toronto
Posts: 169
I cleaned the MAF last night .It did look a bit dirty .i`ll report back in a couple of days if that was the problem .
pfbmgd is offline   Reply With Quote
Old 11-13-2005, 06:22 AM   #9
Registered User
 
cruzin1a's Avatar
 
Join Date: Nov 2004
Posts: 38
I tripped this code by running out of gas. My fuel gauge is currently not working. It would seem that my trailer lights might have shorted a few chips in the dash and maybe the sending unit. However in troubleshooting the code I discovered that running out of gas will trigger this code.
cruzin1a is offline   Reply With Quote
Old 11-13-2005, 05:37 PM   #10
Registered User
 
3.4v6's Avatar
 
Join Date: Jun 2003
Location: Daly City, CA
Posts: 900
pfbmgd
your sig says your running a k&n . my truck kept throwing that code for 2 weeks and i couldnt figure it out ... it was the k&n, and when i put the stock filter back in ... no more code

clean you MAF and swap the filters , it's worth a try

Last edited by 3.4v6; 11-13-2005 at 05:39 PM.
3.4v6 is offline   Reply With Quote
Old 11-13-2005, 07:12 PM   #11
Registered User
Thread Starter
 
Join Date: Sep 2003
Location: Toronto
Posts: 169
I had the filter installed 2 years ago with no codes .I cleaned the MAF and no codes so far .
pfbmgd is offline   Reply With Quote
Old 12-11-2005, 10:40 PM   #12
Registered User
 
cruzin1a's Avatar
 
Join Date: Nov 2004
Posts: 38
Well my code came back so I decided to follow the advice here and clean the MAF. It's been about a week since I cleaned it per the instructions here. I passed the inspection and so far it's not come back on. Hopefully we nailed and thanks for all the great info.
cruzin1a is offline   Reply With Quote
Old 11-02-2007, 02:53 PM   #13
Registered User
 
Join Date: Nov 2007
Posts: 1
I had the same "check engine" light come on when I was going to the Toyota dealership to have my oil changed by co-incidence.

They replaced the engine control computer (#89661-02K41) per Toyota service bulletin.

My car, 2008 Matrix 4 cylnd. If this helps you at all.
danberg is offline   Reply With Quote
Old 07-14-2009, 10:56 AM   #14
Registered User
 
Join Date: Jul 2009
Posts: 3
I went to Advanced Auto Parts and had them check my 99 4Runner with the diagnostic machine because I was getting the check engine light and the Code was PO171 (too lean). I took the advice on cleaning the MAF sensor with the MAF cleaner CRC and it worked. My check engin light went off after two days and my truck is getting better gas mileage and running smoother. thanks for the advice.
hult is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Idle dying/check engine light sonic concepts Newbie Tech Section 0 07-01-2015 02:33 PM
94 toyota pickup will crank but not start rbravo1 86-95 Trucks & 4Runners 4 06-29-2015 01:34 PM
Idle issues Alex Bessinger 86-95 Trucks & 4Runners 4 06-28-2015 10:05 AM
Code 25 problems 94hiluxZE 86-95 Trucks & 4Runners 0 06-22-2015 10:42 AM
Very odd Misfire Mutinebullfrog 86-95 Trucks & 4Runners 1 06-18-2015 01:36 PM


Tags
4runner, air, check, clean, code, dtc, dtcpo171, engine, flow, fuel, lean, mas, po171, trim, z06

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 11:14 AM.


2010 InternetBrands, Inc.