YotaTech Forums  

Go Back   YotaTech Forums > Off Road Tech, Fab Shop, Solid Axle Swaps, Tool Time, & Engine Swaps > Engine Swap Talk > 3.4 Swaps
Sign in using an external account
Register Forgot Password?
Search


3.4 Swaps The 3.4 V6 Toyota engine

Welcome to Yotatech!
Welcome to Yotatech,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
LinkBack Thread Tools Search this Thread
Old 06-24-2010, 07:46 AM   #1 (permalink)
Registered User
Personal Sales Rating: (0)
 
Join Date: Apr 2008
Posts: 528
Reverse light switch

Looks like my reversing lights went out, or more likely never worked after the swap. Anyone have a pic of where the switch is on the auto trannies? The wiring diagram I have says the reverse light switch wires should be red and red/yellow. I dont have those colors in the tranny loom so I need to locate the switch to figure out what the wire colors actually are. Another FSM mistake?
This ad is not displayed to registered members.
Register your free account today and become a member on Yotatech!
UKrunner is offline   Reply With Quote
Old 06-24-2010, 11:34 AM   #2 (permalink)
Registered User
Personal Sales Rating: (0)
 
dntsdad's Avatar
 
Join Date: Jan 2009
Location: Fresno, Ca.
Posts: 1,823
I cant remember exactly and I am not home to check, but something in my brain is telling me the feed for backup light was at the shifter and not the tranny. Now my brain is known to F things up!

I could be wrong but check that. I'll be back Saturday and could check for you then and be sure.

Hope your health is fantastic!!!
__________________
--Jason

1992 Toyota Pickup
Ex-Cab
3.4 swap DONE <-- to lookie
Converted auto harness to manual
R150 manual
Dual cases 2.8/Marlin 4.7's
Marlin MC-07 adapter
Straight Axle Swap COMPLETE!!!
dntsdad is offline   Reply With Quote
Old 06-28-2010, 12:05 PM   #3 (permalink)
Registered User
Personal Sales Rating: (0)
Threadstarter [OP]
 
Join Date: Apr 2008
Posts: 528
Pulled the shifter area off today and did not see a switch for the reversing lights.
UKrunner is offline   Reply With Quote
Old 06-28-2010, 12:19 PM   #4 (permalink)
Registered User
Personal Sales Rating: (0)
 
B4Runner's Avatar
 
Join Date: Oct 2009
Location: Ahwahnee, CA
Posts: 535
Send a message via Yahoo to B4Runner Send a message via Skype™ to B4Runner
Who needs reverse lights? Just wire up lights to a switch for when you need them.
__________________
-Brandon

1988 Toyota 4Runner currently undergoing a 3.4 Swap.

1989 Chevy K1500 Single Cab Long Bed 5-Speed 9" Lift 33"
1986 Toyota AE86 Trueno Coupe
1946 Chevy P/U 12 Volt Rebuilt 216

Quote:
Originally Posted by Slacker View Post
Apparently you're not a "car guy" because no one can "explain it" you just have to "feel" it.
Quote:
Originally Posted by malteserunner View Post
If all goes well, and according to plan, we'll all end up with nice rigs. Now, let's get to work so we can go hit some trails!
B4Runner is offline   Reply With Quote
Old 07-02-2010, 01:34 AM   #5 (permalink)
Registered User
Personal Sales Rating: (1)
 
baja_beetle's Avatar
 
Join Date: Feb 2010
Location: Olympia, Wa
Posts: 96
The reverse light switch is on the passenger side of the transmission.
Now your wiring very well could be totally different colors and positions especially with my IK-2 connector which I couldn't find a wiring diagram for. My vehicles were 2000 Tacoma and 91 4runner for reference. On mine the B-O wire is power to IK2-16 which matches up to switched power IH2-8 also B-O but it says its B-BR.

The signal or return power wire on my harness goes to IK2-2 which is R-B at the harness but at the transmission I think it was a different color. That went to IH2-7 R-W.

Here is the transmission location.
Click the image to open in full size.

And to test the switch put your ohm meter on the two contacts and depress the ball on the switch. And this can be done in or out of the vehicle with switching between reverse and neutral.
Click the image to open in full size.

Hope that helps.
baja_beetle is offline   Reply With Quote
Old 07-02-2010, 05:23 AM   #6 (permalink)
Registered User
Personal Sales Rating: (0)
Threadstarter [OP]
 
Join Date: Apr 2008
Posts: 528
Hey thanks for the info! I did however fix this but forgot to update the thread. Turns out I had not connected either of the wires to the switch. Also, your numbers and colors are correct for a '91 too, fyi.
UKrunner is offline   Reply With Quote
Old 09-02-2011, 04:35 PM   #7 (permalink)
Registered User
Personal Sales Rating: (0)
 
Join Date: Feb 2011
Posts: 28
Except on my 81 its on the driver side for 22r motor
coleman75 is offline   Reply With Quote
Old 10-07-2011, 05:14 PM   #8 (permalink)
Registered User
Personal Sales Rating: (0)
 
DWEINBERG01's Avatar
 
Join Date: Aug 2007
Posts: 319
Quote:
Originally Posted by UKrunner View Post
Hey thanks for the info! I did however fix this but forgot to update the thread. Turns out I had not connected either of the wires to the switch. Also, your numbers and colors are correct for a '91 too, fyi.
Just wondering, since I'm in the same situation, how'd you fix it?
DWEINBERG01 is offline   Reply With Quote
Old 07-14-2013, 08:49 PM   #9 (permalink)
Registered User
Personal Sales Rating: (0)
 
david braun's Avatar
 
Join Date: Nov 2012
Location: Suthern Oregon
Posts: 118
David braun
Yea my reverse lights are not working either, and they are plugged in bulbs good more then likely not hooked back up when the PO did the swap..
After i do a 5 speed swap i'm gonna run aux lights if i cant find out what the problem is.
david braun is offline   Reply With Quote
Old 07-15-2013, 12:33 PM   #10 (permalink)
Registered User
Personal Sales Rating: (3)
 
vasinvictor's Avatar
 
Join Date: Jun 2008
Location: North Central, AR
Posts: 1,373
i quit sounds dirty not even once atari pong toyota
IIRC, it was just 1 wire hookup. Was never a "hangup" in my swap, it was just another simple circuit.

edit: Looks like IH2 7 R-W to II3 19 R-Y from "backup light to backup light switch". Your mileage will vary. Probably just a careless oversight by the PO.
__________________
-Drew

1995 4Runner 4x4 | 3.4 5vz|a340f auto swap | Holset hx35 rear turbo @ 14lb | Transgo 340-HD2 valvebody | Walbro 255 | Coolingmist Autolearn meth injection @ ~22gph | Inchworm Adapter | rf1a case | 4.10 | Lock Right rear | non ADD swap | Aisin hubs | 1.5" BL | 245/75/16 Firestone Destination A/T

Last edited by vasinvictor; 07-15-2013 at 12:35 PM.
vasinvictor is offline   Reply With Quote
Old 07-15-2013, 01:35 PM   #11 (permalink)
Registered User
Personal Sales Rating: (0)
 
david braun's Avatar
 
Join Date: Nov 2012
Location: Suthern Oregon
Posts: 118
David braun
Quote:
Originally Posted by vasinvictor View Post
IIRC, it was just 1 wire hookup. Was never a "hangup" in my swap, it was just another simple circuit.

edit: Looks like IH2 7 R-W to II3 19 R-Y from "backup light to backup light switch". Your mileage will vary. Probably just a careless oversight by the PO.

Thanks i was pretty sure it was 1 or 2 wires its just a matter of tracking them down.
I haven't downloaded the EWD's from Toyota yet but i'm guessing those wires would be part of the body harness spliced into the ecu. the splicing is a rats nest its a wonder it runs.
Thanks for those numbers gives me a place to start.
david braun is offline   Reply With Quote
Old 07-15-2013, 01:35 PM
Yotatech
4WD Truck




Paid Advertisement
Reply

Tags
1997, 34, auxiliary, back, backup, depressed, diagram, fuse, light, lights, location, pickup, reverse, swap, switch, tacoma, toyota

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 07:57 PM.


2010 InternetBrands, Inc.