4runner stalling in gear... Do this again please - YotaTech Forums

Go Back  YotaTech Forums > Toyota SUV & Truck Tech > 95.5-2004 Tacomas & 96-2002 4Runners
Reload this Page >

4runner stalling in gear... Do this again please

Notices
95.5-2004 Tacomas & 96-2002 4Runners 4th gen pickups and 3rd gen 4Runners

4runner stalling in gear... Do this again please

Reply

Old 07-04-2015, 12:31 PM
  #1  
Registered User
Thread Starter
 
Join Date: Jul 2015
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
4runner stalling in gear... Do this again please

I'm aware this problem has been brought up but not properly enough to deem what repair i need. Sorry but here we go.
As a toyota tech (4th yr, so no trans schooling yet ) i realized these days if theres a problem just replace it. If its broke replace it. Im not about to spend 1800 on a trans that i might not need. Like im being told.... I have a 2000 4runner idles great. Code p0770 solenoid e. Pulled it. Tested, failed, replaced it. No more codes. None at all. Still idles good. Put into reverse. Stalls. Skip it quick to neutral idles good. Revs good. Into Drive, stalls. However! If i put it in drive and give it gas it'll chug for first couple feet and take off. Drives good. Can feel it shifting through gears maybe 2,3,4. Not sure only took it around the lot numerous times So 30 ish? Can drop it to second when going slower to keep it running and its ok. Come to a stop and it stalls. Starts right up no problem. In drive brake held and give it gas its stalls out. Torque converter? When I Pulled the pan some usual metal fillings from a tranny with 300,0000 on it. Nothing major. Any thoughts? Thanks
Jnkml is offline  
Reply With Quote
Old 07-05-2015, 12:16 PM
  #2  
Registered User
 
Team420's Avatar
 
Join Date: Feb 2008
Location: the great Maine wilderness
Posts: 2,048
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Jnkml View Post
I'm aware this problem has been brought up but not properly enough to deem what repair i need. Sorry but here we go.
As a toyota tech (4th yr, so no trans schooling yet ) i realized these days if theres a problem just replace it. If its broke replace it. Im not about to spend 1800 on a trans that i might not need. Like im being told.... I have a 2000 4runner idles great. Code p0770 solenoid e. Pulled it. Tested, failed, replaced it. No more codes. None at all. Still idles good. Put into reverse. Stalls. Skip it quick to neutral idles good. Revs good. Into Drive, stalls. However! If i put it in drive and give it gas it'll chug for first couple feet and take off. Drives good. Can feel it shifting through gears maybe 2,3,4. Not sure only took it around the lot numerous times So 30 ish? Can drop it to second when going slower to keep it running and its ok. Come to a stop and it stalls. Starts right up no problem. In drive brake held and give it gas its stalls out. Torque converter? When I Pulled the pan some usual metal fillings from a tranny with 300,0000 on it. Nothing major. Any thoughts? Thanks

Lock up solenoid... The torque converter is not unlocking. All it takes is a tiny piece of lint from a rag to mutter up those solenoids. I have seen them not throw codes, even tho they are not working... usually, if its throwing a code, its a short in the wiring, or the solenoid is not making a connection with the ecu.
Team420 is offline  
Reply With Quote
Old 07-05-2015, 04:20 PM
  #3  
Registered User
Thread Starter
 
Join Date: Jul 2015
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Team420 View Post
Lock up solenoid... The torque converter is not unlocking. All it takes is a tiny piece of lint from a rag to mutter up those solenoids. I have seen them not throw codes, even tho they are not working... usually, if its throwing a code, its a short in the wiring, or the solenoid is not making a connection with the ecu.
Heres the thing. There is only 3. There a shift solenoid no1. Solenoid no.2. And the thing called e shift solenoid SL. Not sure what SL stand for. But where is this solenoid if its not on the valve body?
Jnkml is offline  
Reply With Quote
Old 07-06-2015, 01:20 PM
  #4  
Registered User
 
Team420's Avatar
 
Join Date: Feb 2008
Location: the great Maine wilderness
Posts: 2,048
Thanks: 0
Thanked 0 Times in 0 Posts
I would think its the SL solenoid, but cant remember... been quite a while since I've had to mees with mine...

Might have a read over hear...

https://www.yotatech.com/forums/f166...cement-252389/
Team420 is offline  
Reply With Quote
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
icentropy
86-95 Trucks & 4Runners
17
03-02-2017 12:38 PM
Flying91
86-95 Trucks & 4Runners (Build-Up Section)
39
02-03-2017 05:37 PM
Sleaker
86-95 Trucks & 4Runners
11
03-26-2016 04:12 AM
BeMiceElf
Misc Stuff (Vehicle Related)
7
10-10-2015 09:40 PM
Charecter1
86-95 Trucks & 4Runners
9
07-16-2015 06:40 PM


Thread Tools
Search this Thread
Quick Reply: 4runner stalling in gear... Do this again please


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: