Please Help before I lose my mind! - YotaTech Forums

Go Back  YotaTech Forums > Toyota SUV & Truck Tech > Newbie Tech Section
Reload this Page >

Please Help before I lose my mind!

Notices
Newbie Tech Section Often asked technical questions can be asked here

Please Help before I lose my mind!

Reply

Old 06-24-2015, 04:53 AM
  #1  
Registered User
Thread Starter
 
Join Date: Jun 2015
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Please Help before I lose my mind!

I recently bought a 1988 4runner v6 3.0 4x4 automatic has 3vze motor. It has some serious oil leaks but other than that ran fine during test drive. Drove for a week checking oil everyday, was all good. Went to get in it and checked oil none was showing on the stick. I only had 2 quarts available. I put those in and drove in to maintenance bay at work and had mechanic put more in. Well I guess he didn't check after he put oil in and neither did I before I drove it. I drove home which is about seven miles away. Everything was fine during drive. I didn't get in till about 2 days later and went to start it up. It was hard to start so gave it gas. When it cranked it was missing real bad and as soon as I let off throttle it stalled immediately. I checked oil and it was about 1 1/2" above full line. It needed a tune up anyway so I drained oil to proper level, changed plugs, wires, distributor cap, and rotor. That helped to quick start but still no idle, just stalls. I know from research it is vacuum leak, throttle body, or vane wind meter. I cleaned throttle body, mas and changed gaskets on them using proper torque. I tested hoses with vacuum tester and everything seemed to hold. I could not get vacuum on throttle body or EGR disk? I don't know if was doing it correctly. I also noticed small traces of oil that leaked out from intake manifold gasket. Where should I start now? Would a slight leak from intake manifold cause it to create such a vacuum leak that the engine will not idle? Also don't know proper way to check and see if EGR is stuck in open position? Any ideas would help. I hooked diagnostic machine to it but said vehicle is not responding or cable not connected. It was connected ok so don't know much about that either?


Thanks
James
JF9243176 is offline  
Reply With Quote
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
puddlepirate
84-85 Trucks & 4Runners
2
07-30-2016 06:29 PM
ashamsuddin
General Vehicle Related Topics (Non Year Related)
13
06-18-2016 12:17 AM
Ditch Doc
86-95 Trucks & 4Runners
3
10-27-2015 03:20 PM
Keithstoyota
86-95 Trucks & 4Runners
3
09-27-2015 07:29 AM


Thread Tools
Search this Thread
Quick Reply: Please Help before I lose my mind!


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: