Notices
86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

Power steering whine Please help!!

Old 11-06-2005, 02:01 AM
  #1  
Registered User
Thread Starter
 
Join Date: Aug 2005
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Power steering whine Please help!!

I have a '90 4runner v6 4x4, auto. I have just replaced the power steering pump, and I have a god awfull whine comming from the pump. Not only when I steer but when the brakes are aplied too. whats causing this? Its like I have the wrong fluid in or something. I'm using the factory recomended Dexron III. When I 1st installed the pump it was doing it so I got a exchange for another and still the same thing happens. Anybody have any sudgestion. Its driving me crazy. Thanks
OZONE is offline  
Old 11-06-2005, 06:07 AM
  #2  
Contributing Member
 
SteveO's Avatar
 
Join Date: Oct 2002
Location: NM
Posts: 1,843
Likes: 0
Received 0 Likes on 0 Posts
Did you get all the air out of the system. It takes a while. In the manual there is a method to getting the air out of the system, and making sure you have enough fluid. The only time my PS pump whined is when I didn't have enough fluid. Even now with 37" tires, I don't hear any complaining from the PS pump.
SteveO is offline  
Old 11-06-2005, 07:56 AM
  #3  
Contributing Member
iTrader: (2)
 
4Crawler's Avatar
 
Join Date: Jun 2002
Location: SF Bay Area, CA
Posts: 10,789
Likes: 0
Received 5 Likes on 5 Posts
I use the bleeding instructions here:
- http://howeperformance.com/bleedinginst.html

And likely you have ABS brakes and the ABS actuator is powered off of the power steering pump via lines off of the steering box.
4Crawler is offline  
Old 11-06-2005, 12:25 PM
  #4  
Registered User
Thread Starter
 
Join Date: Aug 2005
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
OK I'll try that, I thought I bleed the system good with the tires off the ground but I didnt do it this way. It looks like I didnt have the right fluid either, so I'll flush that out to. Thanks guys
OZONE is offline  
Old 11-06-2005, 12:42 PM
  #5  
Contributing Member
iTrader: (2)
 
4Crawler's Avatar
 
Join Date: Jun 2002
Location: SF Bay Area, CA
Posts: 10,789
Likes: 0
Received 5 Likes on 5 Posts
For an all-Toyota system, ATF is the proper fluid.
4Crawler is offline  
Old 11-06-2005, 10:27 PM
  #6  
Registered User
Thread Starter
 
Join Date: Aug 2005
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
I'm have valovoline dexron III in right now and Ill try to bleed it out again tommorow. I'll post up my results.
OZONE is offline  
Old 11-07-2005, 10:43 AM
  #7  
Registered User
Thread Starter
 
Join Date: Aug 2005
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Well I went threw the bleeding process again and the fluid looks perfect and no whining. YAY!!! But its at operating tempeture. We see tommorow when its cold how it does. Thanks guys!!!
OZONE is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Zpd426
Newbie Tech Section
4
01-02-2016 01:15 PM
delmert
84-85 Trucks & 4Runners
11
09-30-2015 04:34 PM
Up&Down
95.5-2004 Tacomas & 96-2002 4Runners
4
08-11-2015 10:04 AM
toyoterferdayz
Diesel Swaps
0
07-27-2015 05:25 PM
gmonnie123
86-95 Trucks & 4Runners
2
07-26-2015 02:44 PM


Thread Tools
Search this Thread
Quick Reply: Power steering whine Please help!!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: