Notices
86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

backfiring/hesitation/cuttin out

Old 03-13-2009, 12:36 PM
  #1  
Registered User
Thread Starter
 
bagged94yota's Avatar
 
Join Date: Mar 2009
Location: lenoir, nc
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Exclamation backfiring/hesitation/cuttin out

i have a 94 yota and when i drive it, it backfires and doesn't want to go. i had it in 2nd gear the other day floored and i was only doin 20mph. sometimes it smells rich and it idles really funny. ive already done a new tune up and changed the fuel filter and tried a new maf. could be my valves 2 tight or somethin with fuel? help me out plz.
bagged94yota is offline  
Old 03-15-2009, 08:34 AM
  #2  
Registered User
 
spitfiremkiii's Avatar
 
Join Date: Jun 2008
Location: Columbia MD
Posts: 16
Likes: 0
Received 0 Likes on 0 Posts
Any engine codes?
spitfiremkiii is offline  
Old 03-22-2009, 11:43 AM
  #3  
Registered User
Thread Starter
 
bagged94yota's Avatar
 
Join Date: Mar 2009
Location: lenoir, nc
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
no it don't
bagged94yota is offline  
Old 03-22-2009, 01:45 PM
  #4  
Registered User
iTrader: (2)
 
Robert m's Avatar
 
Join Date: May 2006
Location: Apple Valley, CA
Posts: 1,688
Received 5 Likes on 5 Posts
have you checked your AFM? i had mine go out on me last week and it was doing alot of the same things you have described.
my dads friend who is a mechanic showed me an easy way to check them. just pop open the air box while its idling and use your finger to push open the flapper. the truck should stall out right away. if it doesnt stall and keeps running then something is wrong with it and you should replace it.
Robert m is offline  
Old 03-22-2009, 02:14 PM
  #5  
Registered User
 
ahickman's Avatar
 
Join Date: Jan 2008
Posts: 413
Likes: 0
Received 0 Likes on 0 Posts
Timing is way off? Did you have the distributor out recently?
ahickman is offline  
Old 03-22-2009, 03:57 PM
  #6  
Registered User
 
yodercrawler55's Avatar
 
Join Date: Sep 2008
Location: Lake Tapps, Washington
Posts: 359
Likes: 0
Received 0 Likes on 0 Posts
if its fuel injected it could be injector problems
yodercrawler55 is offline  
Old 04-01-2009, 04:17 PM
  #7  
Registered User
 
Join Date: Aug 2008
Location: Northern Colorado :-(
Posts: 1,758
Likes: 0
Received 0 Likes on 0 Posts
any updates?
DupermanDave is offline  
Old 04-12-2009, 01:25 AM
  #8  
Registered User
 
SurfingDrunk's Avatar
 
Join Date: Sep 2005
Location: AZ, biatches
Posts: 12
Likes: 0
Received 0 Likes on 0 Posts
seafoam!
SurfingDrunk is offline  
Old 04-14-2009, 05:04 PM
  #9  
Registered User
Thread Starter
 
bagged94yota's Avatar
 
Join Date: Mar 2009
Location: lenoir, nc
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
ill check those. how do i tell if my injectors are bad? its not my timin ive set it twice. thanks for the tips if yall think of ne thing else hit me up.
bagged94yota is offline  
Old 04-14-2009, 05:31 PM
  #10  
Registered User
 
abecedarian's Avatar
 
Join Date: Mar 2008
Location: Temecula Valley, CA
Posts: 12,723
Likes: 0
Received 1 Like on 1 Post
pull your trouble codes. if it's running that bad, you've probably thrown at least one
-but based on the 411 above igniter.
abecedarian is offline  
Old 04-14-2009, 08:51 PM
  #11  
Registered User
 
a4runnerfreak's Avatar
 
Join Date: Jul 2008
Location: Grew up in S.C.V, So Cal.....now in Hampstead, NC
Posts: 4,592
Likes: 0
Received 0 Likes on 0 Posts
Maybe 1 or both of the o2 sensors? I don't know if the '94 had 2 or not. Just kind of a thought.
a4runnerfreak is offline  
Old 05-03-2009, 06:03 PM
  #12  
Registered User
Thread Starter
 
bagged94yota's Avatar
 
Join Date: Mar 2009
Location: lenoir, nc
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
well the other day i cranked my truck and it died n i seen smoke comin out of the mafs. it smelled just like gas, ne body kno what that cld b?
bagged94yota is offline  
Old 05-03-2009, 06:43 PM
  #13  
Registered User
 
Lummpus's Avatar
 
Join Date: Apr 2009
Location: Gladstone,Or
Posts: 157
Likes: 0
Received 0 Likes on 0 Posts
you said you recently did a tune up. Are you sure your firing order is correct?
Lummpus is offline  
Old 05-03-2009, 07:54 PM
  #14  
Registered User
 
yzrider273's Avatar
 
Join Date: Apr 2009
Location: El Cajon CA
Posts: 37
Likes: 0
Received 0 Likes on 0 Posts
you might have a vacume leak....in the intake manifold
yzrider273 is offline  
Old 05-03-2009, 07:56 PM
  #15  
Registered User
 
Sin91's Avatar
 
Join Date: Aug 2008
Location: Close to COLDSTONE ICE CREAM
Posts: 65
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by bagged94yota View Post
well the other day i cranked my truck and it died n i seen smoke comin out of the mafs. it smelled just like gas, ne body kno what that cld b?
timng not right or valves
Sin91 is offline  
Old 05-04-2009, 02:54 PM
  #16  
Registered User
Thread Starter
 
bagged94yota's Avatar
 
Join Date: Mar 2009
Location: lenoir, nc
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
the timin is good and i have the firin order right. thanx for the advice if ne body can think of somethin else let me kno its helpin alot
bagged94yota is offline  
Old 05-04-2009, 03:01 PM
  #17  
Registered User
 
1stgen4gunner's Avatar
 
Join Date: May 2008
Location: Connecticut
Posts: 809
Likes: 0
Received 0 Likes on 0 Posts
check to make sure you sparks are plugged into the correct part of the distributor, what I would do is remove you distributor cap and make sure there is no moisture and take all the wires and makes sure they are plugged in correctly.
1stgen4gunner is offline  
Old 01-22-2015, 09:12 AM
  #18  
Registered User
 
Kalihi,HI's Avatar
 
Join Date: May 2014
Posts: 61
Received 1 Like on 1 Post
Aloha from Hawaii. Did you ever figure out your backfire issue? I got a 94 3.0 with a bad backfire (or after fire) when decelerating, it's so loud it sounds like a gunshot...I deleted my cat and just got a new walker sound fx muffler (it's what the truck had when I bought it), but I notice some leaking exhaust in my exhaust pipe (rusted holes) leading up to my muffler. Could this cause the backfire? Thank you for any help.
Kalihi,HI is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: