YotaTech Forums  

Go Back   YotaTech Forums > Toyota SUV & Truck Tech > 95.5-2004 Tacomas & 96-2002 4Runners
Sign in using an external account
Register Forgot Password?
Search


95.5-2004 Tacomas & 96-2002 4Runners 4th gen pickups and 3rd gen 4Runners

Welcome to Yotatech!
Welcome to Yotatech,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
LinkBack Thread Tools Search this Thread
Old 02-28-2008, 10:42 AM   #1
Contributing Member
Personal Sales Rating: (0)
 
jct61765's Avatar
 
Join Date: Jan 2005
Location: Rindge, NH
Posts: 445
Engine hesitates on takeoff

This is something fairly recent. As I am taking off from a stop, there is a hesitation at the beginning of my pushing down the gas pedal. Its only for a second or so. Any ideas?
This ad is not displayed to registered members.
Register your free account today and become a member on Yotatech!
__________________
2002 4runner sport 4X4
124,000 and counting
2007 Camry LE
"
Freedom is never more than one generation away from extinction. We didn't pass it to our children in the bloodstream. It must be fought for, protected, and handed on for them to do the same, or one day we will spend our sunset years telling our children and our children's children what it was once like in the United States where men were free.
Ronald Reagan
40th president of US (1911 - 2004)
jct61765 is offline   Reply With Quote
Old 02-28-2008, 10:45 AM   #2
Registered User
Personal Sales Rating: (0)
 
keithguts's Avatar
 
Join Date: Aug 2006
Location: Bay Shore, NY
Posts: 1,424
Send a message via AIM to keithguts Send a message via MSN to keithguts Send a message via Yahoo to keithguts
What type of rig, engine, etc.
__________________
IF YOU DON'T DRIVE A TOYOTA, TEST DRIVE ONE TODAY!


MY PICS

95 4runner 3.0 auto 4x4

My Rig
My Rig
RangerMan
Enjoy
keithguts is offline   Reply With Quote
Old 02-28-2008, 10:53 AM   #3
Registered User
Personal Sales Rating: (0)
 
pfdaxe's Avatar
 
Join Date: Aug 2002
Location: Phoenix, AZ
Posts: 1,532
Quote:
Originally Posted by keithguts View Post
What type of rig, engine, etc.
I think it's stated in his sig

To be honest, I have the same thing. I'm going to check my MAF and see if it's dirty as well as the TB. Mine still needs some detailed tuning though.
__________________
My 2000 TRD 4 Runner

My email
pfdaxe is offline   Reply With Quote
Old 02-28-2008, 11:18 AM   #4
Registered User
Personal Sales Rating: (0)
 
mkgarrison5's Avatar
 
Join Date: Feb 2007
Location: NC
Posts: 1,511
what kind of maintanence have you had done or done to your 4runner poster?
__________________
02 Tacoma 4-Dr 4x4 V6
117k miles
mkgarrison5 is offline   Reply With Quote
Old 02-28-2008, 12:43 PM   #5
Registered User
Personal Sales Rating: (0)
 
Join Date: Feb 2008
Posts: 155
could be a lot of things. a popular reason is dirty MAF
edzo is offline   Reply With Quote
Old 02-28-2008, 02:42 PM   #6
Registered User
Personal Sales Rating: (0)
 
Jdizzydub's Avatar
 
Join Date: Mar 2006
Location: Lake Stevens, Washington
Posts: 586
Quote:
Originally Posted by edzo View Post
could be a lot of things. a popular reason is dirty MAF
Pulling any codes? Check MAF, clean Throttle body, Check o2's
__________________
97' 4RUNNER SR5 4x4
Lift:OME 881's OME Fronts w/ TOYTEC top out spacer, Billy 5150's and LC Rears
2in. 4crawler BL, SS Diff drop, Custom welded drop bar
Performance:Yellow Top,Custom Dual Vortex Exhaust, Magnaflow Hi-flo CAT, K&N FIPK, Diff Breather Mod
Wheels & Tires:315 16x9's on MOTO METALS

Lights:Silver Reverse Glow Gauges, Hella 500's

Armor:Trailgear Sliders, Taco ARB



"Sounds stupid. . .sign me up!"
Jdizzydub is offline   Reply With Quote
Old 02-28-2008, 04:33 PM   #7
Registered User
Personal Sales Rating: (0)
 
Join Date: Nov 2004
Posts: 196
I have been dealing with this for months now!!!

Its not the MAF or the throttle body...had both of those checked and cleaned and its still doing it.

Mine tends to do it when i am stopped for a bit (30 sec or so) and then press gas and there is a hesitation (for a sec or too) and then it feels like it all of a sudden it gets gas? then it runs fine (idling and acceleration is perfect)

Mine also tends to do it when I am stopped and the wheels are turned to the passenger side?

I am changing the fuel filter next..and we'll see from there?

Its definately a gas pick-up problem of sorts?

-B
BADLNDS is offline   Reply With Quote
Old 02-28-2008, 06:35 PM   #8
Registered User
Personal Sales Rating: (0)
 
Join Date: Dec 2007
Location: Camino, Ca
Posts: 1,159
Does it have a fly by wire throttle? I have dealt with a couple that have had problems with the throttle motors going bad. It will get to a point when you jam on the gas, it will just fall on its face and not go. Get that checked out soon!
__________________
02 Tundra Limited TRD, Bilstien adjustable coilovers, Camburg UCA's up front w/1.5in block and 1500lb hellwig overloads in rear, Procomp 16x8 alloys with 285/75/16 Goodyear DuraTrac's, DDM tuning 5000K HID's, Bank's catback exhaust
toytech76 is offline   Reply With Quote
Old 02-28-2008, 06:41 PM   #9
Registered User
Personal Sales Rating: (0)
 
jason191918's Avatar
 
Join Date: Oct 2007
Location: Hopkins, MN
Posts: 1,520
jason freudigmann
Send a message via ICQ to jason191918 Send a message via AIM to jason191918 Send a message via MSN to jason191918 Send a message via Yahoo to jason191918
Mine used to hesitate like turbo lag, then take off like a bat out of hell. The EGR was sticking...
__________________
JASON

1992 Pickup V6, 4x4, 5 speed, SR5, 300,000 miles young, every option except automatic tranny

31x10.5R15 | K&N FIPK | Cherry Bomb | 3" BL | 4 110W KC Light Bar | 6'6" Western Plow | 800W 10" Sony | 850W Sound Storm | 2 4" Obcon | 4 1" Rockford Fosgate Tweeters | 2 High Pass Crossovers | 2 High-Low Pass Crossovers | 2 6.5" Rockford Fosgate | Pioneer 4x50W Head Unit | Mechanical Oil Pressure Gage | Lack of EGR | Blinker Mod

Quote:
Originally Posted by Elvota View Post

Jason is right.
Quote:
Originally Posted by fishon1213 View Post
Jason rocks!!! :banger:
jason191918 is offline   Reply With Quote
Old 02-29-2008, 01:54 PM   #10
Contributing Member
Personal Sales Rating: (0)
Threadstarter [OP]
 
jct61765's Avatar
 
Join Date: Jan 2005
Location: Rindge, NH
Posts: 445
The only thing I have done is the airbox mod. I guess eventually I will be checking my egr and MAF. Unfortunately we have so much white sh** on the ground it is impossible to do anything to my truck. Aside from brushing off the white sh**. We have another 5 to 12 coming tonight too. thanks for the answers.
__________________
2002 4runner sport 4X4
124,000 and counting
2007 Camry LE
"
Freedom is never more than one generation away from extinction. We didn't pass it to our children in the bloodstream. It must be fought for, protected, and handed on for them to do the same, or one day we will spend our sunset years telling our children and our children's children what it was once like in the United States where men were free.
Ronald Reagan
40th president of US (1911 - 2004)

Last edited by jct61765; 02-29-2008 at 04:01 PM.
jct61765 is offline   Reply With Quote
Old 02-29-2008, 02:03 PM   #11
Registered User
Personal Sales Rating: (0)
 
mjwalfredo's Avatar
 
Join Date: Dec 2005
Location: Columbia, SC
Posts: 702
Send a message via AIM to mjwalfredo
I had my fuel injectors cleaned ultrasonically. It helped a lot with the initial throttle response on my 97 with 210k mi.
__________________
-Mark
1997 4Runner Limited 4x4, E-Locker, OME 880/906, Deckplate Mod, TJM T-15 (no winch yet), 265/70/16R Bridgestones
mjwalfredo is offline   Reply With Quote
Old 02-29-2008, 02:03 PM
Yotatech
4WD Truck




Paid Advertisement
Reply

Tags
02, 1996, 1997, 4runner, 90, 99, engine, gas, hesitates, hesitation, pedal, pushing, stop, takeoff, taking

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine hesitates under boost, but AFR is fine? mastacox 95.5-2004 Tacomas & 96-2002 4Runners 5 08-07-2007 10:32 AM
F35-JSF Takeoff and Vertical landing PirateFins Off Topic Talk 10 05-11-2006 07:52 AM
new owner/engine hesitates?? boz Maintenance & Repair Archives 0 09-13-2002 02:43 PM


All times are GMT -8. The time now is 09:10 PM.


2010 InternetBrands, Inc.