YotaTech Forums  

Go Back   YotaTech Forums > Toyota SUV & Truck Tech > 86-95 Trucks & 4Runners
Sign in using an external account
Register Forgot Password?
Search


86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

Welcome to Yotatech!
Welcome to Yotatech,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
LinkBack Thread Tools Search this Thread
Old 04-24-2011, 09:24 AM   #1
Registered User
Personal Sales Rating: (0)
 
Join Date: Jan 2011
Posts: 51
battery light comes off and on

got a 89 toyota with the 22re, i just noticed yesterday that my battery and brake light keep coming on. I researched and found out that this indicates that the battery is not charging most likely due to a bad alternator, but the truck starts like normal and everything works like normal and sometimes it doesnt come on at all, and sometimes it will come on when first started and when you hit the gas it will go away then come back on, and sometimes it will stay off after mashing the gas, other times it just stays on. lol. i cleaned my battery terminals and had no luck fixing it. is there anything else i can do?
This ad is not displayed to registered members.
Register your free account today and become a member on Yotatech!
ford97 is offline   Reply With Quote
Old 04-24-2011, 09:25 AM   #2
Registered User
Personal Sales Rating: (0)
Threadstarter [OP]
 
Join Date: Jan 2011
Posts: 51
happy easter!!
ford97 is offline   Reply With Quote
Old 04-24-2011, 10:08 AM   #3
Registered User
Personal Sales Rating: (0)
 
stctech74's Avatar
 
Join Date: Apr 2011
Location: Quitman, TX
Posts: 3
check the 3 wire plug at back of alternator wires get bare & the plug terminals get worn
stctech74 is offline   Reply With Quote
Old 04-24-2011, 11:22 AM   #4
Contributing Member
Personal Sales Rating: (0)
 
wyoming9's Avatar
 
Join Date: Apr 2009
Location: I live in New Tripoli Pa out in the woods
Posts: 6,269
Red face

Sounds like you have a loose belt maybe.

I would also look at your grounds something is loose some place!!

It seems the battery is able to charge those times when the light is off
wyoming9 is offline   Reply With Quote
Old 04-24-2011, 12:09 PM   #5
Registered User
Personal Sales Rating: (0)
Threadstarter [OP]
 
Join Date: Jan 2011
Posts: 51
the belt was tight and all connections looked good. i checked the alternator and it seems its not charging the battery very good, i think its going bad, i already pulled it so im just gonna replace it and go from there. im pretty sure its the alternator though. thanks for the suggestions.
ford97 is offline   Reply With Quote
Old 04-24-2011, 02:08 PM   #6
Registered User
Personal Sales Rating: (0)
Threadstarter [OP]
 
Join Date: Jan 2011
Posts: 51
well i got the alternator checked at autozone and it passed twice. maybe i should just put it back on and double check that the belt is tight and all connections are in good shape. what would you guys do? how good is the alternator machine at auto zone?
ford97 is offline   Reply With Quote
Old 04-24-2011, 04:05 PM   #7
Registered User
Personal Sales Rating: (0)
 
andrewflores17's Avatar
 
Join Date: Nov 2010
Location: colorado springs ,co
Posts: 149
prometheusaj
just gona start off and say yes i know this isnt a silverado 1990

had the same thing on my old silverado what happend is that the battery wasnt properly gorunded so it would cause the light to blink on and off all time just added some xtra ground wire check that out could help anyway my 2 cents
andrewflores17 is offline   Reply With Quote
Old 04-24-2011, 04:12 PM   #8
Registered User
Personal Sales Rating: (0)
 
Bad_Bowtie_ssz71's Avatar
 
Join Date: Sep 2004
Location: East TN
Posts: 49
sucks
Send a message via Yahoo to Bad_Bowtie_ssz71
Put a multi-meter on it and see what kinda volts you are getting while its running. My 84 flashes intermitantly but always shows its putten out 14.3-14.6.Which is what you want. I can hit brakes, put it in reverse or turn on the heater fan and charge/brake lights go out. Thinck mine is just a ground problem. Sounds like yours probaly is as well or a bad connection.
__________________
2007 Tacoma Access Cab 4x4 SR5
TRD Sport wheels/ BFG AT's

1984 X-cab 4X4
3" lift 33 TSL's
5.29's and Aussies F&R

88 4Runner
22RE/w56

Last edited by Bad_Bowtie_ssz71; 04-24-2011 at 04:27 PM.
Bad_Bowtie_ssz71 is offline   Reply With Quote
Old 04-25-2011, 04:57 AM   #9
Registered User
Personal Sales Rating: (0)
 
spokane.yota.man's Avatar
 
Join Date: Apr 2008
Location: Spokane, WA
Posts: 238
Make sure you don't have an adapter between the alt and harness. It's a little brown plug thing that rebuilders sometimes use to cover cracked plug housings. I had one of those cause me the flashing light problems. Check the whole alt harness too, its right by the ex. Manifold so could be damaged.
spokane.yota.man is offline   Reply With Quote
Old 04-28-2011, 03:20 PM   #10
Registered User
Personal Sales Rating: (0)
 
Join Date: Jan 2007
Location: Newark, Ca
Posts: 6
I recently had this very problem in my '87 4Runner with 22RE. Turned out to be the alternator brushes. It checked good on the tester several times, but the brushes were just about at their limit. Cost $5 for brushes.
GreyBeard2 is offline   Reply With Quote
Old 04-28-2011, 07:26 PM   #11
Registered User
Personal Sales Rating: (0)
Threadstarter [OP]
 
Join Date: Jan 2011
Posts: 51
yea i changed my alternator and it fixed the problem!!!! now when i was putting it in i somehow knocked a hole in my radiator!!!! I could probrobly fix it but it already has a few other little leaks and i think im just gonna replace it. what kind of radiator do i need that is reasonably priced? advanced has a one row radiator that will work for $80. will one row cut it in this hot georgia weather?
ford97 is offline   Reply With Quote
Old 04-28-2011, 09:28 PM   #12
Registered User
Personal Sales Rating: (0)
 
anthony1's Avatar
 
Join Date: Oct 2003
Location: torrance, CA.
Posts: 1,525
Send a message via AIM to anthony1 Send a message via Yahoo to anthony1
Get a 3 row radiator. You can even wheel with AC on....
__________________
http://www.angelfire.com/ca6/954runner
GOD's Country Best Seen In A 4 Runner. SAS'd front: ARB,Marlin arms, rear: cable elock,APlinks,OEmu860,35MT/R 5spd, 4:1, 5.29.
..."But officer, that was not an illegal turn, it was just an undocumented turn."
anthony1 is offline   Reply With Quote
Old 04-28-2011, 09:28 PM
Yotatech
4WD Truck




Paid Advertisement
Reply

Tags
1990, 82, alternator, battery, brake, brakes, charge, charging, gas, hit, light, press, silverado, toyota, truck

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 11:54 AM.


2010 InternetBrands, Inc.