Rear O2 Sensor Help - YotaTech Forums



Newbie Tech Section Often asked technical questions can be asked here

Rear O2 Sensor Help

Reply
 
LinkBack Thread Tools Search this Thread
Old 10-03-2017, 09:18 PM   #1
Registered User
Thread Starter
 
Join Date: Oct 2017
Location: Corona CA
Posts: 4
Rear O2 Sensor Help

Just found this forum its pretty good. I think I will stick around. Anyway onto my question. I just got a 89 pickup 2WD with a 22RE and manual trans from my friend. When I got it there were multiple codes and I have fixed all of them except for one Code 27 Rear O2 sensor. I was told it had new O2 sensors when I got it and by the looks of them they are fairly fresh. The rear O2 was hardlined in and according to my wiring schematics it was wrong. I wired it what should be correctly and I'm still getting the code.

Here's how it was wired when I got it. Sensor wires listed first, harness wires second:
Blue - Black shielded white wire
White - Brown
Black - White/Red stripe
Black - Red/Green stripe

Here is how the engineer in me feels it should be wired:
Black - Brown
Black - White/Red stripe
White - Black shielded white wire
Blue - Red/Green stripe

On the sensor I know both black wires are too the heater, blue is signal, white is ground.

Did I screw up and the blue signal should go to the white double shielded wire or does anyone think the new sensor could be fried from being hooked up wrong? I checked the heater circuit on the sensor and it ohm's out good.
SunSetPrez is offline   Reply With Quote
Old 10-05-2017, 10:22 PM   #2
Registered User
Thread Starter
 
Join Date: Oct 2017
Location: Corona CA
Posts: 4
If anyone looks at this I was typing this incorrectly. I got it wired the second way. I just went and wired it as follows:
Black - red/green
Black - White/Red
White - Brown
Blue - Black shielded white

This is the correct way. Sorry for my terrible initial post. It was late and I was tired
SunSetPrez is offline   Reply With Quote
Old 10-06-2017, 12:40 AM   #3
Registered User
iTrader: (1)
 
wyoming9's Avatar
 
Join Date: Apr 2009
Location: I live in New Tripoli Pa out in the woods
Posts: 12,330
Red face

The problem with these Trucks is one never knows what might have been done .

People do all sorts of wiring improvements that make no sense at times
wyoming9 is online now   Reply With Quote
Old 10-06-2017, 02:03 PM   #4
Registered User
Thread Starter
 
Join Date: Oct 2017
Location: Corona CA
Posts: 4
I agree. I'm just a bit embarrassed about my first post. That will teach me to post while tired. Got it all fixed now and repaired all 7 codes I got the truck with. This weekend I will take it for a test drive.
SunSetPrez is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 08:56 AM.


2017 InternetBrands, Inc. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: