no power when warm - YotaTech Forums

Notices
86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

no power when warm

Reply

Old 11-27-2007, 05:35 PM
  #1  
Registered User
Thread Starter
 
gametom's Avatar
 
Join Date: Sep 2006
Location: Manhattan IL
Posts: 476
Thanks: 0
Thanked 0 Times in 0 Posts
no power when warm

i hate to star another thread but i need to get this solved. i have a 91 runner with a 22re, and when my truck is cold it runs great but after about 4 min or so of driving i have no power the only i can accelerate is with the pedal to the floor. i can even hold 50 in 5th on flat ground unless i have the pedal on the floor. i think it ether the o2 or the coolant temp sensors but i dont' want to just throw parts at it any thing else i should check? this is what's been done recently new plugs, wires, fuel filter, cone air filter, new exaugst, new clutch, cleaned and tested injectors, the timing is at 7-8 BTDC timeing chane has maybe 50k on it.

Thanks
-Tom
gametom is offline  
Reply With Quote
Old 11-28-2007, 10:28 AM
  #2  
Registered User
Thread Starter
 
gametom's Avatar
 
Join Date: Sep 2006
Location: Manhattan IL
Posts: 476
Thanks: 0
Thanked 0 Times in 0 Posts
i had a chance to drive it longer last night and noticed after about 20-30 min of driving it runs good again any thoughts
cold good, warming up bad, and hot good
now i'm lost
gametom is offline  
Reply With Quote
Old 11-28-2007, 10:51 AM
  #3  
Registered User
 
Join Date: Jun 2007
Location: Marietta, Georgia
Posts: 182
Thanks: 0
Thanked 0 Times in 0 Posts
You should be getting engines codes. Does your check engine light work?
Georgiadave is offline  
Reply With Quote
Old 11-28-2007, 01:24 PM
  #4  
Registered User
Thread Starter
 
gametom's Avatar
 
Join Date: Sep 2006
Location: Manhattan IL
Posts: 476
Thanks: 0
Thanked 0 Times in 0 Posts
if i unplug something major like my tps or o2 i get a cel but other wise it's off
gametom is offline  
Reply With Quote
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Sleaker
86-95 Trucks & 4Runners
11
03-26-2016 04:12 AM
maddogd
86-95 Trucks & 4Runners
1
08-09-2015 04:32 AM
tomczaksdiesel
86-95 Trucks & 4Runners
0
07-26-2015 10:35 PM
luckypig44
Newbie Tech Section
4
07-19-2015 11:25 AM
kyletbert
86-95 Trucks & 4Runners
3
07-17-2015 11:39 AM


Thread Tools
Search this Thread
Quick Reply: no power when warm


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: