22RE rough idle...the journey - YotaTech Forums

Go Back  YotaTech Forums > Toyota SUV & Truck Tech > 86-95 Trucks & 4Runners
Reload this Page >

22RE rough idle...the journey

Notices
86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

22RE rough idle...the journey

Reply

Old 08-12-2018, 03:33 PM
  #1  
Registered User
Thread Starter
 
Join Date: Aug 2018
Posts: 1
22RE rough idle...the journey

Hello everyone, 1st time poster, but I have been creeping the forums for quite awhile. I recently bought a 94 with the 22RE. The details of buying it are: 150k miles on body, and 20/30k on re-manufactured motor from Grooms, in Nashville. I get the truck and notice it has a rough idle and runs rich. the idle almost sounded like a dead miss. I read all the threads I could find and started with the obvious:
- changed plugs,wires, distributor, ect.
- checked TPS, passed the tests.
- replaced all 4 fuel injectors, cleaned intake and TB.

today pulled the valve cover and checked the clearenances. They where all super tight. I adjusted and set cold and hot clearances and the engine idles perfectly now.
The remaining issue that i noticed today was a hesitation when the throttle is reved. It stumbles a second them responds.

I checked the TPS this evening and it needs adjusting, and i have a denso O2 sensor going in tommorrow.

My word of caution to anyone would be just because a motor is from a professional outfit that rebuilds engines does not mean they know what they are doing. Besides the valve clearances being way off, the Scale that has the 5* and 0* markings to find TDC was completely broken off. So I had to use tape and a sharpie to make a scale off of another motor.

I hope this helps someone and I will try my best to keep this updated until the problem is resolved. If you have any recommendations or input please share. I plan on putting some pictures up in the future.

A big thanks to all the people that contribute to these pages. I was reading threads from 10 years ago am grateful to all the knowledge and experience on this site. thanks everyone, - Traveling Man

travelingman is online now  
Reply With Quote
Old 08-13-2018, 07:35 AM
  #2  
Registered User
 
gsp4life's Avatar
 
Join Date: Feb 2015
Location: Mogadore, Ohio
Posts: 793
The cast peice on the oil pump with the timing marks was snapped off? Not a good sign of the care and attention to build quality, but glad it seems to be running better.

I'd pick up a compression tester (about $40) to get a cheap reading on the overall health of the engine.
gsp4life is online now  
Reply With Quote
Reply
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
83yotadream
Pre 84 Trucks (Build-Up Section)
23
09-27-2014 05:10 AM
toyospearo
86-95 Trucks & 4Runners
2
09-01-2008 07:06 PM
YodasTaco
Trip-Trail Reports & Photos
2
01-27-2006 11:54 AM
UKMyers
95.5-2004 Tacomas & 96-2002 4Runners
24
07-23-2003 11:35 AM


Thread Tools
Search this Thread
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: