Go Back  YotaTech Forums > Toyota SUV & Truck Tech > 86-95 Trucks & 4Runners
Reload this Page >

1990 pickup 3.0 v6 losing throttle

Notices
86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

1990 pickup 3.0 v6 losing throttle

Old 03-02-2019, 04:20 PM
  #1  
Registered User
Thread Starter
 
Join Date: Mar 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
1990 pickup 3.0 v6 losing throttle

Iíve got a 1990 pickup 5 speed with 271k on it and recently it started losing throttle response when I get to about 55mph. As soon as it slows down to about 50 mph the throttle response picks right back up like nothing happened. If I put the clutch in when it has its hissy fit it will die. In the past it has thrown codes 24 and 41. It also has picked up a high idle. Everything I have read says thatís typically a vacuum line but I have checked all the ones that I can find and everything seems to be good. No cracked lines and seem to fit snug. Tonight I pulled the throttle body off and cleaned it. I have replaced the throttle position sensor (adjusted it to specs), the mass air flow sensor, has a new fuel pump and filter also. I have also ran all the wiring for the TPS circuit out all the way to the ECM. And they ohmed out. Iím just running out of ideas on what could be causing the throttle loss and what to check. Any help would be appreciated!
bowhntr_ryser is offline  
Old 03-03-2019, 05:51 PM
  #2  
Registered User
 
Join Date: Jul 2017
Location: West Texas
Posts: 88
Thanks: 0
Thanked 3 Times in 3 Posts
Seems I read on here about engine throttle cutout at high speeds ( around 90 ish mph). Turns off the fuel pump until speed reduces. If this is correct then you might have something still out of whack. If I remember or find that post I will post it.
amamike91 is offline  
Old 03-04-2019, 05:23 AM
  #3  
Registered User
Thread Starter
 
Join Date: Mar 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
That would make sense if itís cutting the fuel off why it dies when I put the clutch in. I wonder if there is something that piggy backs off the throttle cable that goes to the ecm that could be throwing it out of wack.
bowhntr_ryser is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
oldmansimek
86-95 Trucks & 4Runners
1
02-04-2015 03:56 AM
youseemyevil
86-95 Trucks & 4Runners
2
04-06-2014 06:03 PM
PNW Yotanation
86-95 Trucks & 4Runners
9
10-17-2013 08:14 PM
Roofmaster
86-95 Trucks & 4Runners
10
07-13-2012 03:54 AM
toyotap
86-95 Trucks & 4Runners
6
02-23-2012 12:09 AM


Thread Tools
Search this Thread
Quick Reply: 1990 pickup 3.0 v6 losing throttle


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: