Pulls hard right in 4wd - YotaTech Forums


Go Back   > >


86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

Pulls hard right in 4wd

Reply
 
LinkBack Thread Tools Search this Thread
Old 12-04-2009, 02:03 PM   #1
BT
Registered User
Thread Starter
 
Join Date: Jan 2008
Location: Davis, CA
Posts: 63
Pulls hard right in 4wd

My truck started pulling meeaannn right if the hubs are locked and the transfer is in 4hi or 4lo. It's a new issue, no gear mismatches or anything. The CV's look fine, but that's just a visual inspection under the truck.

The passenger side front differential mount looks a little jacked. There's ~1/8-1/4" separation visible. I'm gonna replace it, but I don't know if that could be causing the pulling problem.

Any thoughts?

Also, on rough road, I can hear a little bit of clunking. I assume it's the differential moving on the separated mount.
BT is offline   Reply With Quote
Old 12-04-2009, 02:21 PM   #2
Registered User
 
ayoung101's Avatar
 
Join Date: Feb 2004
Location: detroit, mi
Posts: 641
uhhhh, not even sure if this would cause that or not, but could be your 4wd hub is locked up on the right side, causing wheel drag on that side? and in 2wd it just freewheels cuz the hub isn't engaged? just a complete guess.
ayoung101 is offline   Reply With Quote
Old 12-04-2009, 02:37 PM   #3
Registered User
 
yoterr's Avatar
 
Join Date: Jun 2007
Location: Inverness,FL
Posts: 1,787
bad cv, mine does it on the drivers side, and i replaced my spindle not too long ago cuz it was all jacked up and noticed its EXTREMELY hard to move the outer joint around...my guess, but mine clicks when its engaged...
yoterr is offline   Reply With Quote
Old 12-07-2009, 06:44 PM   #4
BT
Registered User
Thread Starter
 
Join Date: Jan 2008
Location: Davis, CA
Posts: 63
No clicks from the CV, and it still tracks fine with the hubs locked and the shifter in 2HI.

I took it through snow, ice and dirt yesterday. When the road is bad and a lot of slipping is going on, it seems to track like it should. But when I hit a smooth, dry patch, it pulls really hard right again.

I tried to take out the mount bolt from the front diff today to check the rubber bushing, but it wouldn't budge with a breaker bar. I need friends with impact tools.
BT is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
88 Pickup Transmission Swap mskalmus 86-95 Trucks & 4Runners 6 03-21-2016 11:41 AM
WTB[PacSoWest]: Oil Dipstick Tube 1985 4wd Pickup adammtb Items Wanted 6 07-27-2015 11:57 AM
Leaking Rear Tranny Seal and Top Tranny Gasket Iceman4193 86-95 Trucks & 4Runners 3 07-15-2015 04:48 PM
NEED HELP! 4wd actuator Vacuum line! TokyoD23 95.5-2004 Tacomas & 96-2002 4Runners 4 07-12-2015 06:01 AM
BFGoodrich All Terrain T/A KO2 or Goodyear Wrangler Duratrac Tires djpg2000 Tires & Wheels 0 07-11-2015 07:26 AM


Tags
2003, 4hi, 4wd, 4x4, dodge, drive, engaged, expedition, hard, pull, pulling, pulls, ranger, side, truck, wheel

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 11:27 PM.


2010 InternetBrands, Inc.