YotaTech Forums - Search Results

Notices
Search: Posts Made By: Terrys87
Showing results 1 to 4 of 4
Search took 0.01 seconds.
11-15-2017, 08:37 AM
Replies: 15
Views: 779
Posted By Terrys87

It sounded great to me. These things have there...

It sounded great to me. These things have there own special noise. I was at a parts store the other day and without even seeing the truck coming in the drive way, I told one of the managers I know (...
10-03-2015, 07:44 PM
Replies: 50
Views: 9,585
Posted By Terrys87

Your lower hose is ready to pop. I would check...

Your lower hose is ready to pop. I would check the hoses under the plenum as well.

I use Gates Rubber hose PN# 20801, around $10. It comes is a "S" shaped form, but when you cut the lower part...
08-13-2013, 02:24 AM
Replies: 64
Views: 71,348
Posted By Terrys87

I have gotten 2 guages to work. Both of the ones...

I have gotten 2 guages to work. Both of the ones I fixed did not have the insulating piece that Inferno is showing. It may not be on all guages, and I am sure both of mine had never been taken apart....
07-28-2013, 01:26 AM
Replies: 64
Views: 71,348
Posted By Terrys87

I got one of my guages working great thanks to...

I got one of my guages working great thanks to this thread. Mine did not have the broken wire, but it did have some corrosion on one of the post. Also I did have a loose nut on the guage itself. It...
Showing results 1 to 4 of 4


 
Forum Jump

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.