97' 4Runner V6 4WD "High NO" Smog results - YotaTech Forums

Notices
95.5-2004 Tacomas & 96-2002 4Runners (Build-Up Section) Post your build-ups here

97' 4Runner V6 4WD "High NO" Smog results

Reply

Old 07-19-2017, 09:29 AM
  #1  
Registered User
Thread Starter
 
Join Date: Jul 2017
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
97' 4Runner V6 4WD "High NO" Smog results

Located in California--I recently bought a used JDM engine with around 50k miles. ALL accessories, e.g. oil pump, water pump, timing belt, ALL seals, spark plugs & wires etc.....worth about $1k in parts were replaced w/Toyota parts. I did NOT go cheap. Original engine had 387k miles and head gasket blew. Took the 4runner to the smog shop and failed with "high" NO (nitric oxide); MAX allowed is 512 and MEASURED at 679.

What should I start doing first? Clean air flow sensor? Replace O2 sensor? I'm praying that it's not my Catalytic converter. The smog results printed/stated the catalytic converter PASSED?? Any input is appreciated.
rhabdo932 is offline  
Reply With Quote
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MRecio
Newbie Tech Section
5
07-08-2007 07:28 AM
RR DIFF LOCK
95.5-2004 Tacomas & 96-2002 4Runners
33
02-12-2007 12:11 PM
joesrunner
86-95 Trucks & 4Runners
9
02-07-2007 07:23 AM
dafried
95.5-2004 Tacomas & 96-2002 4Runners
0
03-10-2004 12:28 PM


Thread Tools
Search this Thread
Quick Reply: 97' 4Runner V6 4WD "High NO" Smog results


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: