Marker light out and squeaky carrier bearing? - YotaTech Forums

Newbie Tech Section Often asked technical questions can be asked here

Marker light out and squeaky carrier bearing?

LinkBack Thread Tools Search this Thread
Old 09-21-2017, 01:42 PM   #1
Registered User
Thread Starter
Sr5stripes's Avatar
Join Date: Sep 2017
Posts: 1
Marker light out and squeaky carrier bearing?

So it looks like my passenger side front marker light went out on me, I replaced the bulb but it didn't help. Not sure what to do.

Also, I've been dealing with his squeal I get taking off in first from a atop. Thought it was my ujoints but those were greased up about a year ago and seem to have normal play. The carrier bearing didn't look too good though.

Shoukd I look for a new one? Look into a new driveshaft? Un sure of which route to go any advice would help. Thanks.
Sr5stripes is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -8. The time now is 10:56 PM.

2017 InternetBrands, Inc.
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to and affiliated sites.
  • Ask a Question
    Get answers from community experts
Question Title:
Your question will be posted in: