Help - 94 4runner 3.0 cranks & Runs but looses power - YotaTech Forums



Newbie Tech Section Often asked technical questions can be asked here

Help - 94 4runner 3.0 cranks & Runs but looses power

Reply
 
LinkBack Thread Tools Search this Thread
Old 07-11-2018, 08:52 AM   #1  
Big
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 2
Help - 94 4runner 3.0 cranks & Runs but looses power

I got a 94 4runner with the 3.0£ cranks an runs fine but it losses power going down the road an won't pull its self I can pop it in neutral an rev it up throught the hesitation an it clears out I just put a fuel pump an filter needs some advice the cel works but isn't on while driving
Big is offline   Reply With Quote
Old 07-11-2018, 08:41 PM   #2  
Registered User
iTrader: (1)
 
Join Date: Dec 2011
Location: sammamish, wa.
Posts: 1,798
Jump the diagnostic port and see if there is a stored code. Might not actually flash on the dash but you can still have a code tripped.
thefishguy77 is offline   Reply With Quote
Old 07-12-2018, 12:55 AM   #3  
Registered User
iTrader: (1)
 
wyoming9's Avatar
 
Join Date: Apr 2009
Location: I live in New Tripoli Pa out in the woods
Posts: 12,885
Red face

Clutch or Transmission Slipping ??
wyoming9 is offline   Reply With Quote
Old 07-12-2018, 07:39 AM   #4  
Registered User
 
Join Date: Apr 2016
Location: Alaska
Posts: 781
Time to play doctor, take it's temperature, check for a hernia, blood pressure etc.
If it has been a while since your last tune up put in some new plugs (do a compression test while you are there), cap/rotor, plug wires. Check the timing with and without the jumper.
Check the fuel supply (disconnect the return from the fuel pressure regulator and see if you are getting enough flow into a bucket according to the service manual).
akwheeler is offline   Reply With Quote
Old 07-14-2018, 09:03 AM   #5  
Big
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 2
Quote:
Originally Posted by thefishguy77 View Post
Jump the diagnostic port and see if there is a stored code. Might not actually flash on the dash but you can still have a code tripped.
Only code that comes up is the 71 egr would that make it run that way
Big is offline   Reply With Quote
Old 07-15-2018, 03:02 PM   #6  
Registered User
iTrader: (1)
 
Join Date: Dec 2011
Location: sammamish, wa.
Posts: 1,798
Yea it could. Especially if its because of a vacuum leak. A can of started fluid sprayed around vacuum lines while its running should help track down any vacuum leaks.
thefishguy77 is offline   Reply With Quote
Old 07-15-2018, 04:28 PM   #7  
Fossilized
Staff
iTrader: (6)
 
dropzone's Avatar
 
Join Date: Oct 2005
Location: PNW
Posts: 18,738
welcome to YT...in the future please don't make a thread title with just 'Help" for a few reasons:
-it clogs the search function
-it could lead to your thread be deleted because the title doesn't say anything
-Please make your title relevant to the issue you are having. YT members are more than willing to help out and someone may have a solution/fix for you but they could pass over the thread because the title doesn't get their attention
dropzone is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Another 3VZE cold start issues - Fuel side is good -Weak ignition? Low compression? Grabbit89 86-95 Trucks & 4Runners 5 06-04-2018 02:50 PM
The Adventures of Jane – ‘15 4R TP CreeperSleeper 2010+ 4Runner (Build-Up Section) 11 05-14-2018 03:29 PM
93 Toyota Pickup 3VZE Pulley InsigZi 86-95 Trucks & 4Runners 21 04-27-2018 08:26 PM
Help needed! hellgrunt5643 86-95 Trucks & 4Runners 20 04-21-2018 03:49 PM
3.0 low power in closed loop nmchuck 86-95 Trucks & 4Runners 6 05-31-2017 06:27 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 04:27 AM.


2017 InternetBrands, Inc.
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: