Bad NSS cause tranny not to shift properly? - YotaTech Forums

Go Back  YotaTech Forums > Toyota SUV & Truck Tech > Newbie Tech Section
Reload this Page >

Bad NSS cause tranny not to shift properly?

Notices
Newbie Tech Section Often asked technical questions can be asked here

Bad NSS cause tranny not to shift properly?

Reply

Old 11-15-2013, 04:58 PM
  #1  
Registered User
Thread Starter
 
Join Date: Nov 2013
Location: Southwest Ohio
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Question Bad NSS cause tranny not to shift properly?

I have a 2000 Toyota 4Runner 3.4V6 287,000 miles.
my check engine light is on for the 3rd time and the code always says Neutral Safety Switch. Light has stayed on a few days this time vs. going back out in few hours.
My other problem is - transmission doesn't shift out of 2nd gear (auto tranny) when it's cold. once it warms and the viscosity of fluid is smoother or not as thick (this is my guess from educating myself) then 4runner runs fine.
this started in about Feb of this year but as weather warmed up the problem disappeared all summer. So yes, it's normally corrected by letting my 4runner warm up significantly to get the fluid running.
However, lately (according to my 19 yr old son who is driving it) it's not shifting properly even after warming up several minutes. One "solution" -he pulls over, turns vehicle off; let's it set a few and restarts.
I 've talked with three diff mechanics and also auto parts stores. too many diff "opinions" . but basically everyone seems to think the NSS will correct the tranny not shifting problem except one mechanic who said the NSS has to do with the ignition.
I also believe after me researching that I'm learning that the NSS has to do with the ignition and may or may not be related to the shifting of tranny??
however, when the non-shifting tranny problem is going to happen, my reverse light comes on while in D and then i know i'm going to have problem with the tranny.
I saw that the NSS does say something about Reverse light , etc.
So i am not clear if the two issues are connected or not. Specific insight MUCH appreciated.
4-RunnerGal is offline  
Reply With Quote
Old 08-04-2014, 06:04 PM
  #2  
Registered User
Thread Starter
 
Join Date: Nov 2013
Location: Southwest Ohio
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Tranny won't shift when headlights are on

I believe I started this thread last fall - I thought then that my problem was the cold affecting the shifting of my tranny.. and it DOES take a few minutes for my 4runner to warm up in the cold and shift properly - HOWEVER, that's not THE problem. I have since discovered that it's something electrical . My check engine light now stays on - the code ALWAYS says my Neutral Safety switch is the problem.
However, I had the NSS replaced and my 4Runner ran perfect for a few hours that evening. Next evening when I turned on headlights, it was back to not shifting again. So it has for several months, run fine as long as headlights are not turned on. the Check Engine light is on and intermittently the Reverse light is on while I'm in Drive but as long as headlights are off, I don't have the problem. The running lights are always on and I can drive with blinkers on.. but not headlight. tranny won't shift. Any ideas?
4-RunnerGal is offline  
Reply With Quote
Old 08-04-2014, 06:30 PM
  #3  
Contributing Member
 
rworegon's Avatar
 
Join Date: Nov 2010
Location: Columbia River Gorge, Oregon...east side
Posts: 5,125
Thanks: 0
Thanked 0 Times in 0 Posts
Do you have what the code number that you are getting? It will help if you can share it.
rworegon is offline  
Reply With Quote
Old 08-05-2014, 05:53 PM
  #4  
Registered User
Thread Starter
 
Join Date: Nov 2013
Location: Southwest Ohio
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
i don't have code #, but I will check tomorrow. every time I get the code and look it up it says Neutral Safety switch. Thanks for moving me out here in this thread.
To clarify - my 4Runner shifts/runs fine with the headlights off. When I turn headlights on, the tranny wont shift. And also upon turning headlights on, the REverse light immediately comes on while in drive. I can go about 30-35 mph and then the RPM go high and tranny will not shift. Turn headlights off right then, it shifts fine.
4-RunnerGal is offline  
Reply With Quote
Old 01-14-2015, 08:20 AM
  #5  
Registered User
 
Join Date: Jan 2015
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Did anyone find the cause of this issue? I just bought a 2000 4runner and I'm having the same issue with it not shifting or when it's warm and I turn on the high beams, it shifts down to first and I have to pull over and shut it off. The check engine light is on and the code is saying neutral safety switch, but doesn't seem like the lights would have anything to do with that?
toyota20004 is offline  
Reply With Quote
Old 06-21-2017, 07:35 AM
  #6  
Registered User
 
Join Date: Jun 2017
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Did you get a answer?

My toyota will not shift when the lights are on! Did you find out what was wrong with yours? Any help would be greatly appreciated!!!!


Originally Posted by 4-RunnerGal View Post
I believe I started this thread last fall - I thought then that my problem was the cold affecting the shifting of my tranny.. and it DOES take a few minutes for my 4runner to warm up in the cold and shift properly - HOWEVER, that's not THE problem. I have since discovered that it's something electrical . My check engine light now stays on - the code ALWAYS says my Neutral Safety switch is the problem.
However, I had the NSS replaced and my 4Runner ran perfect for a few hours that evening. Next evening when I turned on headlights, it was back to not shifting again. So it has for several months, run fine as long as headlights are not turned on. the Check Engine light is on and intermittently the Reverse light is on while I'm in Drive but as long as headlights are off, I don't have the problem. The running lights are always on and I can drive with blinkers on.. but not headlight. tranny won't shift. Any ideas?
Keepur0pinions is offline  
Reply With Quote
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mskalmus
86-95 Trucks & 4Runners
9
05-28-2017 07:51 AM
smthwsn357
86-95 Trucks & 4Runners
7
04-11-2016 05:22 AM
BeMiceElf
Misc Stuff (Vehicle Related)
7
10-10-2015 09:40 PM
crashburnoveride
86-95 Trucks & 4Runners
1
07-10-2015 06:39 AM
Jnkml
95.5-2004 Tacomas & 96-2002 4Runners
3
07-06-2015 01:20 PM


Thread Tools
Search this Thread
Quick Reply: Bad NSS cause tranny not to shift properly?


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: