Go Back  YotaTech Forums > Toyota SUV & Truck Tech > 86-95 Trucks & 4Runners
Reload this Page >

injectors keeps leaking,no power and stalls when clutch is pressed

Notices
86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

injectors keeps leaking,no power and stalls when clutch is pressed

Old 10-24-2009, 06:45 PM
  #1  
Registered User
Thread Starter
 
ernestmiller347's Avatar
 
Join Date: Jul 2008
Location: nc
Posts: 13
Likes: 0
Received 0 Likes on 0 Posts
injectors keeps leaking,no power and stalls when clutch is pressed

ok where do i begin ...... ok 1992 yoda i just changed the head gasket and had a valve job and put it bk together and truck runs good when i start it up and idles good but when i take it dwn the road it has no power at all . to begin with when i left for work it started to act like it wanted to loose power for a mile or 2 and then it would clear up and run fine but now it wnt clear up at all . and when i push the clutch it idles dwn so low that i cuts off ?? and i have changed the orings on the injector 5 times and after i put it bk together it wasnt leaking when i drove it up and dwn the rode it was fine untill i cut it off and let it cool dwn and start it bk up it seems like it starts leaking as soon as i start it up ? so i changed the orings and took it dwn the road and let it warm up trying to rack my brain to figure out y it dnt have power so i inspected the vac lines and they was fine so i got bk in the truck to try it again i noticed that another injector was leaking a diff one ??? what the hell ????
ernestmiller347 is offline  
Old 10-24-2009, 06:53 PM
  #2  
Registered User
 
Kiroshu's Avatar
 
Join Date: Oct 2007
Location: NC
Posts: 2,747
Likes: 0
Received 0 Likes on 0 Posts
Have the injectors been changed before? How do you know its the injectors leaking? Are you positive? Pics? Your truck should not be dying with the clutch pressed in.... that may be related to lack of power.... Vac leaks? Where the intake gaskets replaced? Any codes?
Kiroshu is offline  
Old 10-24-2009, 07:16 PM
  #3  
Registered User
Thread Starter
 
ernestmiller347's Avatar
 
Join Date: Jul 2008
Location: nc
Posts: 13
Likes: 0
Received 0 Likes on 0 Posts
when i turned the truck over and raised the hood u could see is squirting out of num 1 the last time , all gaskets was replaced except the oil pan i also changed the timing chain and i checked checked and rechecked the timing chain to make sure it was right , and yea its throwing o2 sensor and knock sensor but that's bc i lost the connector and haven't got a new one yet ( they have to order one at the dealership) but it was doing the loss of power thing b4 i tore it dwn and no codes then. i checked the vac lines and i didnt see any that was bad
ernestmiller347 is offline  
Old 10-24-2009, 07:24 PM
  #4  
Registered User
 
Kiroshu's Avatar
 
Join Date: Oct 2007
Location: NC
Posts: 2,747
Likes: 0
Received 0 Likes on 0 Posts
Are the correct injectors in the truck? There is 2 O-rings on the injector..... one on the inside and one on the ouside.... (to where it goes in the intake) make sure they are both there..... make sure its all tight. Hows the fuel rail look? Your lake of power issue could be manythings..... Tune-up? Does it have NGK or OEM plugs? OEM plug wires? I highly recommend them highly for best performance..... Air filter dirty? Main intake hose leaking? Fuel filter? Valves adjusted properly? Exhaust manifold leaking? Cat converter clogged?
Kiroshu is offline  
Old 10-24-2009, 07:35 PM
  #5  
Registered User
Thread Starter
 
ernestmiller347's Avatar
 
Join Date: Jul 2008
Location: nc
Posts: 13
Likes: 0
Received 0 Likes on 0 Posts
i replaced all the seals on the injectors and it leaks from thefuel rail side everytimes i have replaced the orings 6 times in 1 year most of the time its a diff one that leaks , yea they r the right ones for the truck lol i checked on that yesterday lol. i done a tune up 6 months ago,i am running ngk plugs,and u know t been thinking bout the valves but my mind goes bk to when it would clear up b4 u know ?? now i havent never changed the fuel filter that could b it too cat seems to b ok but the muffler ant that good tho lol.
ernestmiller347 is offline  
Old 10-24-2009, 07:40 PM
  #6  
Registered User
 
Kiroshu's Avatar
 
Join Date: Oct 2007
Location: NC
Posts: 2,747
Likes: 0
Received 0 Likes on 0 Posts
weird it keeps blowing out seals..... i wonder if your fuel pressue is too high.... that would be the seal issue.... fuel pressure regulator is prolly bad.... well you could by a new fuel filter and if thats not it knock out ur cat..... sure timing is correct. Have you tried advancing? The more advanced the timing the more effecient the engine runs. I'd put it at about 12BTDC or 8 up to you.
Kiroshu is offline  
Old 10-24-2009, 08:05 PM
  #7  
Registered User
Thread Starter
 
ernestmiller347's Avatar
 
Join Date: Jul 2008
Location: nc
Posts: 13
Likes: 0
Received 0 Likes on 0 Posts
thats what i was thinking but i didnt know if the regulater is sumthing that goes bad .i will try to advance it tomm , u know my buddy gave me a good idea he said that i have a vac leaking cuz when it is idleing its fine but when i go dwn the road is when it stalls and he was telling me that the motor isnt advancing the timing when it is idled up and that couses it to stall too but i cnt find a leak ??
ernestmiller347 is offline  
Old 10-24-2009, 08:08 PM
  #8  
Registered User
 
Kiroshu's Avatar
 
Join Date: Oct 2007
Location: NC
Posts: 2,747
Likes: 0
Received 0 Likes on 0 Posts
Tiz possible, but vac could be leaking going to your regulator cause it not to work properly and trouble during driving range. Check your regualtor and lines going to it.
Kiroshu is offline  
Old 10-24-2009, 08:15 PM
  #9  
Registered User
Thread Starter
 
ernestmiller347's Avatar
 
Join Date: Jul 2008
Location: nc
Posts: 13
Likes: 0
Received 0 Likes on 0 Posts
how do i check the regulater ?
ernestmiller347 is offline  
Old 10-24-2009, 08:23 PM
  #10  
Registered User
 
Kiroshu's Avatar
 
Join Date: Oct 2007
Location: NC
Posts: 2,747
Likes: 0
Received 0 Likes on 0 Posts
To do that you have to tap into the fuel system with a fuel pressure gauge.... i'm sure you donot have one of those just layin around..... i forget what the fuel pressure is for a 22re but yea. But i'm pretty sure your regualtor either has the vac line going to it cracked or busted or the regualtor itself is done Theres a little rubber diaphram inside the regualtor and its prolly craked and or has holes. You could prolly take it to a shop and they may have a fuel pressure guage.... you get them to tell you if it was bad for sure and you change it..... up to you....
Kiroshu is offline  
Old 10-24-2009, 08:42 PM
  #11  
Registered User
Thread Starter
 
ernestmiller347's Avatar
 
Join Date: Jul 2008
Location: nc
Posts: 13
Likes: 0
Received 0 Likes on 0 Posts
hahaha lol u know what as a matter of a fact i do have a fuel pressure gauge i just got for my mustang that i ant put on yet lol i will try that tomm and i dnt think the pressure cnt b over 15 pounds cuz i know thats stock on my mustang so it cnt b that much on a 4 banger u know ? pretty convenient huh lol
ernestmiller347 is offline  
Old 10-24-2009, 09:34 PM
  #12  
Registered User
 
Jason4X4's Avatar
 
Join Date: Jun 2006
Location: Chandler, AZ
Posts: 156
Likes: 0
Received 0 Likes on 0 Posts
sounds like your cat is plugged by the lack of power
Jason4X4 is offline  
Old 10-25-2009, 06:17 AM
  #13  
Registered User
 
Kiroshu's Avatar
 
Join Date: Oct 2007
Location: NC
Posts: 2,747
Likes: 0
Received 0 Likes on 0 Posts
The fuel pressure for a 22re should be between abour 33-38.
Kiroshu is offline  
Old 10-26-2009, 11:08 AM
  #14  
Registered User
Thread Starter
 
ernestmiller347's Avatar
 
Join Date: Jul 2008
Location: nc
Posts: 13
Likes: 0
Received 0 Likes on 0 Posts
ok i gutted my cat and dirlled holes in my muffler to see if that was my prob and sure enough the power is bk but i dnt think thats cousing my inj to have a blow out as much as they been messing up but ima check the pressure in a mim or to but thanks
ernestmiller347 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Charecter1
86-95 Trucks & 4Runners
9
07-16-2015 06:40 PM
andrewtexas123
86-95 Trucks & 4Runners
3
07-14-2015 04:29 AM
nick b
86-95 Trucks & 4Runners
4
07-11-2015 04:38 AM
Kalihi,HI
86-95 Trucks & 4Runners
3
07-09-2015 04:29 PM
Jnkml
95.5-2004 Tacomas & 96-2002 4Runners
3
07-06-2015 01:20 PM


Thread Tools
Search this Thread
Quick Reply: injectors keeps leaking,no power and stalls when clutch is pressed


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: