Notices
86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

high idle and sterring pump nosie

Old 10-09-2005, 08:58 PM
  #1  
Registered User
Thread Starter
 
r6dallastx's Avatar
 
Join Date: Jun 2005
Posts: 59
Likes: 0
Received 0 Likes on 0 Posts
high idle and sterring pump nosie

I have a 1990 v6 4x4 4runner. I'm in dallas tx and last week it's been a bit cold in the morning, around 55. well, my engine reves up high around 1700 rpm and stays there for 10 mins of driving. My power steering pump also makes a noise for about 10 mins. after the truck is nice and warm eveything is fine, no noise and the engine idles fine. today it was abot 85 when i turned on the truck for the first time in the day and the idled was up to 1100 rpm and then it when down to 900 after may be 2 mins. The power steering pump didn't make any nosie. before it started to get cold the truck would idle fine and the pump wouldn't make any nosie. I just changed my spark plugs, wires, cap, rotor, 02 sensor, air filter, fuel filter, i've cleaned my intake. I checked the steering pump fluid when the day is cold and it's making that nosie it looks like foam in there. when the day is warm it looks fine. Why is the engine revving so high, I try to keep it tuned and she runs very nice. I can't even feel the engine on once its warm. i can understand the pump is getting old and it may need to get warm to work.

Last edited by r6dallastx; 10-09-2005 at 09:56 PM.
r6dallastx is offline  
Old 10-09-2005, 09:27 PM
  #2  
Contributing Member
 
Elton's Avatar
 
Join Date: Jul 2005
Location: Siletz,Oregon
Posts: 12,261
Likes: 0
Received 3 Likes on 2 Posts
when there cold it will idle high till it warms up its fine as far as the steering pump i dont know about that some one will chime in
Elton is offline  
Old 10-09-2005, 10:01 PM
  #3  
Registered User
Thread Starter
 
r6dallastx's Avatar
 
Join Date: Jun 2005
Posts: 59
Likes: 0
Received 0 Likes on 0 Posts
new cars don't idle like when its cold. they do it for about 1 min or less. I also have a 2003 chevy silverado 1500, and when its cold it will rev high for maybe a 1 min even less than the idle will go down to 500. I know that when car become older they need repair and tuning, so i thinking maybe some thing needs to replace or to be tuned to get the truck to idle right.

Last edited by r6dallastx; 10-09-2005 at 11:35 PM.
r6dallastx is offline  
Old 10-10-2005, 02:00 PM
  #4  
Contributing Member
 
Sleepydog's Avatar
 
Join Date: May 2005
Location: Clarksville, TN
Posts: 18
Likes: 0
Received 0 Likes on 0 Posts
Foam in the ps fluid reservoir would make me think you've got air in the system. Is the fluid level low?

I just replaced the pump on my 95 - It would be terribly noisy when the fluid got real low, especially at startup...
Sleepydog is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
smthwsn357
86-95 Trucks & 4Runners
7
04-11-2016 05:22 AM
luckypig44
Newbie Tech Section
4
07-19-2015 11:25 AM
kyletbert
86-95 Trucks & 4Runners
3
07-17-2015 11:39 AM
Charecter1
86-95 Trucks & 4Runners
9
07-16-2015 06:40 PM
ZONAYODA
86-95 Trucks & 4Runners
12
07-13-2015 07:17 PM


Thread Tools
Search this Thread
Quick Reply: high idle and sterring pump nosie


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: