Freshly rebuilt 22r. Turns over but won't start. - YotaTech Forums



86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS
Sponsored by:
Sponsored by:

Freshly rebuilt 22r. Turns over but won't start.

Reply
 
LinkBack Thread Tools Search this Thread
Old 04-21-2017, 02:43 AM   #1
irv
Registered User
Thread Starter
 
Join Date: Dec 2011
Posts: 170
Freshly rebuilt 22r. Turns over but won't start.

Just completed a fresh rebuild of my 86 22r. It cranks strong and steady but just won't start. Every few seconds a puff of gasoline shoots out the top of the carburetor while it's cranking. So it's definitely getting gas but it just cranks and cranks and cranks without fully firing up. I'm going to do a compression test and a spark test tomorrow. I've just desmogged the truck and am using the stock Aisin carb. I'm near positive that all other wires and connections are where they should be. She's full of fresh oil and coolant. When I installed the distributor I set #1 piston at TDC and set the distributor to the #1 piston position - from what I understand this is correct. Any tips or thoughts?

Last edited by irv; 04-21-2017 at 03:35 AM.
irv is offline   Reply With Quote
Old 04-21-2017, 11:57 AM   #2
Registered User
 
Join Date: May 2013
Location: Arizona Desert
Posts: 207
Is your idle circuit cut off solenoid getting power? Off the top of my head that is all I can think of other then checking spark.

grey
greyheadedguy is offline   Reply With Quote
Old 04-21-2017, 12:51 PM   #3
irv
Registered User
Thread Starter
 
Join Date: Dec 2011
Posts: 170
Quote:
Originally Posted by greyheadedguy View Post
Is your idle circuit cut off solenoid getting power? Off the top of my head that is all I can think of other then checking spark.

grey
Interesting thought. I don't actually know what the idle circuit cut off solenoid is. I'll google search for it. Anything additional that you might want to tell me would be excellent too.
irv is offline   Reply With Quote
Old 04-21-2017, 01:24 PM   #4
irv
Registered User
Thread Starter
 
Join Date: Dec 2011
Posts: 170
I am following the vacuum diagram attached. However, I omitted the top circled hose. And the bottom circled area I have located at one of the side ports where the arrow points. At the moment I also have both hoses leading to the distributor capped off. I just didn't have the proper hose on hand yet but I will have them attached soon. All other openings are plugged. Should any of these things prevent the truck from starting?


irv is offline   Reply With Quote
Old 04-22-2017, 10:05 PM   #5
Registered User
 
Join Date: May 2013
Location: Arizona Desert
Posts: 207
Quote:
Originally Posted by irv View Post
I am following the vacuum diagram attached. However, I omitted the top circled hose. And the bottom circled area I have located at one of the side ports where the arrow points. At the moment I also have both hoses leading to the distributor capped off. I just didn't have the proper hose on hand yet but I will have them attached soon. All other openings are plugged. Should any of these things prevent the truck from starting?



Look at the carburetor rebuild section for the solenoid, I have attached a couple pages,

grey
Attached Files
File Type: pdf Cut off solenoidl.pdf (97.9 KB, 16 views)
greyheadedguy is offline   Reply With Quote
Old 04-23-2017, 11:54 PM   #6
irv
Registered User
Thread Starter
 
Join Date: Dec 2011
Posts: 170
So I found my answer. I had the distributor installed a tooth or two off. It's now running fantastically. It's great having all of the smog equipment removed as well. Funny to have a heavy box full of stuff that was removed and won't go back on. I'm still doing a bit of troubleshooting on the carb. I'm following the above vacuum diagram and I've got the Hot Air Intake and Automatic Choke working but the fast idle isn't working for some reason. I turn the fast idle screw and it changes nothing.
irv is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 08:46 AM.


2017 InternetBrands, Inc.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: