94 Toyota Truck 3.0 Rebuild Trouble - YotaTech Forums

Go Back  YotaTech Forums > Toyota SUV & Truck Tech > 86-95 Trucks & 4Runners
Reload this Page >

94 Toyota Truck 3.0 Rebuild Trouble

Notices
86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

94 Toyota Truck 3.0 Rebuild Trouble

Reply

Old 06-11-2008, 03:29 PM
  #1  
Registered User
Thread Starter
 
Join Date: Jun 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
94 Toyota Truck 3.0 Rebuild Trouble

So my brother was kind enough to install a rebuilt motor in my 94 Toyota pickup. Everything went fine but we have had an issue that we cannot resolve. The car will not go over 50 MPH. In the lower gears there isn't as much of a power issue but it will not get up to speed on the highway.

The first time we brought the truck to the dealer they said that it was the knock sensor the second time the mass air flow sensor. Both have been replaced and we are having the same issue. When the knock sensor was replaced the check engine light went off.

Any and all help would be greatly appreciated.

Thanks!
thomason498 is offline  
Reply With Quote
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Nathan_F
86-95 Trucks & 4Runners
2
08-19-2015 04:03 PM
matrad
86-95 Trucks & 4Runners
2
06-25-2015 10:15 PM
nyk08trx
86-95 Trucks & 4Runners
1
06-18-2015 09:01 PM
yamaha73
86-95 Trucks & 4Runners
10
06-18-2015 06:19 PM


Thread Tools
Search this Thread
Quick Reply: 94 Toyota Truck 3.0 Rebuild Trouble


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: