Notices
86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

94 3.0 idle issue

Old 01-28-2019, 07:16 PM
  #1  
Registered User
Thread Starter
 
Join Date: Mar 2014
Location: Portland OR
Posts: 16
Likes: 0
Received 1 Like on 1 Post
94 3.0 idle issue

Hi,I recently replaced a 3.0 in my truck,at first it ran fine except it wouldn't idle when hot,, in the process of troubleshooting that i swapped my injectors out, then it started but ran rough,figured out 3 of the injectors were not delivering fuel,so i pulled them out and replaced them with injectors from the old motor which ran fine(even at 340,000 miles i should have left it in),now when i try to start it ,it will fire ,rev up and die,,if i keep my foot on the gas and feather it it will run but as soon as i let off dies. Thoughts?


/
wadester33 is offline  
Old 01-28-2019, 07:34 PM
  #2  
Registered User
Thread Starter
 
Join Date: Mar 2014
Location: Portland OR
Posts: 16
Likes: 0
Received 1 Like on 1 Post
also

I have jumpered fuel pump it runs but no change,swapped throttle bodies,no change
wadester33 is offline  
Old 01-28-2019, 08:18 PM
  #3  
Registered User
 
Killemall's Avatar
 
Join Date: Mar 2014
Location: CA
Posts: 29
Received 3 Likes on 3 Posts
Are you 100% sure all the vacuum lines are connected properly?
Killemall is offline  
Old 01-28-2019, 08:25 PM
  #4  
Registered User
Thread Starter
 
Join Date: Mar 2014
Location: Portland OR
Posts: 16
Likes: 0
Received 1 Like on 1 Post
To the best of my knowledge they are,went off diagrams from here.it was running,,˟˟˟˟ty but running now all the sudden this,i dont get what could have triggered it
wadester33 is offline  
Old 01-28-2019, 08:28 PM
  #5  
Registered User
 
Killemall's Avatar
 
Join Date: Mar 2014
Location: CA
Posts: 29
Received 3 Likes on 3 Posts
I don't think it should die even if some cylinders aren't firing due to faulty injectors You can try to take off one coil per time and see if anything changes.

In any cases , I would start from rechecking the vacuum lines. Even two swapped can make it run like crap. I spent hrs looking for issues just to find out had reconnected something wrong. Many times....

Last edited by Killemall; 01-28-2019 at 08:30 PM.
Killemall is offline  
Old 01-28-2019, 09:54 PM
  #6  
Registered User
Thread Starter
 
Join Date: Mar 2014
Location: Portland OR
Posts: 16
Likes: 0
Received 1 Like on 1 Post
I follow ya,,I deleted the egr and pair so the lines left are fairly easy to hookup,,but Ive been known to cross em up,,I'll recheck
wadester33 is offline  
Old 01-29-2019, 04:34 PM
  #7  
Registered User
 
Merklecr's Avatar
 
Join Date: Jul 2018
Location: Cincinnati, OH
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
I had a similar issue when I deleted my EGR. Did you replace the single bolt on the front left of the intake manifold? I don't remember what it holds, but it's easy to forget to put back. Replacing this solved all of my extremely rough idling issues. Good luck!
Merklecr is offline  
Old 01-30-2019, 08:18 AM
  #8  
Registered User
Thread Starter
 
Join Date: Mar 2014
Location: Portland OR
Posts: 16
Likes: 0
Received 1 Like on 1 Post
I figured it out,,the plenum gasket was torn in the back and i didnt notice it so big leak there,,but thank you guys for your input.
wadester33 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
redbayredneck
GPS & Communication
3
06-02-2014 04:29 AM
nothingbetter
Offroad Tech
3
11-11-2013 03:40 PM
kevo4runner89
86-95 Trucks & 4Runners
44
09-13-2013 04:30 PM
Rob2thec
86-95 Trucks & 4Runners
2
01-28-2010 10:09 PM
de6w6it
Off Topic Talk
1
10-29-2008 10:10 AM


Thread Tools
Search this Thread
Quick Reply: 94 3.0 idle issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: