Notices
86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

'86 Toyota Pickup Stall once put in gear

Old 02-25-2019, 12:22 PM
  #1  
Registered User
Thread Starter
 
Join Date: Feb 2019
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
'86 Toyota Pickup Stall once put in gear

[color=left=#26282a]I am having a hell of a time with my '86 Pickup. I'm not incredibly mechanically inclined but so far I have changed the fuel filter (frame), alternator[/color][color=left=#26282a], battery, carb (had it rebuilt), spark plugs, and the tranny had to be replaced with used one. Our pickup can sit and idle all day long, then I go to put it in gear and drive and put put put and dies out. The other morning I actually drove it about a mile then had to be towed home by my wife in our other Toyota Tacoma. [/color]
JamesnJensBaby is offline  
Old 02-25-2019, 02:55 PM
  #2  
Registered User
 
87-4runner's Avatar
 
Join Date: Mar 2012
Location: Oklahoma
Posts: 435
Received 43 Likes on 41 Posts
What does it do when it dies? Miss, backfire, just die, describe in detail what is happening...
87-4runner is offline  
Old 02-26-2019, 04:43 AM
  #3  
Registered User
 
Discombobulated's Avatar
 
Join Date: Oct 2011
Location: Denver CO
Posts: 1,822
Likes: 0
Received 30 Likes on 24 Posts
This wouldnít make too much sense with a manual I take it you have an automatic??
Discombobulated is offline  
Old 02-26-2019, 07:45 AM
  #4  
Registered User
Thread Starter
 
Join Date: Feb 2019
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
@Discombobulated ...This is a standard. @87-4runner It feels like it just loses all power. It sputters almost like its being choked out for some reason. I pulled the intake off again last night and also swapped out the fuel pump again with a brand new one from Autozone. Thank goodness the mechanical fuel pumps are still reasonable price. Truck starts right up no problem I haven't test drove it but im still leery about it on the open road. I will say the truck sat for a loooong while before being started up. brand new gas is in it finally along with of course the fuel pump and filter.
JamesnJensBaby is offline  
Old 02-26-2019, 07:47 AM
  #5  
Registered User
Thread Starter
 
Join Date: Feb 2019
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Also forgot to mention Im having the a different symptom I noticed last night. the brake lights and the "brake light" dash light are staying on when all brakes are disengaged. not sure if this might play a role or different problem.
JamesnJensBaby is offline  
Old 02-26-2019, 09:14 AM
  #6  
Registered User
 
Discombobulated's Avatar
 
Join Date: Oct 2011
Location: Denver CO
Posts: 1,822
Likes: 0
Received 30 Likes on 24 Posts
So once you engage the clutch in first it dies? Sorry it just sounded like an auto if you put it in gear and it dies. How long has the brake lights been on? Does the truck roll freely when in neutral or does it feel like it’s dragging?
Discombobulated is offline  
Old 02-26-2019, 09:24 AM
  #7  
Registered User
Thread Starter
 
Join Date: Feb 2019
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Once I get going 1st then switch to second it dies. the other day I got it into 3rd and going about 30mph and it sputtered out. It idles fine no problem sometimes if I push on the gas itll die while idling. The brake lights have been on for as long as I can remember, but it rolls freely no resistance at all.
JamesnJensBaby is offline  
Old 02-26-2019, 10:28 AM
  #8  
Registered User
 
87-4runner's Avatar
 
Join Date: Mar 2012
Location: Oklahoma
Posts: 435
Received 43 Likes on 41 Posts
Sounds like your FPR... fuel pressure regulator
87-4runner is offline  
Old 02-27-2019, 05:19 AM
  #9  
Registered User
Thread Starter
 
Join Date: Feb 2019
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
So last night I started truck (two pumps of the gas) and started right up! I let it idle for about 45 minutes while doing other things inside the truck I also fixed the brake problem it turned out there was a spring that fell off and the brake pedal was not returning all the way back to position... easy and more importantly free! After running the truck and adding more fresh gas I tried the test drive again and to my surprise it took off like a bat outta hell!! I got about 3 miles down the road and it was running great!!! Then sputter sputter dead.... I started it back up after a few attempts it fired up and then dead I had to limp like that all the way home... all I did different last night was add gas and fiddle with the idle screw and oxygen adjustment on the carb.
JamesnJensBaby is offline  
Old 02-27-2019, 05:26 AM
  #10  
Registered User
 
87-4runner's Avatar
 
Join Date: Mar 2012
Location: Oklahoma
Posts: 435
Received 43 Likes on 41 Posts
Fuel filter... bad gas...
87-4runner is offline  
Old 02-27-2019, 05:49 AM
  #11  
Registered User
Thread Starter
 
Join Date: Feb 2019
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
@87-4Runner Iíve switched out the fuel filter twice and I know the gas that was in there say for years! I just got the truck from my dad after he had it with the gas sitting for at least a year and Iím not sure how long before that the truck sat not running! Would idiling just burn out all that junk meanwhile adding fresh gas to it solve this issue?
JamesnJensBaby is offline  
Old 02-27-2019, 06:30 AM
  #12  
Registered User
 
87-4runner's Avatar
 
Join Date: Mar 2012
Location: Oklahoma
Posts: 435
Received 43 Likes on 41 Posts
You may have a rusty tank or moisture in your fuel from condensation....
I'd siphon out the old fuel and get fresh or at least add some water removal additive and a can of seafoam....
87-4runner is offline  
Old 02-27-2019, 06:43 AM
  #13  
Registered User
Thread Starter
 
Join Date: Feb 2019
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
I will check that tonight and cross my fingers thatís what it is ! The first fuel filter we pulled off was full of what looked like dirt but now thinking it could of been rust... thank you !!! Iíll post what the outcome is
JamesnJensBaby is offline  
Old 02-28-2019, 08:08 AM
  #14  
Registered User
Thread Starter
 
Join Date: Feb 2019
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Success!!! emptied the gas out of the tank along with what looked like silt and filled up with fresh gas..... drove around about 20 minutes with no problems at all.
I changed fuel filter twice
changed fuel pump twice
changed out old fuel lines
rebuilt carb
replaced alternator
new battery
new transmission
new plugs
new wiring
new distributor
that's was all just to get it running!

Next it goes for Paint, window tint, a 4inch lift, rims and tires, and new upholstery,... ill post some before and after and some progress pictures!

Last edited by JamesnJensBaby; 02-28-2019 at 08:10 AM.
JamesnJensBaby is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
The BeeMan
86-95 Trucks & 4Runners
0
02-20-2015 04:04 PM
notagain
Newbie Tech Section
0
03-11-2014 05:24 AM
chrisj345
Pre 84 Trucks
16
07-14-2010 10:13 AM
John911
86-95 Trucks & 4Runners
4
08-20-2008 06:05 PM
Maverick2004
95.5-2004 Tacomas & 96-2002 4Runners
1
06-16-2004 02:28 PM


Thread Tools
Search this Thread
Quick Reply: '86 Toyota Pickup Stall once put in gear


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: