87 4runner keeps high rpm - YotaTech Forums



4Wheeling 101 Discussion pertaining to the proper use of your off road gear and recovery techniques

87 4runner keeps high rpm

Reply
 
LinkBack Thread Tools Search this Thread
Old 10-10-2013, 07:51 PM   #1
Registered User
Thread Starter
 
Join Date: Oct 2013
Posts: 4
87 4runner keeps high rpm

I have a 22r 87 4runner with manual tranny, when I come to a stop my engine keeps a high rpm until I put a load on it or just gas it a little bit, how do I resolve this.
87snowrunner is offline   Reply With Quote
Old 10-10-2013, 08:29 PM   #2
Contributing Member
 
bob200587's Avatar
 
Join Date: Feb 2005
Location: Nashville, TN
Posts: 3,546
Dash pot is probably all out of whack or it could be the throttle needs adjusting.

I've had the same issue.
bob200587 is offline   Reply With Quote
Old 05-21-2014, 10:59 AM   #3
Registered User
 
Join Date: May 2014
Location: Pnw Washington
Posts: 12
Quote:
Originally Posted by 87snowrunner View Post
I have a 22r 87 4runner with manual tranny, when I come to a stop my engine keeps a high rpm until I put a load on it or just gas it a little bit, how do I resolve this.
I am having the same issue did u ever get it resolved it is driving me nuts!!
slg4runner1988BNB is offline   Reply With Quote
Old 05-21-2014, 11:21 AM   #4
Registered User
 
nacheswheelin's Avatar
 
Join Date: May 2014
Posts: 23
Could be a vacuum leak?
nacheswheelin is offline   Reply With Quote
Old 05-21-2014, 05:43 PM   #5
Registered User
 
Join Date: May 2014
Location: Pnw Washington
Posts: 12
Quote:
Originally Posted by nacheswheelin View Post
Could be a vacuum leak?
I checked all the vacuum lines no apparent leaks... I can start it and it will have the cold start high idle.. Which is normal upon startup... But every time I drive and let off the gas it will idle up or stay at a high idle... I can press the gas quickly and it will go away until I rev it up again and it will stay at high idle ... It does this every time I let of the gas...
slg4runner1988BNB is offline   Reply With Quote
Old 05-21-2014, 06:26 PM   #6
Registered User
 
nacheswheelin's Avatar
 
Join Date: May 2014
Posts: 23
Quote:
Originally Posted by slg4runner1988BNB View Post
I checked all the vacuum lines no apparent leaks... I can start it and it will have the cold start high idle.. Which is normal upon startup... But every time I drive and let off the gas it will idle up or stay at a high idle... I can press the gas quickly and it will go away until I rev it up again and it will stay at high idle ... It does this every time I let of the gas...
What rpm are you sitting at? It is fuel injection right?
nacheswheelin is offline   Reply With Quote
Old 05-21-2014, 08:32 PM   #7
Registered User
 
Join Date: May 2014
Location: Pnw Washington
Posts: 12
Quote:
Originally Posted by nacheswheelin View Post
What rpm are you sitting at? It is fuel injection right?
Yes fuel injection 22re... Regular idle is about 1000 and the high idle until I tap the gas after every time I use the throttle is 1400
slg4runner1988BNB is offline   Reply With Quote
Old 07-09-2014, 08:08 AM   #8
Registered User
 
Join Date: Mar 2014
Posts: 14
My runner does the same thing. Well it just started doing it about two months ago. I'd love to hear what y'all think it is.
ScottieP13 is offline   Reply With Quote
Old 07-09-2014, 08:18 AM   #9
Registered User
iTrader: (1)
 
Join Date: Mar 2013
Location: Mobile, Alabama
Posts: 2,121
Quote:
Originally Posted by slg4runner1988BNB View Post
I checked all the vacuum lines no apparent leaks... I can start it and it will have the cold start high idle.. Which is normal upon startup... But every time I drive and let off the gas it will idle up or stay at a high idle... I can press the gas quickly and it will go away until I rev it up again and it will stay at high idle ... It does this every time I let of the gas...
Is the throttle sticking slightly open? Cleaned the IAC? I believe 22re's have one…
JasonYota is offline   Reply With Quote
Old 04-30-2017, 07:53 PM   #10
Registered User
 
Join Date: Feb 2017
Location: Couer D Alene Idaho
Posts: 51
Quote:
Originally Posted by 87snowrunner View Post
I have a 22r 87 4runner with manual tranny, when I come to a stop my engine keeps a high rpm until I put a load on it or just gas it a little bit, how do I resolve this.
My 88 22re efi does the same thing. Its off and on. I have asked this and people are saying to take a look at the throttle position sensor (TPS). Im planning on trying to fix the problem when I get a break in work.
88mtnrunner is offline   Reply With Quote
Old 05-01-2017, 09:35 AM   #11
Registered User
 
gsp4life's Avatar
 
Join Date: Feb 2015
Location: Marietta, Ohio
Posts: 345
I also had this problem and it was the dashpot. Just pull the hose on the tb that has the little plastic valve dangling at the end of it. If the problem's gone, there's your culprit. You can also adjust the little screw on the throttle higher or remove it so the dashpot spring doesn't depress anymore. It's not easily serviceable and I haven't found anyone that makes a new plastic valve so it's gone on my truck. Fortunately, I'm emissions exempt here.
gsp4life is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Icentropy's $400 4runner build icentropy 86-95 Trucks & 4Runners 17 03-02-2017 12:38 PM
White tire letters in, or white letters out? Scenic WonderRunner Off Topic Talk 36 03-03-2016 07:37 PM
93 4runner MTLroadierunner Newbie Tech Section 3 07-15-2015 12:58 PM
94' Pickup ZUK Mod - What Springs? Nickdigg 86-95 Trucks & 4Runners 1 07-07-2015 06:04 AM
93 runner build MTLroadierunner 86-95 Trucks & 4Runners 0 07-06-2015 12:17 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 12:39 AM.


2010 InternetBrands, Inc.
 
  • Ask a Question
    Get answers from community experts
What's your question?
Send