YotaTech Forums  

Go Back   YotaTech Forums > Toyota SUV & Truck Tech > 95.5-2004 Tacomas & 96-2002 4Runners
Sign in using an external account
Register Forgot Password?
Search


95.5-2004 Tacomas & 96-2002 4Runners 4th gen pickups and 3rd gen 4Runners

Welcome to Yotatech!
Welcome to Yotatech,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
LinkBack Thread Tools Search this Thread
Old 04-13-2003, 11:58 AM   #1
Registered User
Personal Sales Rating: (0)
 
Join Date: Jan 2003
Location: san diego, CA
Posts: 15
tacoma cruise control problems

I just bought a used Toyota tacoma 2000 ex cab truck but just found out that the cruise control doesnt work on it. I do know that the "cruise control" light (on the dash board) comes up and doesn't flash. Nothing happens when i "Set" the CC. I checked under the hood and the connector to the CC unit connector seems fine, its connected to the throttle body fine too....any suggestions? i believe this was a factory installed option when truck was purchased (i have the window sticker).

Thanks,

regis
This ad is not displayed to registered members.
Register your free account today and become a member on Yotatech!
regisphilbin is offline   Reply With Quote
Old 04-14-2003, 12:41 PM   #2
Registered User
Personal Sales Rating: (0)
 
Join Date: Jan 2003
Location: san diego, CA
Posts: 15
anyone?
regisphilbin is offline   Reply With Quote
Old 04-14-2003, 12:54 PM   #3
Contributing Member
Personal Sales Rating: (0)
 
rimpainter.com's Avatar
 
Join Date: Jan 2003
Posts: 10,916
1. Did you check the CC fuse?

2. Is the CC throttle linkage hooked up?

3. Are you sure you are operating it correctly?
(Push set, then push down on the tree)

4. How many miles do you have?

Last edited by rimpainter.com; 04-14-2003 at 12:57 PM.
rimpainter.com is offline   Reply With Quote
Old 04-14-2003, 01:15 PM   #4
Registered User
Personal Sales Rating: (0)
 
zedex's Avatar
 
Join Date: Mar 2003
Location: British Columbia
Posts: 397
Regis?? I had the same problem with my 98 Taco. Cruize wouldnt work. It turns out i didnt know how to use it properly. The cruize light shouldnt blink. And with mine i have to hold the set button till the servo catches up witth the speed im going. With mine anyways, you cant just hit the set button. You have to hold it until you can feel the petal depress from the servo. Read your manual. Hope that help ya a bit.
__________________
Zedex
zedex is offline   Reply With Quote
Old 04-14-2003, 03:22 PM   #5
Registered User
Personal Sales Rating: (0)
 
Join Date: Jan 2003
Location: san diego, CA
Posts: 15
thanks 96 runner...i'll look into the CC fuse tonight...i did check the engine and the throttle linkage is hooked up....the truck has 80k miles on it..

zedex...i've held the CC to "Set" for over 10 seconds before and it hasn't latched. I had a 94 SR5 truck and its CC worked just fine...


someone mentioned that the CC ECU is to the right and below the glove compartment box where the passengers right foot would be?
regisphilbin is offline   Reply With Quote
Old 04-14-2003, 06:02 PM   #6
Registered User
Personal Sales Rating: (0)
 
Join Date: Mar 2003
Location: Moncton NB, CA
Posts: 21
My cruise control was operating irratically a few months ago. The problem was very stupid. There's a switch that should make contact when the clutch pedal is released. It was not closing because I lost a little bushing that goes between the cutch pedal and the spring and that gave it enough slack so the switch was not closing.

The cruise control ecu won't activate until that switch is closed. But I did have a light when I was turning on the system.

When mine is not engaging, I just pull on the clutch pedal to make sure it closes that switch and bingo!
__________________
Chris

2000 s/c'ed Tacoma, w/fuel mods
future Mods : SMT6 or Other
juicyfruity is offline   Reply With Quote
Old 04-15-2003, 07:06 AM   #7
Registered User
Personal Sales Rating: (0)
 
Join Date: Jan 2003
Location: san diego, CA
Posts: 15
thanks juicyfruity...i'll check the switch....

Regis
regisphilbin is offline   Reply With Quote
Old 04-18-2003, 01:46 PM   #8
Registered User
Personal Sales Rating: (0)
 
Join Date: Jan 2003
Location: san diego, CA
Posts: 15
ok,

after a bit of testing, i'm still at a loss...

1) I've checked all the fuses associated with the cruise control. None bad.

2) no OBDII errors...

any other suggestions?
regisphilbin is offline   Reply With Quote
Old 04-18-2003, 02:01 PM   #9
Contributing Member
Personal Sales Rating: (0)
 
rimpainter.com's Avatar
 
Join Date: Jan 2003
Posts: 10,916
Quote:
Originally posted by regisphilbin
ok,

after a bit of testing, i'm still at a loss...

1) I've checked all the fuses associated with the cruise control. None bad.

2) no OBDII errors...

any other suggestions?
The CC "stock" itself may be bad. You know, the part you are pushing down on. I dont know how to get that out of the steering wheel, but it might be your problem.
rimpainter.com is offline   Reply With Quote
Old 04-18-2003, 02:03 PM   #10
Registered User
Personal Sales Rating: (0)
 
Join Date: Jan 2003
Location: san diego, CA
Posts: 15
what do you mean by "stock"? the "Set" Switch in the steering column?
regisphilbin is offline   Reply With Quote
Old 06-27-2006, 09:06 PM   #11
Registered User
Personal Sales Rating: (0)
 
Join Date: Sep 2003
Location: Willington, CT
Posts: 119
Send a message via Yahoo to Cardiac
He means "stalk".
__________________
-Ken
1991 Toyota MR2 Turbo - 3S-GTE
1997 Toyota Tacoma - X-cab, 3RZ-FE
Cardiac is offline   Reply With Quote
Old 06-27-2006, 09:06 PM
Yotatech
4WD Truck




Paid Advertisement
Reply

Tags
04, 1997, 2000, 97, control, cruise, ecu, issues, light, problem, problems, set, tacoma, toyota, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise Control calebpwarren General Electrical & Lighting Related Topics 4 04-05-2007 06:46 AM
Cruise Control PeanutRanger 86-95 Trucks & 4Runners 2 08-19-2006 09:10 AM
Cruise Control issue kev93p-up 95.5-2004 Tacomas & 96-2002 4Runners 5 10-08-2005 03:52 PM
1995 lc cruise control problems fastv6 Early Land Cruisers 1 06-26-2004 03:27 PM
Cruise Control Help colsoncj 95.5-2004 Tacomas & 96-2002 4Runners 15 06-20-2004 09:31 PM


All times are GMT -8. The time now is 07:44 AM.


2010 InternetBrands, Inc.