Spark Plugs - YotaTech Forums


Go Back   > >


95.5-2004 Tacomas & 96-2002 4Runners 4th gen pickups and 3rd gen 4Runners

Spark Plugs

Reply
 
LinkBack Thread Tools Search this Thread
Old 03-21-2007, 11:30 PM   #1
Banned
Thread Starter
 
Join Date: Mar 2007
Posts: 64
Spark Plugs

Havent had new ones in about 50,000. Do i need em? lol.
BYAHnate is offline   Reply With Quote
Old 03-21-2007, 11:32 PM   #2
Contributing Member
 
Elton's Avatar
 
Join Date: Jul 2005
Location: Siletz,Oregon
Posts: 12,261
couldint hurt make sure there factory denso's or ngk dual ground install is very easy
Elton is offline   Reply With Quote
Old 03-22-2007, 06:02 AM   #3
Registered User
 
gpcollen1's Avatar
 
Join Date: Mar 2006
Location: Connecticut (NY State of Mind)
Posts: 452
I think 50k is getting to be about time.
gpcollen1 is offline   Reply With Quote
Old 03-22-2007, 06:09 AM   #4
Registered User
 
mkgarrison5's Avatar
 
Join Date: Feb 2007
Location: NC
Posts: 1,511
Quote:
Originally Posted by BYAHnate View Post
Havent had new ones in about 50,000. Do i need em? lol.
change em up
mkgarrison5 is offline   Reply With Quote
Old 03-22-2007, 06:14 AM   #5
Registered User
 
91TPU's Avatar
 
Join Date: Oct 2006
Location: NorthWest NJ
Posts: 1,589
itll do your motor good...switch em up with NGK's or Denso dual electrodes.
91TPU is offline   Reply With Quote
Old 03-22-2007, 06:50 AM   #6
Contributing Member
 
MTL_4runner's Avatar
 
Join Date: Jul 2003
Location: Montreal, QC Canada
Posts: 8,807
Quote:
Originally Posted by gpcollen1 View Post
I think 50k is getting to be about time.
More like 30K is getting to be about time.



so 50k miles = way overdue

Last edited by MTL_4runner; 03-22-2007 at 06:51 AM.
MTL_4runner is offline   Reply With Quote
Old 03-22-2007, 06:56 AM   #7
Contributing Member
 
Tanto's Avatar
 
Join Date: Oct 2005
Location: Smoky San Diego
Posts: 2,346
Make sure you re-gap them. You can see the difference in the picture Jamie posted.

OEM Specs say .044, the sparkplugs FROM TOYOTA come gapped at .034
Tanto is offline   Reply With Quote
Old 03-22-2007, 06:58 AM   #8
Contributing Member
 
Chapman88SR5's Avatar
 
Join Date: Jun 2004
Location: wisconsin
Posts: 1,428
Has anyone ever experienced ill side affects using a different brand plugs and wires?
Chapman88SR5 is offline   Reply With Quote
Old 03-22-2007, 07:04 AM   #9
Registered User
 
profuse007's Avatar
 
Join Date: Apr 2006
Location: TX
Posts: 503
I have used Bosh brand wires on different vehicles and they're sux in every way. although it work, the manufacturing quality is very poor.

I have never use bosch plugs, only denso or ngk.
profuse007 is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
94 pickup 22re sluggish bogging idle issues montanatruck 86-95 Trucks & 4Runners 14 04-21-2016 04:52 PM
Code 25 issues raptor510 86-95 Trucks & 4Runners 18 08-19-2015 02:15 PM
22r Smog troubles accuracy 86-95 Trucks & 4Runners 6 08-04-2015 08:05 PM
CODE issue. SOS HELP! raptor510 86-95 Trucks & 4Runners 14 07-31-2015 04:38 PM
FS[SouthEast]: 1995 4Runner 4x4 3.0L Auto - Overland/Offroad/Camping Ready $3500 - Clearwater,FL defrag4 Vehicles - Trailers (Complete) 0 07-31-2015 10:50 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 06:28 AM.


2010 InternetBrands, Inc.