O2 sensor Replacement - YotaTech Forums


Go Back   >


95.5-2004 Tacomas & 96-2002 4Runners 4th gen pickups and 3rd gen 4Runners
Sponsored by:
Click Here

O2 sensor Replacement

Reply
 
LinkBack Thread Tools Search this Thread
Old 05-19-2005, 03:10 PM   #1
Registered User
Thread Starter
 
george16's Avatar
 
Join Date: Sep 2002
Location: Florida
Posts: 511
O2 sensor Replacement

I"m in the process of replacing the front O2 sensor and I was surprised to see 3 rows (18 total) of holes on the original and 4 rows (24 total) for the O2 sensor I bought from URD. I chose 234-4161 from their site because I have the 49 state manual V6 4WD 1999 4runner. Can any body confirm if the extra holes would not matter at all? I haven't install until somebody can tell me if this is the right sensor. Thank you very much.

George
george16 is offline   Reply With Quote
Old 05-19-2005, 03:32 PM   #2
Registered User
Thread Starter
 
george16's Avatar
 
Join Date: Sep 2002
Location: Florida
Posts: 511
confused

Just for kicks, I decided to remove the sensor after the cat and i was surprised to see that it has the same number of holes like the sensor I received from URD. They match in size and number of holes. Now I'm confused if I got a front sensor from URD or a back one. Please help.

George
george16 is offline   Reply With Quote
Old 05-19-2005, 05:20 PM   #3
Registered User
Thread Starter
 
george16's Avatar
 
Join Date: Sep 2002
Location: Florida
Posts: 511
Update

Here's the e-mail I received from Gadget with regards to the O2 sensor I just installed.

You have the correct part. It will appear to be slightly different, but it is the correct part. Denso makes two versions, one they sell to Toyota that they can not sell to anyone else, and a slightly different one that they can sell aftermarket through us. It will work just like the Toyota one.

Gadget


For those of you who have a manual trans, you can access the connector by removing the shifter and reaching in to disconnect it. The connector is mounted above the trans and it's a pain in the a$$ to get to it from underneath the truck. My dig camera is dead so no pics.

Last edited by george16; 05-19-2005 at 05:24 PM.
george16 is offline   Reply With Quote
Old 02-08-2013, 05:52 AM   #4
Registered User
 
Join Date: Jan 2013
Posts: 2
I replaced the sensor on the catalyic converter but the check engine light keeps coming back on. This is on a 2005 Toyota Tundra V8. Help!!
jimmergb1 is offline   Reply With Quote
Old 02-08-2013, 07:09 AM   #5
Registered User
iTrader: (1)
 
aa1911's Avatar
 
Join Date: Sep 2009
Location: Western Washington
Posts: 1,256
Quote:
Originally Posted by jimmergb1 View Post
I replaced the sensor on the catalyic converter but the check engine light keeps coming back on. This is on a 2005 Toyota Tundra V8. Help!!
Need some more info, what code is the CEL? That will point you in the right direction. Autozone reads the code for free if you haven't already.

Not sure if you have one or two sensors, the one that is upstream from the cat converter is the one that is important to engine input for air/fuel ratio.
aa1911 is offline   Reply With Quote
Old 02-08-2013, 10:54 AM   #6
Registered User
 
Join Date: Jan 2013
Posts: 2
02 sensor

I asume you mean the fault that came up on the code reader. It said "bank 1 sensor 2"

Thanks,
jimmergb1 is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1985 22r pickup, no spark but engine cranks sandyota 84-85 Trucks & 4Runners 3 05-12-2016 05:04 PM
ENGINE TROUBLE 3vze please help :( smiley52 86-95 Trucks & 4Runners 8 07-11-2015 05:16 AM
2000 camry wont start Huntingtruckcletus Other Makes Cars/Trucks 0 07-08-2015 05:26 PM
speedometer 'freaking out' wilbertd 86-95 Trucks & 4Runners 2 07-06-2015 07:39 AM


Tags
4runner, o2, replacement, sensor, toyota

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 10:41 AM.


2010 InternetBrands, Inc.