Engine running rich. Possible cause = ? - YotaTech Forums


Go Back   >


95.5-2004 Tacomas & 96-2002 4Runners 4th gen pickups and 3rd gen 4Runners
Sponsored by:
Click Here

Engine running rich. Possible cause = ?

Reply
 
LinkBack Thread Tools Search this Thread
Old 05-01-2008, 05:35 AM   #1
Registered User
Thread Starter
 
Join Date: Jun 2002
Location: Charlesbourg (Qc)
Posts: 188
Engine running rich. Possible cause = ?

I'm selling my truck and don't want any problems afterwards.

I keep getting a P0172 code (running rich).

I changed the dirty K&N and put back the stocker back in, and it went from throwing a CEL like twice a day to once every two days, or twice a week.

What could cause that?
Hugo is offline   Reply With Quote
Old 05-01-2008, 07:38 AM   #2
Contributing Member
 
BajaRunner's Avatar
 
Join Date: Apr 2004
Location: 5th Gen San Diegan, California
Posts: 7,120
First thing Id do is clean the mass air flow sensor (MAF). Do some searching if you will. But, basically, its the unit which sits right behind the airbox and inline of the intake tube which runs to the throttle body.

Get electric contact cleaner or they actually sell MAF cleaner as well, spray it down, wait for it to dry, and reinstall 1 hr done deal.
BajaRunner is offline   Reply With Quote
Old 05-01-2008, 07:51 AM   #3
Registered User
 
mkgarrison5's Avatar
 
Join Date: Feb 2007
Location: NC
Posts: 1,511
glad you ditched the K&N... such a waste of $$ and to top it off they can cause problems esp when over oiled..
mkgarrison5 is offline   Reply With Quote
Old 05-01-2008, 05:30 PM   #4
Registered User
 
Yota Doc's Avatar
 
Join Date: Aug 2007
Location: Farmerville,La.
Posts: 33
Like how rich? Black smoke coming from the exaust rich, I know it was enough to throw a code. You can also try the fuel pressure regulator. Good luck.

Last edited by Yota Doc; 05-01-2008 at 05:31 PM.
Yota Doc is offline   Reply With Quote
Old 05-02-2008, 05:46 AM   #5
Registered User
Thread Starter
 
Join Date: Jun 2002
Location: Charlesbourg (Qc)
Posts: 188
No idea how rich, really... I don't follow myself

I'll clean the MAF and hope for the best.
Hugo is offline   Reply With Quote
Old 05-02-2008, 10:03 AM   #6
Registered User
 
Yota Doc's Avatar
 
Join Date: Aug 2007
Location: Farmerville,La.
Posts: 33
I walked in to that one.
Yota Doc is offline   Reply With Quote
Old 05-02-2008, 11:43 AM   #7
Registered User
 
bwhyit's Avatar
 
Join Date: Nov 2006
Location: Cincinnati
Posts: 233
I know cleaning the MAF is the generic answer for everything but a dirty MAF will cause a lean condition not a rich one.

My bet is AF/O2 sensor if you want a generic answer. If you actually want to diagnose the problem then start with these items: fuel pressure (high), leaking injector, coolant temp sensor, exhaust leak before the O2 sensor. Any of these could cause a rich condition.

Contrary to popular belief, you can diagnose most problems without just throwing parts at the problem.

PM me if you need any service manual info. I can probably help out.

Last edited by bwhyit; 05-02-2008 at 11:47 AM.
bwhyit is offline   Reply With Quote
Old 05-02-2008, 02:34 PM   #8
Contributing Member
 
turboale's Avatar
 
Join Date: Jun 2002
Location: Brooklyn, NY
Posts: 4,868
Sounds like it needs more air, you definitely need a supercharger...
turboale is offline   Reply With Quote
Old 05-02-2008, 11:01 PM   #9
Registered User
 
alotawatts's Avatar
 
Join Date: Jan 2006
Location: N.Seattle
Posts: 118
Search Challenged

Checked Tech-Write-ups and searched Forum for MAF cleaning / write-up/pics. No can find....?
alotawatts is offline   Reply With Quote
Old 05-03-2008, 01:29 AM   #10
Registered User
Thread Starter
 
Join Date: Jun 2002
Location: Charlesbourg (Qc)
Posts: 188
Quote:
Originally Posted by turboale View Post
Sounds like it needs more air, you definitely need a supercharger...
LOL!

Nah, it's sold already, I'm just waiting for my Legacy 2.5 GT Wagon to arrive to let it go.
Hugo is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
RedRunner_87's aka "Operation Mall Crawler" Build Thread RedRunner_87 95.5-2004 Tacomas & 96-2002 4Runners (Build-Up Section) 44 06-11-2016 06:21 PM
87 22r rebuild issue bigjstang 86-95 Trucks & 4Runners 10 06-10-2016 06:15 PM
83 pickup lift and engine rebuild God's Bounty Hunter Pre 84 Trucks 6 07-08-2015 12:54 PM
Wiring help toyotamonster 3.4 Swaps 2 07-08-2015 09:17 AM
4runner stalling in gear... Do this again please Jnkml 95.5-2004 Tacomas & 96-2002 4Runners 3 07-06-2015 01:20 PM


Tags
2002, 95, air, code, engine, flow, legacy, mass, p0172, petrol, reasons, rich, run, running, subaru

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 03:29 PM.


2010 InternetBrands, Inc.