04 Tacoma, can't fill up with gas? - YotaTech Forums
YotaTech Forums  

Go Back   YotaTech Forums > Toyota SUV & Truck Tech > 95.5-2004 Tacomas & 96-2002 4Runners
Search


95.5-2004 Tacomas & 96-2002 4Runners 4th gen pickups and 3rd gen 4Runners

04 Tacoma, can't fill up with gas?

Reply
 
LinkBack Thread Tools Search this Thread
Old 03-05-2006, 11:48 AM   #1
Registered User
Personal Sales Rating: (0)
 
Join Date: Mar 2006
Posts: 3
04 Tacoma, can't fill up with gas?

I tried the search feature..with no luck. I have a 2004 Tacoma, 4cyl/ 2x4/5 spd. I tried to get gas yesterday, but couldn't get the nozzle to keep a vacuum seal on my filler tank. I though it was just the gas nozzle...it kept shutting itself off after several re-adjustments. I got to about 4 dollars and gave up. Then my wife drove the truck, tried to fill up at a different place, same problem. Then this morning, I got my first ever check engine light (41,958 miles) and still can get a good seal when I try to gas up. I'm guessing it's related but haven't had a chance to get the code pulled. Anyone else ever have this happen? I'm a honda guy, this is my first Toyota. I love the truck, just a bit lost.
Thanks in advance.
terble250 is offline   Reply With Quote
Old 03-05-2006, 12:36 PM   #2
Contributing Member
Personal Sales Rating: (0)
 
Paul H.'s Avatar
 
Join Date: Jun 2002
Location: Eastern NC
Posts: 7,414
How much gas is in the tank? Have never heard of this happening. Have you checked to make sure there is no obstruction in the filler neck?
__________________
92 4Runner SR5 V6 4X4
Skyjacker Nitro shocks, Pro-Comp steering stabilizer, clear bumper lenses, lund windjammer, OME standard coils, ISR mod, inlet pipe removed, Bushwaker Fender Flares.

2002 Tacoma Prerunner V6 Xtracab. Lund Intercepter bug guard, rear glass sunshield, Bilstein shocks on rear. - Sold

2004 Honda CRV EX stock belongs to wife.

2010 Corolla S, no mods yet.

Quote:
Originally Posted by habanero View Post
I did a lot of masticating today.....and now I'm going to go do some more.
Paul H. is offline   Reply With Quote
Old 03-05-2006, 12:40 PM   #3
Registered User
Personal Sales Rating: (0)
 
sasquatch's Avatar
 
Join Date: Feb 2006
Location: Wa Coast
Posts: 105
Send a message via MSN to sasquatch
Never heard of this either. I have an 04 also....never any troubles
__________________
04 Qcab TRD - Toytec Lift w/aal - Leer 100XQ Canopy w/Yakima Rack - 110watt back-up lights - Toyo Open Country Tires - 16x8 Ultra BajaChamp Wheels - Billet Grille - Spray-In Bedliner


Future Mods---Badland Bumpers F&R, with winch, Gray Wire Mod/HiLo Mod, Fox Coilovers

http://img.photobucket.com/albums/v8...ToyotaQcab.jpg
sasquatch is offline   Reply With Quote
Old 03-05-2006, 12:45 PM   #4
Contributing Member
Personal Sales Rating: (0)
 
Silver_Truck's Avatar
 
Join Date: Oct 2004
Location: B'ham, WA
Posts: 1,817
vacuum seal? is that something on the newer trucks? mine just pours in. I'd check for blockage
__________________
-Geoff
*1991 Toyota Pickup Ext. Cab SR5 4x4 V6 5 spd K&N intake, port & polished heads with OS valves, port & polished intake manifold and plenum, NWOR headers and crossover, NWOR catback, Denso Iridium plugs, Redline Fluids, 4.88s, Rear LockRight, Aisin hubs, Chevy springs, BJ spacers, 2" RB body lift, 34x10.5 Swamper LTBs, WolphisWorks Sliders and bumpers, 400,000 mi.
Silver_Truck is offline   Reply With Quote
Old 03-05-2006, 01:30 PM   #5
Registered User
Personal Sales Rating: (0)
 
Join Date: Aug 2003
Posts: 99
Could it be a broken gas gauge and the tank is already full?
Ishinc is offline   Reply With Quote
Old 03-05-2006, 01:39 PM   #6
Registered User
Personal Sales Rating: (0)
 
Join Date: Nov 2005
Location: Boston, MA
Posts: 45
Send a message via AIM to BustedTaco
The check engine light could be from not tightening the gas cap enough. As for the filling problems, I don't really know. I know at certain pumps I really need to keep pressure on the nozzle to keep it far enough down the filler neck so it won't shut itself off; others I could almost hold it above the filler neck and let it pour in.
__________________
'98 Taco
Regular Cab 4x4
2.7L 5-speed

TJM Front Bumper
31x10.50R15 BFG A/Ts
3" Revtek Spacers on D-cab coils
1.5" Shackles
BustedTaco is offline   Reply With Quote
Old 03-05-2006, 05:31 PM   #7
Registered User
Personal Sales Rating: (0)
 
TACOMANATOR's Avatar
 
Join Date: Sep 2003
Location: Littleton, CO
Posts: 643
There should be a vent for air/fumes attached to your tank. When you fill up with gas the fumes vent to the outside. If this vent (should be a hose attached to it) is blocked it would cause what you are describing. I'm at work and its dark so I can't confirm this, but my previous vehicle and my boat have one.
__________________
2000 Taco SR5 V6 5speed TRD
Airaid MIT
Vortex muffler
DEI 2-way
Extang Tuff Tonno III
TACOMANATOR is offline   Reply With Quote
Old 03-05-2006, 06:28 PM   #8
Registered User
Personal Sales Rating: (0)
Threadstarter [OP]
 
Join Date: Mar 2006
Posts: 3
I appreciate everyone's help..i'm kinda at a loss..It's not the gauge...if I sit there long enough I can put in 10 Gallons..it's just taking 45 minutes. No matter how I angle the gas nozzle..it just keeps shutting off. Eveyone seem to think it's user error (me) and I don't blame them. What I did notice is when I push down on the filler neck..there seems to be alot of movement from the neck itself. This may keep me from being able to fully engage whatever it is on the gas nozzle that lets the good stuff flow. I never heard about the vent hose thing. I will check into that. Wife is gonna fly by the dealer to have the code checked and I'll post what they find. Even if it's that I suck and need to learn to pump gas. This is my first time on this site and I appreciate everyone's prompt replys.
Thanks.
terble250 is offline   Reply With Quote
Old 03-05-2006, 06:48 PM   #9
Registered User
Personal Sales Rating: (0)
 
Cebby's Avatar
 
Join Date: Sep 2002
Location: Pittsburgh, PA
Posts: 11,199
Send a message via AIM to Cebby
Don't insert the nozzle fully. Bottom it then pull it back maybe a 1/2".
Cebby is offline   Reply With Quote
Old 03-05-2006, 06:49 PM   #10
Registered User
Personal Sales Rating: (0)
 
mudnsnow's Avatar
 
Join Date: Aug 2005
Location: Menasha, WI
Posts: 106
Go to auto zone

Go to auto zone and get the code checked, its free!
__________________
Looking for the perfect truck after toyota bought back my tacoma!!

O6 Tundra Double Cab 4x4

99 4Runner

Blake Joseph Born 12/08/08

GOT MARRIED 10/27/07!!!
mudnsnow is offline   Reply With Quote
Old 03-05-2006, 07:05 PM   #11
Registered User
Personal Sales Rating: (0)
 
Godzilla's Avatar
 
Join Date: Mar 2004
Location: Vancouver
Posts: 2,171
Quote:
Originally Posted by mudnsnow
Go to auto zone and get the code checked, its free!
definitely get your code checked as stated. this kinda happens to me on my runner. Sometimes when i put the nozzle all the way in and put the flow of fuel to full blast it clicks prematurely..so i just raise it out about an inch from all the way in and only depress the gas lever to about half for a slower fill,,,but it only takes me a few minutes to fill up.
Godzilla is offline   Reply With Quote
Old 03-05-2006, 09:43 PM   #12
Registered User
Personal Sales Rating: (0)
 
bigacuralvr's Avatar
 
Join Date: Dec 2005
Location: Evans/Greeley, CO
Posts: 289
Send a message via AIM to bigacuralvr Send a message via Yahoo to bigacuralvr
Hmmm....my guess is that there is something down the filler neck that is obstruction a full/fast fill. The nozzle shuts off as soon as fluid hits the end of the nozzle. So, it may be going down the neck, but no draining into the tank faster than its pumping in the neck. Try barely putting the nozzle in, and see if you can see the gas overflowing in the neck. Have you noticed an worse gas milage, or noticed anything else??
__________________
Current:

94 4Runner SR5 3.Slow...for now.

SOLD. :(
99 4Runner Limited SuperCharged, Hood Scoop, Westin Bull Bar, PIAA 510's, PIAA GTX Heads and Fogs, ProComp 1069's, True Flow Intake, Jardine Exhaust, Red Interior Lights, Other Little Stuff...
bigacuralvr is offline   Reply With Quote
Old 03-06-2006, 12:05 PM   #13
Registered User
Personal Sales Rating: (0)
 
ricky's Avatar
 
Join Date: Jul 2005
Location: Denver, CO
Posts: 168
What do you mean by the fact that you couldn't keep a vacuum seal? Are you in California? I've never heard of a pump that requires a vacuum seal to dispense gas.
ricky is offline   Reply With Quote
Old 03-06-2006, 02:08 PM   #14
Registered User
Personal Sales Rating: (0)
Threadstarter [OP]
 
Join Date: Mar 2006
Posts: 3
Ok..just got back from the dealer...and here's what we got...The check engine light was caused by the pnumatic fuel route being obstructed by the orientation of the flux timing gear. I wish...the vacuum hose on the airbox (airfilter) came unplugged. As for the reason I couldn't get the tank to fill up (keeping in mind i've been putting gas in this monster for the last two years with no problems) They couldn't find anything wrong with the filler/neck/tank or anything. They put the hose back on the air box, sent me down the road to get gas, and the little slut filled up first try---go figure. My friend is the service manager at the local Toyota dealer by me, so it didn't cost me anything other than some teasing at my lack of mechanical ability--which i'm sure is well deserved. So that's my story, I told you I'd keep it real for ya. Thanks again for all your advice. I would certainly not hesitate to jump back on this site for Toyota info.
-tyson
terble250 is offline   Reply With Quote
Old 03-06-2006, 03:54 PM   #15
Contributing Member
Personal Sales Rating: (0)
 
Paul H.'s Avatar
 
Join Date: Jun 2002
Location: Eastern NC
Posts: 7,414
LOL, glad all is well now.
__________________
92 4Runner SR5 V6 4X4
Skyjacker Nitro shocks, Pro-Comp steering stabilizer, clear bumper lenses, lund windjammer, OME standard coils, ISR mod, inlet pipe removed, Bushwaker Fender Flares.

2002 Tacoma Prerunner V6 Xtracab. Lund Intercepter bug guard, rear glass sunshield, Bilstein shocks on rear. - Sold

2004 Honda CRV EX stock belongs to wife.

2010 Corolla S, no mods yet.

Quote:
Originally Posted by habanero View Post
I did a lot of masticating today.....and now I'm going to go do some more.
Paul H. is offline   Reply With Quote
Old 08-29-2015, 09:05 PM   #16
Registered User
Personal Sales Rating: (0)
 
Join Date: Aug 2015
Posts: 1
I have a 2004 Toyota Tacoma 4x4, I cant fill the tank up, the nozzle keeps kicking off. I have tried other gas stations ,same thing happens, I have taken all the hoses off the charcoal canister and fuel tank and blew through them, even check for obstruction in the filler hose,( all clear).The only thing that I find a little strange is the vent line solenoid is not getting enough voltage in the line going to it to make it work, I did remove and function test the solenoid and it does work? "Puzzling"
Tom@1957 is offline   Reply With Quote
Old 08-30-2015, 03:23 AM   #17
Registered User
Personal Sales Rating: (1)
 
wyoming9's Avatar
 
Join Date: Apr 2009
Location: I live in New Tripoli Pa out in the woods
Posts: 8,685
Red face

Know this is a very old thread !!

Not knowing what state your in and what type of gas nozzles you might have.

Are you sure the pump is not just to fast causing the fuel to back up kicking the nozzle off Some of the nozzles trip real easy to prevent spills

That is the only problem I have ever had

Make some one mad at you something in the filler neck would slow the flow but allow air to blow through quite easy

Weather the Evap system works or not should not effect the filling of the tank.

It vents as soon as the cap is removed
wyoming9 is offline   Reply With Quote
Old 08-30-2015, 05:43 AM   #18
Registered User
Personal Sales Rating: (0)
 
tj884Rdlx's Avatar
 
Join Date: Apr 2007
Location: ATL!
Posts: 1,253
Try putting gas in with a red gas can. Take the can with you, fill it up, pour in truck, repeat.

Gas cans don't auto shut off. =)
__________________
88 4Runner DLX, 15x8 soft8s w/ BFG 33x10.5 A/Ts. 1.5" SDORI spacers, 4.88s, OME CS009s, 1" 4crawler b.l., original Canback top
tj884Rdlx is offline   Reply With Quote
Old 08-30-2015, 06:12 AM   #19
Registered User
Personal Sales Rating: (0)
 
Buckaroo5's Avatar
 
Join Date: Mar 2014
Posts: 19
I would suggest two potential causes - both already discussed in the thread. The first thing I would check is that there are no obstructions in the tube running from the gas port to the tank - just had this issue on a Corolla. Easy to drop something in the gas tank like a foil seal from a fuel treatment bottle. It was stuck at the tank inlet. If that is not the issue, I would check the tank vent to make sure it is not clogged and is open to atmosphere.

Buckaroo
Buckaroo5 is offline   Reply With Quote
Reply

Tags
03, 2003, blocked, fill, filler, fuel, gas, gast, neck, nozzles, overflowing, pump, shuts, slow, tacoma, tank, toyota, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough idle mystery Eggslinger 86-95 Trucks & 4Runners 13 07-15-2015 07:29 AM
Please help! smthwsn357 86-95 Trucks & 4Runners 5 07-09-2015 09:22 AM
4runner stalling in gear... Do this again please Jnkml 95.5-2004 Tacomas & 96-2002 4Runners 3 07-06-2015 01:20 PM
1991 truck 3VZE Help with diagnosis (Results of tests) zd92655 86-95 Trucks & 4Runners 3 07-01-2015 05:48 PM


All times are GMT -8. The time now is 04:17 AM.


2010 InternetBrands, Inc.