YotaTech Forums  

Go Back   YotaTech Forums > Off Road Tech, Fab Shop, Solid Axle Swaps, Tool Time, & Engine Swaps > Engine Swap Talk > 3.4 Swaps
Sign in using an external account
Register Forgot Password?
Search


3.4 Swaps The 3.4 V6 Toyota engine

Welcome to Yotatech!
Welcome to Yotatech,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
LinkBack Thread Tools Search this Thread
Old 07-29-2011, 05:24 PM   #1
Registered User
Personal Sales Rating: (0)
 
Join Date: Jul 2011
Location: maple ridge b.c.
Posts: 7
96 T100 swapped to 97ecm for 1st gen s/c. Now have code p0450. Any way to trick ecm?

Hey fella's i have a 96 T100 that i am going to be installing a 1st gen(grey) s/c on the 3.4 have done some diggin n found that my
96ecm wont work, have swapped in a 97ecm , runs the same as norm but throws code p0450 (evap). I'm guessing the ecm dont realize my truck is not equipped with that system. Anyone run into this? Or have a trick to fool the ecm into thinking i do?
This ad is not displayed to registered members.
Register your free account today and become a member on Yotatech!
Meangreen T100 is offline   Reply With Quote
Old 08-01-2011, 09:57 AM   #2
Registered User
Personal Sales Rating: (0)
 
Join Date: Sep 2006
Location: Junction City, OR
Posts: 421
So your t100 has evap. It just doesn't have what one of the sensors I think? the VPS one? To resolve the issue, you would need to add that in. I honestly can't think of any way around it. Unless you possibly re-flash it? or just live with it. knowing that you have that code. And check it from time to time to make sure you have no others.
__________________
1990 Toyota 4runner 3vze - 5vzfe swap. IFS lift with 35 inch BFG KM2's. Now with ARB, and smittybilt xrc8 winch(thanks truck!!), rear TRD E-Locker 5.29 gears front and rear. Mobile PC, Alpine alarm

1993 Toyota pickup with 3vze. SAS'd running on 37" Super Swamper SSR's. Sold Oct 23rd :( bye little buddy!
hamish_18 is offline   Reply With Quote
Old 08-01-2011, 11:59 AM   #3
Registered User
Personal Sales Rating: (0)
 
Join Date: Jul 2011
Location: maple ridge b.c.
Posts: 7
Yea thats kinda what i figured, sounds like more messing with wires than needed!! I can live with the light on, it only throws that one code and runs great. Thanks for the reply pal!!! Supercharger is goin on this week! Wooo
Meangreen T100 is offline   Reply With Quote
Old 08-02-2011, 11:20 PM   #4
Registered User
Personal Sales Rating: (0)
 
Join Date: Feb 2007
Posts: 440
What did you do to swap that ECU in? Wanna share yer steps? Got any piccies? How long did it take you?
BamZipPow is offline   Reply With Quote
Old 08-03-2011, 06:16 AM   #5
Registered User
Personal Sales Rating: (0)
 
Join Date: Jul 2011
Location: maple ridge b.c.
Posts: 7
Dont have any pics but i'll walk ya through, super easy the ecm on t100's are behind the pass side kick panel, just remove that n you will see it. There is 3 10mm bolts holdin it down, the plugs are the same (for m/t 4wd) ecm's only. Auto trans ecm's are different. Hope that helps a bit.
Meangreen T100 is offline   Reply With Quote
Old 08-03-2011, 06:19 AM   #6
Registered User
Personal Sales Rating: (0)
 
Join Date: Jul 2011
Location: maple ridge b.c.
Posts: 7
Oh yea and timewise it took about 20 mins all said n done, the brackets fit the same on the 97 ecm just remove the black tape covering the screw holes. All ya need is a 10mm socket and phillips driver : )
Meangreen T100 is offline   Reply With Quote
Old 08-03-2011, 06:19 AM
Yotatech
4WD Truck




Paid Advertisement
Reply

Tags
130, 95, 96, 97, 98, code, convert, ecm, ecu, p0450, po450, po450f, swapped, t100, toyota, toyotta

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 05:21 PM.


2010 InternetBrands, Inc.