YotaTech Forums  

Go Back   YotaTech Forums > Toyota SUV & Truck Tech > General Electrical & Lighting Related Topics
Sign in using an external account
Register Forgot Password?
Search


General Electrical & Lighting Related Topics Ask here for electrical, wiring, and lighting info for your rig that could apply to all years

Welcome to Yotatech!
Welcome to Yotatech,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
LinkBack Thread Tools Search this Thread
Old 01-03-2008, 05:40 PM   #1
Registered User
Personal Sales Rating: (0)
 
spanish-road's Avatar
 
Join Date: Mar 2007
Location: Fairbanks Ak
Posts: 1,211
battery light and brake light on

1991 toyota 4x4 22re

Well my brake light is on and battery light is on at the same time, also the voltage is low. I checked the fuses and this has been going on for a few weeks.
This ad is not displayed to registered members.
Register your free account today and become a member on Yotatech!
__________________
What I don't get is why pay someone to work on your vehicle?
1991 toyota pickup extcab- 22re 31x10.5x15 bone stock except for the RV cam and tires.
spanish-road is offline   Reply With Quote
Old 01-03-2008, 05:41 PM   #2
Contributing Member
Personal Sales Rating: (0)
 
linuxrunner's Avatar
 
Join Date: Nov 2005
Location: Gladstone, Oregon
Posts: 851
check the alternator
__________________
88 4runner 22re

Quote:
"Ditch that IFS because it is already crap and go for an SAS! (Single Axle Swap)"
linuxrunner is offline   Reply With Quote
Old 01-03-2008, 05:47 PM   #3
Banned fruitloop
Vendor Sales Rating: (0)
 
4runnerchevy's Avatar
 
Join Date: Jun 2007
Location: Santa Cruz
Posts: 124
Alt.

Agreed. That is your Toyota truck telling you your alternator (or wiring to it) is dead. Check that FIRST!
4runnerchevy is offline   Reply With Quote
Old 01-03-2008, 05:50 PM   #4
Registered User
Personal Sales Rating: (0)
 
Join Date: Jan 2007
Location: Seattle(ish)
Posts: 15
Send a message via AIM to VoxMan
This happened to me on my '95 runner and it turned out i hadn't tightened the alternator bolt so the belt was slipping half the time. Re-tensioned the belt and cranked down on the bolt and no more problems.
__________________
VoxMan
'95 SR5 4Runner (Stock for now)
www.zinniawa.com
VoxMan is offline   Reply With Quote
Old 01-03-2008, 06:44 PM   #5
Registered User
Personal Sales Rating: (0)
 
spanish-road's Avatar
 
Join Date: Mar 2007
Location: Fairbanks Ak
Posts: 1,211
Well I checked it and its on its last leg cause I removed the battery and put in a spare that was new and it did the same thing, also I removed the battery while it was running and it died when it had high beams, brakes, flashers, wipers all on.
__________________
What I don't get is why pay someone to work on your vehicle?
1991 toyota pickup extcab- 22re 31x10.5x15 bone stock except for the RV cam and tires.
spanish-road is offline   Reply With Quote
Old 01-03-2008, 06:54 PM   #6
Banned fruitloop
Vendor Sales Rating: (0)
 
4runnerchevy's Avatar
 
Join Date: Jun 2007
Location: Santa Cruz
Posts: 124
Battery

Truthfully IT IS your Toyota truck, telling you it IS your alternator. Take it out, or not, and test it ! Just my guess !
4runnerchevy is offline   Reply With Quote
Old 01-03-2008, 07:03 PM   #7
Registered User
Personal Sales Rating: (0)
 
williemon's Avatar
 
Join Date: Jun 2002
Location: Georgia
Posts: 811
Had same issues on my 90 runner. It has a volt meter as well and showed alt was not putting out, but then a few miles down the road, it started working fine again. Been doing this every day for the past month. I ordered a brush and holder asy. for the alternator from the toyota place and just installed it. The old one was worn out compared to the new. I have not tested it yet because my intake busted all up taking it out. 30 min job has now turned into an intake mod job.
__________________
90 4 Runner 4x4 V6 Auto, Westin step bars, Eagle rims, DOA head port and camshaft.
94 Toy truck 4x4 22RE 5sp, 31x12.5 BFG muds, eagle rims, Rancho RS9000s, nerfs, ext. shackles. SOLD


http://community.webshots.com/user/williemon
williemon is offline   Reply With Quote
Old 01-03-2008, 09:06 PM   #8
Registered User
Personal Sales Rating: (0)
 
Join Date: Dec 2007
Location: Camino, Ca
Posts: 1,159
Its your alternator. While its running tap on it with something and it might start charging again. You can just replace the internal brushes to fix the problem. DON'T BUY A NEW ALT. ESPECIALLY FROM KRAGEN
toytech76 is offline   Reply With Quote
Old 01-07-2008, 12:15 PM   #9
Contributing Member
Personal Sales Rating: (2)
 
4Crawler's Avatar
 
Join Date: Jun 2002
Location: SF Bay Area, CA
Posts: 10,757
Inexpensive to repair:
http://www.4x4wire.com/toyota/mainte...nator_brushes/

And X2 on repair vs. replace.
__________________
1985 Toyota 4Runner SR-5, 22REC engine, dual t-cases, 4.88 gears, dual ARBs, 33x10.50 BFGs or 35x12.50 MTRs
r.c.brown@ieee.org
TruckEditor@tlca.org
Project: 4Crawler
4Crawler OffRoad - YotaTech discount code
Gettin'Off 4WD Club
4Crawler is offline   Reply With Quote
Old 01-07-2008, 12:44 PM   #10
Registered User
Personal Sales Rating: (0)
 
Join Date: Dec 2007
Location: Camino, Ca
Posts: 1,159
I am gonna be starting to sell brushes for alts. $12 + 6 to ship
toytech76 is offline   Reply With Quote
Old 01-07-2008, 02:41 PM   #11
Registered User
Personal Sales Rating: (0)
 
Join Date: Dec 2007
Posts: 2
This is a good thread! What about upgrading at the same time? I know that Mr. Alternator and a rewound alternator are not a good way to go, but Alterstart in Texas is selling a 160amp (75amps at idle) with a two year warranty and print out of the bench test for $229. Thoughts?
Noahrob is offline   Reply With Quote
Old 02-15-2010, 07:35 PM   #12
Registered User
Personal Sales Rating: (0)
 
Join Date: Feb 2010
Posts: 12
Help

Help guys I took alternator out had tested it tested good i put new belts on I tigthen everything good Double check twice and still have problem of brake and battary light on but u rev motor over 4000 rpm lights go out turn off start up again they come back on and do it all over again so can anyone help me out it's driving me crazy any idea would help alot
83toy4x4509 is offline   Reply With Quote
Old 02-16-2010, 09:06 PM   #13
Registered User
Personal Sales Rating: (0)
 
Join Date: Feb 2010
Posts: 12
Any ideas anyone
83toy4x4509 is offline   Reply With Quote
Old 02-17-2010, 05:34 AM   #14
Banned
Vendor Sales Rating: (-1)
 
waskillywabbit's Avatar
 
Join Date: Jul 2003
Posts: 0
Alternator is bad or something else is wrong with your charging system.

Ncttora.com/fsm

waskillywabbit is offline   Reply With Quote
Old 02-17-2010, 05:43 AM   #15
Registered User
Personal Sales Rating: (0)
 
Join Date: Feb 2010
Posts: 12
Had it tested could it still be the altenator thow I have no idea what else it could be thow grrrr
83toy4x4509 is offline   Reply With Quote
Old 02-18-2010, 06:17 PM   #16
Registered User
Personal Sales Rating: (0)
 
Join Date: Feb 2010
Posts: 12
I got a new one and still doing same thing grrrr
83toy4x4509 is offline   Reply With Quote
Old 02-23-2010, 01:11 AM   #17
Registered User
Personal Sales Rating: (0)
 
Join Date: Jun 2009
Posts: 12
Hey buddy, If you replaced your alt with a new one and it is still doing it then it sounds like you need to check your connector that plugs into the back of the alt, Mine did the same thing and i wrote it off as being the alternator, after spending $130 on a new one only to find out it was still there i realized that 1 of the wires that goes into the plug that plugs into the alt had pulled out of the plastic plug itself. It was an easy fix but it happened again later on so i ended up putting the wire back in the plug again but this time i used a few zip ties around the wires going into the plug to keep the wires from getting jar'd around during normal engine operation etc...it hasnt let me down yet. So i suggest trying that, examine the plug real good make sure your connections are not packed with corrosion as well. Hope that helps bud...
YoterMoter is offline   Reply With Quote
Old 02-23-2010, 05:48 AM   #18
Registered User
Personal Sales Rating: (0)
 
Join Date: Feb 2010
Posts: 12
Thanks I'm going to try that I'm taking the napa crap one out and making them give me a new one and I'm checking wire everything again so hopefull I can find it wish me luck
83toy4x4509 is offline   Reply With Quote
Old 04-14-2012, 06:55 PM   #19
Registered User
Personal Sales Rating: (0)
 
vanduzerwilliam's Avatar
 
Join Date: Feb 2012
Location: Ventura, California
Posts: 90
www.facebook.com/vanduzerwilliam
I had the same problem with mine, sprayed the plug with electronic cleaner and hit it with a wrench a couple times, and volts came up and works fine now
vanduzerwilliam is offline   Reply With Quote
Old 04-14-2012, 08:33 PM   #20
Contributing Member
Personal Sales Rating: (1)
 
James Woods's Avatar
 
Join Date: Oct 2010
Location: Beav-Town, OR
Posts: 1,579
Wrenches are for bolts and nuts, hammers are for hitting stuff.

Click the image to open in full size.
__________________
1988 Pickup dubbed -Bucket-Build-
Ongoing garage queen project at the moment
Trail Gear 4.7 T-Case gears, Dana 60 front axle, 14 Bolt FF rear axle, All-Pro T-case parking brake,
Dents and Stickers and now with lots more dents.


1998 Toyota 4runner Limited-
4wd, Automatic, 3.4 5vze and Rear E-Locker Daily Driver.

James Woods is offline   Reply With Quote
Old 04-14-2012, 08:33 PM
Yotatech
4WD Truck




Paid Advertisement
Reply

Tags
1991, 22r, 4runner, 84, 91, alternator, battery, brake, break, idiot, light, pickup, pu, toyota, truck

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
84 pickup 22re battery light and brake light on eroc1313 95.5-2004 Tacomas & 96-2002 4Runners 5 12-20-2011 02:38 PM
Lights on HELP.. trans light, charging light, and brake light krash2k77 General Electrical & Lighting Related Topics 3 04-16-2007 06:20 AM
Question about my dad's 94 toy's battery light and brake light staying on?? whitetaco02 86-95 Trucks & 4Runners 20 10-25-2006 06:16 PM
new alternator - battery/brake light on! reef 86-95 Trucks & 4Runners 21 10-19-2006 04:38 PM
A/T light, brake light, & battery light ON!! mdhunter 86-95 Trucks & 4Runners 3 03-13-2006 05:21 AM


All times are GMT -8. The time now is 06:20 PM.


2010 InternetBrands, Inc.