Signs of a bad knock sensor? - YotaTech Forums


Go Back   > >


86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

Signs of a bad knock sensor?

Reply
 
LinkBack Thread Tools Search this Thread
Old 08-04-2008, 08:48 PM   #1
Registered User
Thread Starter
 
Join Date: Jul 2008
Posts: 25
Signs of a bad knock sensor?

So I took my V6 4runner to the dealership because when the replaced my engine they forgot to properly attach a vacuum hose (hose that goes from EVAP purge line to TVV). Well they hooked it up properly, but when I went to pick up my car, it would not start properly. Normally takes only one crank and it starts right up. This time I need three tries before it started.

I drove it out of the dealership and didn't notice anything different until I reached a little higher speed when the check engine light came on. It seemed to sputter too. I stopped at a nearby parking lot and shut down the engine. Waited a couple of minutes then restarted my car. Same problems as before. Took three tries to get it to start. All the failures it was like the car was sputtering and just couldn't start. In fact it shook a bit violently when it failed.

I took it back to the dealership. On the way there I tried to get up to 60 miles per hour but it sputtered and didn't want to go that fast.

I found it odd that after I picked up my car it started to act up. Even with that vacuum hose completely unattached it gave no error codes or check engine light. It ran perfectly fine. Now after they reattach the hose it doesn't want to start or go very well.

Today they told me that it was a bad knock sensor. Can a bad knock sensor cause these problems? I thought a bad knock sensor would only cause detontation to occur not inability to start (with shuddering) and lack of power.

Thanks.

Last edited by 90-4runnerv6; 08-04-2008 at 08:58 PM.
90-4runnerv6 is offline   Reply With Quote
Old 08-05-2008, 11:35 AM   #2
Registered User
 
Dasuprawolf's Avatar
 
Join Date: Jun 2008
Location: Muskegon, MI
Posts: 57
It doesnt sound like a knock sensor at all. When the KS goes bad(rare) or circuit, the ECM will just pull timing to KEEP form detonating, won't cause it to detonate. the only difference you should feel is a little less power. Nothing as far as starting or drivability.
Dasuprawolf is offline   Reply With Quote
Old 08-05-2008, 01:31 PM   #3
Registered User
Thread Starter
 
Join Date: Jul 2008
Posts: 25
Thanks for the responses Dasuprawolf. I talked with the service advisor and he's being a bit vague. He told me that they are still working on the car and I won't have it back until tomorrow. They have had it since Saturday. I know that each technician has other work they have to do, but my understanding was to replace a knock sensor was at most a two hour job. It makes me wonder if they either haven't really gotten to my car yet or there's something else going on with my car and the knock sensor was just an excuse.
90-4runnerv6 is offline   Reply With Quote
Old 08-05-2008, 07:54 PM   #4
Registered User
 
Dasuprawolf's Avatar
 
Join Date: Jun 2008
Location: Muskegon, MI
Posts: 57
I hope their not trying to make it seem like its something completely different so they can try and make you pay for it.

If it is the KS, they probably had to order the sensor and/or harness. But they need to tell you EXACTLY what the problem is/was and they need to be clear as to if this is "customer pay" or not. You should ask what the check engine light code was(52 is the knock sensor itself or the circuit fault) and don't let them make you feel stupid or like you wouldnt understand. Make them PROVE the problem, especially if their wanting you to pay!

Good luck man, the dealership can really try to screw you. Beat them, we'll all try and help you.
Dasuprawolf is offline   Reply With Quote
Old 08-05-2008, 08:17 PM   #5
Registered User
Thread Starter
 
Join Date: Jul 2008
Posts: 25
Yeah, I hear you on that. I hate going to the dealership but damn it was their fault for not putting the engine back together properly.

Oddly enough, the service advisor told me today that they weren't going to charge me for the knock sensor and work they are doing. This really makes me think it was something they did wrong and they are going to fix it without really letting me know what they fixed. I think a knock sensor itself is a bit pricey so them giving me one free is strange.
90-4runnerv6 is offline   Reply With Quote
Old 08-06-2008, 11:13 AM   #6
Registered User
 
Dasuprawolf's Avatar
 
Join Date: Jun 2008
Location: Muskegon, MI
Posts: 57
your right. I'd be willing to bet their fixing something else, something they screwed up. At least their taking care of it, and no charge to you. Make sure they did it right this time!! GL.
Dasuprawolf is offline   Reply With Quote
Old 08-06-2008, 03:40 PM   #7
Registered User
Thread Starter
 
Join Date: Jul 2008
Posts: 25
Got my 4runner back and it's running great. They couldn't give me an invoice on work done because they said their service manager had to do something with it because of the no charge. They did promise to mail it to me. It'll be interesting to read what they did!
90-4runnerv6 is offline   Reply With Quote
Old 08-06-2008, 04:27 PM   #8
Registered User
 
abecedarian's Avatar
 
Join Date: Mar 2008
Location: Temecula Valley, CA
Posts: 12,715
well if it is running good and no charge, then you know it was something they didn't do correctly to begin with.
the service manager is busy trying to bury the problem under the work they did under the original work order.
abecedarian is offline   Reply With Quote
Old 08-06-2008, 07:15 PM   #9
Registered User
 
Dasuprawolf's Avatar
 
Join Date: Jun 2008
Location: Muskegon, MI
Posts: 57
Glad you got it and that it runs great!!
Dasuprawolf is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1985 22r pickup, no spark but engine cranks sandyota 84-85 Trucks & 4Runners 3 05-12-2016 05:04 PM
Code 52 Vanished nonstop Newbie Tech Section 3 07-24-2015 06:29 PM
96 3.4, very high idle no vacuum leaks I can find greenbuggy 3.4 Swaps 4 07-23-2015 11:51 AM
Finding the engine knock keithporter83 Pre 84 Trucks 2 07-18-2015 12:37 PM
ENGINE TROUBLE 3vze please help :( smiley52 86-95 Trucks & 4Runners 8 07-11-2015 05:16 AM


Tags
4runner, 52, 53, 55, 95, bad, check, code, engine, fault, knock, light, problems, running, senser, sensor, signs, sputtering, symptoms

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 04:46 PM.


2010 InternetBrands, Inc.