YotaTech Forums  

Go Back   YotaTech Forums > Toyota SUV & Truck Tech > 86-95 Trucks & 4Runners
Sign in using an external account
Register Forgot Password?
Search


86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

Welcome to Yotatech!
Welcome to Yotatech,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
LinkBack Thread Tools Search this Thread
Old 10-19-2006, 07:26 PM   #1
Registered User
Personal Sales Rating: (0)
 
iruny4wd's Avatar
 
Join Date: Aug 2006
Posts: 269
Power steering gone

Well I was driving today and my power steering suddenly went out. It's been working great up until now. I checked the fluid level and it's all good, looked around for leaks and didn't see any. Did my power steering pump go out or what?

edit: oh and if it's the pump, how much do you guys estimate this costing me to fix if I take it to Toyota?
This ad is not displayed to registered members.
Register your free account today and become a member on Yotatech!
__________________
Alma Airdales
Arkansas Razorbacks

You call me showering with a gun being "paranoid", I call it being prepared.

Last edited by iruny4wd; 10-19-2006 at 07:28 PM.
iruny4wd is offline   Reply With Quote
Old 10-19-2006, 09:10 PM   #2
Registered User
Personal Sales Rating: (0)
 
Join Date: Jun 2006
Location: Mooresville, NC
Posts: 263
Send a message via AIM to Firefightertaco
do u still have a belt on there, it might have broken
__________________
JP
2003 Tacoma TRD
2007 fj
Firefightertaco is offline   Reply With Quote
Old 10-19-2006, 09:13 PM   #3
Contributing Member
Personal Sales Rating: (0)
 
Elton's Avatar
 
Join Date: Jul 2005
Location: Siletz,Oregon
Posts: 12,278
elton hostler
Send a message via AIM to Elton Send a message via MSN to Elton
for a new pump pm strap22
__________________
07 Tundra d-cab limited 5.7L 4x4 was my moms r.i.p 3/19/11
98 4runner SR5 3.4L 5spd 4x4 E-Locker sold 10-2-11
91 4runner SR5 4x4 3.0L 5spd Totaled 5/13/06
97 honda civic lx 4dr ls vtec
Elton is offline   Reply With Quote
Old 10-19-2006, 09:16 PM   #4
Registered User
Personal Sales Rating: (0)
 
iruny4wd's Avatar
 
Join Date: Aug 2006
Posts: 269
Yea the belt is still there, I examined everything and it seemed to be in perfect working order so I'm stumped on what it is that's why I guessed it had to be that pump. Thanks Elton, if I find out for sure that's what it is i'll shoot him a pm.
__________________
Alma Airdales
Arkansas Razorbacks

You call me showering with a gun being "paranoid", I call it being prepared.
iruny4wd is offline   Reply With Quote
Old 10-19-2006, 09:32 PM   #5
Registered User
Personal Sales Rating: (0)
 
harpen123's Avatar
 
Join Date: Feb 2006
Location: Mooresville, NC but college at Auburn, AL
Posts: 422
Send a message via AIM to harpen123
get someone to turn the wheel and watch the pump and see if it does anything. Mine was acting funny and i tightened the belt down and now it works. Just some thoughts but it sounds like if u checked everything else ur pumps probably bad.
harpen123 is offline   Reply With Quote
Old 10-20-2006, 04:18 AM   #6
Registered User
Personal Sales Rating: (0)
 
iruny4wd's Avatar
 
Join Date: Aug 2006
Posts: 269
Quote:
Originally Posted by harpen123 View Post
get someone to turn the wheel and watch the pump and see if it does anything. Mine was acting funny and i tightened the belt down and now it works. Just some thoughts but it sounds like if u checked everything else ur pumps probably bad.
Okay i'll try that today. Thanks.
__________________
Alma Airdales
Arkansas Razorbacks

You call me showering with a gun being "paranoid", I call it being prepared.
iruny4wd is offline   Reply With Quote
Old 10-20-2006, 04:24 AM   #7
Registered User
Personal Sales Rating: (0)
 
Join Date: Sep 2006
Posts: 282
yeah do what harpen advised, usually a pump will give some warning signs like growling, bearing noise, hard to steer, etc..before going out completely.

highway
highway is offline   Reply With Quote
Old 10-20-2006, 05:05 PM   #8
Registered User
Personal Sales Rating: (0)
 
iruny4wd's Avatar
 
Join Date: Aug 2006
Posts: 269
Well on my way to school today the power steering suddenly came back. It's been fine since then. Any ideas on what's going on?
__________________
Alma Airdales
Arkansas Razorbacks

You call me showering with a gun being "paranoid", I call it being prepared.
iruny4wd is offline   Reply With Quote
Old 10-20-2006, 05:32 PM   #9
Registered User
Personal Sales Rating: (0)
 
Join Date: Sep 2006
Posts: 282
my guess would be the power steering belt does not have enough tension or worn out

highway
highway is offline   Reply With Quote
Old 10-20-2006, 05:32 PM
Yotatech
4WD Truck




Paid Advertisement
Reply

Tags
34, 4runner, 97, belt, broken, driving, growl, power, powersteering, ps, pump, steering, suburban, suddenly, tacoma

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No power steering...but i want it. joegee1773 95.5-2004 Tacomas & 96-2002 4Runners 6 07-08-2008 06:33 AM
power steering 89red4x4yota 86-95 Trucks & 4Runners 1 11-21-2006 07:25 PM
Power Steering? slowyota 95.5-2004 Tacomas & 96-2002 4Runners 6 05-19-2004 10:57 AM
power steering help notaco 95.5-2004 Tacomas & 96-2002 4Runners 2 04-04-2004 07:51 PM
More power steering help...? fourunnabilly 95.5-2004 Tacomas & 96-2002 4Runners 2 10-13-2003 08:36 AM


All times are GMT -8. The time now is 09:07 PM.


2010 InternetBrands, Inc.