YotaTech Forums  

Go Back   YotaTech Forums > Toyota SUV & Truck Tech > 86-95 Trucks & 4Runners
Sign in using an external account
Register Forgot Password?
Search


86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

Welcome to Yotatech!
Welcome to Yotatech,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
LinkBack Thread Tools Search this Thread
Old 10-09-2008, 07:02 AM   #1 (permalink)
Registered User
Personal Sales Rating: (0)
 
GorgeRunner's Avatar
 
Join Date: Oct 2008
Location: The Gorge
Posts: 209
Cruise Control Not Working-1995 4Runner

The cruise control on my 1995 4Runner does not work. The dash light comes on but nothing else happens.
Never had cruise control before, any suggestions where I should start trying to solve this problem?
Thanks
This ad is not displayed to registered members.
Register your free account today and become a member on Yotatech!
__________________
WatermanAtWork - Blog - 1990 Pickup - 22RE - 4 speed manual
GorgeRunner is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Old 10-09-2008, 07:18 AM   #2 (permalink)
Contributing Member
Personal Sales Rating: (2)
 
4Crawler's Avatar
 
Join Date: Jun 2002
Location: SF Bay Area, CA
Posts: 10,734
The Factory Service Manual will have a fill section on troubleshooting the cruise control unit. What sort of engine and transmission in the 4Runner? One thing to check is the servo unit under the hood. If it is vacuum operated, make sure there is a vacuum line hooked to it and that there is vacuum present with the engine running. If a manual transmission, check that the clutch switch is adjusted properly.
__________________
1985 Toyota 4Runner SR-5, 22REC engine, dual t-cases, 4.88 gears, dual ARBs, 33x10.50 BFGs or 35x12.50 MTRs
r.c.brown@ieee.org
TruckEditor@tlca.org
Project: 4Crawler
4Crawler OffRoad - YotaTech discount code
Gettin'Off 4WD Club
4Crawler is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Old 10-09-2008, 07:56 AM   #3 (permalink)
Contributing Member
Personal Sales Rating: (0)
 
eric-the-red's Avatar
 
Join Date: Oct 2003
Location: Port Coquitlam, BC
Posts: 2,593
GorgeRunner, if you want a copy of an FSM for a 95 4Runner PM me an email address.
eric-the-red is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Old 10-09-2008, 11:17 AM   #4 (permalink)
Registered User
Personal Sales Rating: (0)
Threadstarter [OP]
 
GorgeRunner's Avatar
 
Join Date: Oct 2008
Location: The Gorge
Posts: 209
Thanks for the tips. It is an automatic, so I'll check that servo unit first. I have a Chiltons manual, it has the diagnostic codes, but I was hoping this might be common issue with a well known fix.
The 4Runner is a bit of a project vehicle and I'm down to the pesky little things like the cruise control, rear window, etc.
__________________
WatermanAtWork - Blog - 1990 Pickup - 22RE - 4 speed manual
GorgeRunner is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Old 06-30-2014, 10:20 PM   #5 (permalink)
Registered User
Personal Sales Rating: (0)
 
justjay's Avatar
 
Join Date: Jun 2014
Posts: 3
Please help! I have a "94 4Runner with a "95 V6. Manual Trans. The cruise control light on the dash comes on when I turn the system on, but when I try to set the speed, the green "CRUISE" light on the dash flashes and wont set a speed. Is this a module failure? I dont have a lot of money and was hoping to fix this myself if I can. Thank you in advance for any suggestions!
justjay is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Old 06-30-2014, 10:38 PM   #6 (permalink)
Registered User
Personal Sales Rating: (0)
 
Join Date: Sep 2007
Location: San Francisco East Bay
Posts: 2,809
What do you think the "Cruise" light flashing means?
http://personal.utulsa.edu/~nathan-b...10cruiseco.pdf
__________________
1994 6cyl 4wd XCab -- all stock
scope103 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Old 07-01-2014, 11:33 PM   #7 (permalink)
Registered User
Personal Sales Rating: (0)
 
justjay's Avatar
 
Join Date: Jun 2014
Posts: 3
Quote:
Originally Posted by scope103 View Post
What do you think the "Cruise" light flashing means?
http://personal.utulsa.edu/~nathan-b...10cruiseco.pdf
The flashing is most likely a trouble code, but since I was driving on the freeway I didnt want to take my eyes off the road long enough to count and time/space the flashes.
7/1/2014 Update- Drove the truck to the shop for other unrelated repair this morning (suspension) and tried the cruise control and it works just fine now. Shop found no stored trouble codes and no electrical issues anywhere other than 1 marker light out. I had found a list of trouble codes online and bookmarked the page to post here, but my laptop dropped the page! If anyone finds the page I would be grateful to find it again so I can print them out for future use!
justjay is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Old 07-02-2014, 05:34 AM   #8 (permalink)
Registered User
Personal Sales Rating: (0)
 
Join Date: Sep 2007
Location: San Francisco East Bay
Posts: 2,809
Quote:
Originally Posted by scope103 View Post
What do you think the "Cruise" light flashing means?
http://personal.utulsa.edu/~nathan-b...10cruiseco.pdf
Quote:
Originally Posted by justjay View Post
...! If anyone finds the page I would be grateful to find it again so I can print them out for future use!
(Why do I even bother ...)
__________________
1994 6cyl 4wd XCab -- all stock
scope103 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Old 07-02-2014, 06:48 AM   #9 (permalink)
Registered User
Personal Sales Rating: (0)
 
Join Date: Sep 2013
Posts: 806
It's okay Scope... some people don't pay enough attention sometime..

justjay, people care to help strangers on these forums, you need to read everyone's post so they aren't wasting their time repeating themselves.

The FSM is very thorough in the cruise control dpt. You should find your answer there. If there is something you don't understand, write it here! Good luck.
__________________
1991 4Runner 4X4 SR5
3.0 3VZ-E _216k miles
Gevo is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Old 07-02-2014, 03:00 PM   #10 (permalink)
Registered User
Personal Sales Rating: (0)
 
justjay's Avatar
 
Join Date: Jun 2014
Posts: 3
**Scope103- Sorry I missed your hint. Sure am hoping it wasn't sarcasm- I sure dont need to feel any more stupid than I already do. There are several links here I cant open. Not sure why, just get error messages. I was hoping for help, not (Why do I even bother...)
**Gevo- I do pay attention, but since I couldn't access anything before GorgeRunner's post, nor open any links I was hoping for a straight answer. There were several things I dont understand, but now thanks to these two replies, I just feel like a dumb blonde. Since I cant seem to keep up with you, I'll step out. Sorry I bothered you.
justjay is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Old 07-02-2014, 04:01 PM   #11 (permalink)
Super Moderator
Personal Sales Rating: (0)
Staff
 
rworegon's Avatar
 
Join Date: Nov 2010
Location: Columbia River Gorge, Oregon...east side
Posts: 3,902
justjay, try opening the link in post #6 above and then look on page BE-61. Can you use the steps shown to get the code to reappear via the blinking cruise light?
__________________
95.5 Tacoma 3.4L Auto, bought with 0.8mi.

FSMs (many missing references as of 2014) TSBs
P/N & diagrams (source for OEM parts on east coast)
PNW OEM Parts source - Titus-Will Toyota, Tacoma, WA

Forum Rules
Know them. Abide by them.
rworegon is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Old 07-02-2014, 04:50 PM   #12 (permalink)
Registered User
Personal Sales Rating: (0)
 
Join Date: Sep 2007
Location: San Francisco East Bay
Posts: 2,809
Quote:
Originally Posted by justjay View Post
**Scope103- Sorry I missed your hint. ...
Okay, don't get too broke up about it. Don't forget that, for the most part, we're all mostly anonymous.

If you've got trouble opening links, say that. If you can't find a referenced page, then say that.

We're all trying to help (and you will be too, soon enough).
__________________
1994 6cyl 4wd XCab -- all stock
scope103 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Old 07-02-2014, 04:50 PM
Yotatech
4WD Truck




Paid Advertisement
Reply

Tags
1987, 1995, 2000, 4runner, control, cruise, line, lines, problem, quit, tacoma, toyota, vaccum, vacuum, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cruise control not working jrock 95.5-2004 Tacomas & 96-2002 4Runners 1 09-02-2008 10:17 AM
Cruise control not working... bigpest88 86-95 Trucks & 4Runners 4 11-07-2006 06:54 PM
cruise control not working...clutch bushing? northfacer581 95.5-2004 Tacomas & 96-2002 4Runners 5 11-25-2005 02:12 PM
Highlander Blinkers and Cruise Control not working JBHaywood 95.5-2004 Tacomas & 96-2002 4Runners 3 02-25-2005 10:48 AM
1995 lc cruise control problems fastv6 Early Land Cruisers 1 06-26-2004 02:27 PM


All times are GMT -8. The time now is 04:16 PM.


2010 InternetBrands, Inc.

Search Engine Friendly URLs by vBSEO 3.5.2