94 4runner solenoid problems - YotaTech Forums
YotaTech Forums  

Go Back   YotaTech Forums > Toyota SUV & Truck Tech > 86-95 Trucks & 4Runners

86-95 Trucks & 4Runners 2nd/3rd gen pickups, and 1st/2nd gen 4Runners with IFS

94 4runner solenoid problems

LinkBack Thread Tools Search this Thread
Old 12-07-2011, 09:22 AM   #1
Registered User
Personal Sales Rating: (0)
Join Date: Dec 2011
Posts: 1
94 4runner solenoid problems

I've read on here about other people's problems too, but I'm thinking of doing the replacement myself and need some help.

Symptoms: From dead stop care barely moves, I have to put it up to about 2500 RPMs just to get going. (Guessing I'm starting in 3rd gear or something). The OD Off light is blinking of course. I drove the car from Denver to Greeley for 45 minutes without a single issue, started it up the next time and it hardly moves in drive. I can use my auto trans as a manual and start it in low then it accelerates fine.

Solutions?: I've heard it's the shift solenoid on the valve body. Does anyone know how hard this is to replace? I know I need to drain the fluid and drop the pan, but is there a lot else to do? I worked on cars for 4 years in high school so I know the basics. Just trying to see if it will be dangerous to do it myself.

Any information you have would be awesome. Thanks.

MTP944runner is offline   Reply With Quote
Old 12-08-2011, 11:19 AM   #2
Registered User
Personal Sales Rating: (0)
Vengeanceent's Avatar
Join Date: Nov 2011
Posts: 3
I'm currently having the same problem with my 92.

I just bought the 4Runner with a bad motor after it was sitting for two years. I was unable to get any history on the trans or rest of the truck.

I put a motor in it and have been driving it for two weeks now.

The trans is doing the exact same thing 90 percent of the time. I get lucky on occasion and it shifts properly.

Put it in drive and it goes right into 3rd. Put it in 1st and manualy shift it and it shifts from 1 to 3 skipping 2nd. Also if on the highway while in OD it seems to unlock-lock the converter a lot while driving at speed.

Haven't had a chance to scan yet but I'm sure it's throwing codes.


Support Those That Support You!


92 4Runner
3.0 Auto
Vengeanceent is offline   Reply With Quote
Old 02-06-2012, 04:27 PM   #3
Registered User
Personal Sales Rating: (0)
Join Date: Feb 2012
Posts: 14
I am having same problem with 94 4runner v6
Do I need shift solenoid #1
I already tried replacing speed control sensor on the trans but no response.
my speedo is out as well but tach works
mr_4runner is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cold Start Issues Yota.Jay 86-95 Trucks & 4Runners 3 07-23-2015 09:08 PM
4runner stalling in gear... Do this again please Jnkml 95.5-2004 Tacomas & 96-2002 4Runners 3 07-06-2015 02:20 PM
22rte troubles karbin Newbie Tech Section 1 07-06-2015 12:37 AM
New AC Questions (Not the same old ones) HRDC0R19 86-95 Trucks & 4Runners 3 07-05-2015 07:43 PM
Has anyone else ever had this problem? Badger62811 Off Topic Talk 2 07-05-2015 10:17 AM

30, 4runner, 4runners, 94, barely, loud, moves, overdrive, problems, replace, solenoid, solenoids, starter, starting, transmission, whine

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -8. The time now is 04:49 PM.

2010 InternetBrands, Inc.